aboutsummaryrefslogtreecommitdiff
path: root/net/socks5/Makefile
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>1997-12-24 18:42:25 +0000
committerWarner Losh <imp@FreeBSD.org>1997-12-24 18:42:25 +0000
commitc8f9434dbe559a0cb3895090d917f94de295dae4 (patch)
tree100b04d66589b40e257a671a4b910e327843017f /net/socks5/Makefile
parent7b1c34eeb16a25086f9f9ad4e028df562efb416d (diff)
downloadports-c8f9434dbe559a0cb3895090d917f94de295dae4.tar.gz
ports-c8f9434dbe559a0cb3895090d917f94de295dae4.zip
Notes
Diffstat (limited to 'net/socks5/Makefile')
-rw-r--r--net/socks5/Makefile30
1 files changed, 20 insertions, 10 deletions
diff --git a/net/socks5/Makefile b/net/socks5/Makefile
index 8a0dccd91085..f2bf4e7287ac 100644
--- a/net/socks5/Makefile
+++ b/net/socks5/Makefile
@@ -1,19 +1,19 @@
# New ports collection makefile for: socks5
-# Version required: beta-0.17.2-exportable
+# Version required: v1.0r3
# Date created: 24 Apr 1996
# Whom: pst
#
-# $Id: Makefile,v 1.13 1997/08/15 08:32:52 obrien Exp $
+# $Id: Makefile,v 1.14 1997/08/28 06:49:06 obrien Exp $
#
-DISTNAME= socks5-v1_0r2_tar
-PKGNAME= socks5-1.0.2
+DISTNAME= socks5-v1.0r3
+PKGNAME= socks5-1.0.3
CATEGORIES= net security
MASTER_SITES= ftp://ftp.astec.co.jp/pub/security/socks/ \
ftp://ftp.ualg.pt/Linux/net/proxies/
-EXTRACT_SUFX= .gz
+EXTRACT_SUFX= .tar.gz
-MAINTAINER= ambrisko@ambrisko.roble.com
+MAINTAINER= imp@freebsd.org
NO_CDROM= "NEC has a funky license for this software"
RESTRICTED= "no commercial use"
@@ -26,9 +26,8 @@ RESTRICTED= "no commercial use"
# --with-syslog-facility=LOG_AUTH \
# --with-passwd
-WRKSRC= ${WRKDIR}/socks5-v1.0r2
+WRKSRC= ${WRKDIR}/socks5-v1.0r3
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS=-lcrypt
CONFIGURE_ARGS= --with-libconffile=${PREFIX}/etc/libsocks5.conf \
--with-srvconffile=${PREFIX}/etc/socks5.conf \
--with-srvpidfile=/var/run/socks5.pid \
@@ -37,7 +36,18 @@ CONFIGURE_ARGS= --with-libconffile=${PREFIX}/etc/libsocks5.conf \
MAN1= runsocks.1 socks5.1 stopsocks.1 socks5_clients.1
MAN5= libsocks5.conf.5 socks5.conf.5
+.include <bsd.port.mk>
+
+# the following need to be included after bsd.port.mk, since OPSYS
+# ARCH are defined in bsd.port.mk
+
+.if ${OPSYS} == "FreeBSD"
+CONFIGURE_ENV= LIBS=-lcrypt
+.endif
+
+# OpenBSD/arc doesn't seem to have a working ldconfig
+
+.if ${OPSYS} != "OpenBSD" || ${ARCH} != "arc"
post-install:
ldconfig -m ${PREFIX}/lib
-
-.include <bsd.port.mk>
+.endif