aboutsummaryrefslogtreecommitdiff
path: root/net/spread
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 06:21:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 06:21:20 +0000
commit12f56a38a7178dc6335f27c4ce0a2d6336762ba2 (patch)
tree88dd7135fa5b41bfb4f596c8373ecc6a242577ab /net/spread
parent0905610dccf2c73d47a93e738266ed90de57afd9 (diff)
downloadports-12f56a38a7178dc6335f27c4ce0a2d6336762ba2.tar.gz
ports-12f56a38a7178dc6335f27c4ce0a2d6336762ba2.zip
Notes
Diffstat (limited to 'net/spread')
-rw-r--r--net/spread/Makefile42
-rw-r--r--net/spread/distinfo2
-rw-r--r--net/spread/files/patch-Makefile.in31
-rw-r--r--net/spread/files/patch-auth-ip.c12
-rw-r--r--net/spread/files/patch-auth-pword.c12
-rw-r--r--net/spread/files/patch-configuration.c12
-rw-r--r--net/spread/files/patch-docs::spmonitor.118
-rw-r--r--net/spread/files/patch-docs::spread.118
-rw-r--r--net/spread/files/patch-perl::Spread::Spread.pm13
-rw-r--r--net/spread/files/patch-sample.spread.conf20
-rw-r--r--net/spread/files/patch-session.c11
-rw-r--r--net/spread/files/patch-sp.c11
-rw-r--r--net/spread/files/patch-spread.c22
-rw-r--r--net/spread/files/spread.sh62
-rw-r--r--net/spread/pkg-plist11
15 files changed, 222 insertions, 75 deletions
diff --git a/net/spread/Makefile b/net/spread/Makefile
index fada5f96f318..b3528f4ae269 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: spread
+# New ports collection makefile for: spread
# Date created: 11 June 2001
# Whom: Anders Nordby <anders@fix.no>
#
@@ -6,15 +6,15 @@
#
PORTNAME= spread
-PORTVERSION= 3.17.0
-PORTREVISION= 1
+PORTVERSION= 3.17.1
CATEGORIES= net perl5
-MASTER_SITES= http://www.roughtrade.net/distfiles/
+MASTER_SITES= http://www.cnds.jhu.edu/download/noformdown/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= joshua@roughtrade.net
COMMENT= The Spread Group Communication System, a network toolkit
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
MAN1= spflooder.1 spmonitor.1 spread.1 sptuser.1 spuser.1
@@ -24,35 +24,57 @@ MAN3= libsp.3 SP_connect.3 SP_disconnect.3 SP_equal_group_ids.3 SP_error.3 \
SP_scat_multicast.3 SP_scat_receive.3
USE_PERL5= yes
+USE_RC_SUBR= yes
INSTALLS_SHLIB= yes
PKGMESSAGE= ${WRKSRC}/license.txt
MAKE_ARGS+= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}
+.if !defined(NOPORTDOCS)
+PORTDOCS+= Readme.txt LICENSE
+.endif
+
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
.include <bsd.port.pre.mk>
+# bsd.port.mk doesn't allow us to use GNU_CONFIGURE and PERL_CONFIGURE together.
+
+PERL_CONFIGURE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}" \
+ INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib"
+
+_MANPAGES+= ${PREFIX}/lib/perl5/${PERL_VERSION}/man/man3/Spread.3
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/docs/spread.1 ${WRKSRC}/docs/spmonitor.1
+
post-build:
- (cd ${WRKSRC}/perl/Spread; ${PERL} Makefile.PL; ${MAKE})
+ @cd ${WRKSRC}/perl/Spread && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./Makefile.PL ${PERL_CONFIGURE_ARGS}
+ @cd ${WRKSRC}/perl/Spread && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+ @cd ${WRKSRC}/perl/Spread && ${MAKE}
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/spread.sh > ${WRKDIR}/spread.sh
pre-install:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/spread.sh ${PREFIX}/etc/rc.d/spread.sh.sample
+ ${INSTALL_SCRIPT} ${WRKDIR}/spread.sh ${PREFIX}/etc/rc.d/spread.sh
${INSTALL_DATA} ${WRKSRC}/sp.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/sp_func.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/sp_events.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/sample.spread.conf ${PREFIX}/etc/spread.conf.sample
${INSTALL_DATA} ${WRKSRC}/sample.spread.access_ip ${PREFIX}/etc/spread.access_ip.sample
(cd ${WRKSRC}/perl/Spread && ${MAKE} install)
- ${GZIP_CMD} ${GZIP} ${LOCALBASE}/lib/perl5/${PERL_VERSION}/man/man3/Spread.3
.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+ ${INSTALL} -d -o root -g wheel -m 0755 ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/license.txt ${DOCSDIR}/LICENSE
- ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}/perl
- ${INSTALL_DATA} ${WRKSRC}/perl/Spread/README ${DOCSDIR}/perl
- ${INSTALL_DATA} ${WRKSRC}/perl/Spread/test.pl ${DOCSDIR}/perl
+ ${INSTALL_SCRIPT} ${WRKSRC}/perl/Spread/test.pl ${EXAMPLESDIR}
.endif
@${CAT} ${PKGMESSAGE}
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/net/spread/distinfo b/net/spread/distinfo
index 7d7007f4bf86..46ba65c5312c 100644
--- a/net/spread/distinfo
+++ b/net/spread/distinfo
@@ -1 +1 @@
-MD5 (spread-src-3.17.0.tar.gz) = 77d927584e66cb09472f5e9a1613e274
+MD5 (spread-src-3.17.1.tar.gz) = b423da7012f0237a877b604ebd80cfc4
diff --git a/net/spread/files/patch-Makefile.in b/net/spread/files/patch-Makefile.in
index bf659c926b1c..32dd8494442e 100644
--- a/net/spread/files/patch-Makefile.in
+++ b/net/spread/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Sat Sep 28 08:38:59 2002
-+++ Makefile.in Wed Nov 6 07:41:33 2002
-@@ -25,7 +25,7 @@
+--- Makefile.in Wed Jun 18 05:00:10 2003
++++ Makefile.in Tue Aug 5 21:26:23 2003
+@@ -26,7 +26,7 @@
#Rules: major -- inc for incompatible change
# : minor -- inc for bugfix or forward compatible change
@@ -9,7 +9,7 @@
PATHS=
-@@ -34,7 +34,7 @@
+@@ -35,7 +35,7 @@
CFLAGS=@CFLAGS@
CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
LDFLAGS=@LDFLAGS@
@@ -18,7 +18,7 @@
THLDFLAGS=@THLDFLAGS@
THLIBS=@THLIBS@
AR=@AR@
-@@ -51,8 +51,10 @@
+@@ -52,8 +52,10 @@
PERL=@PERL@
ENT=@ENT@
EXEEXT=@EXEEXT@
@@ -30,9 +30,9 @@
LIBSP_OBJS= alarm.o events.o memory.o sp.o
-@@ -123,8 +125,11 @@
+@@ -124,8 +126,11 @@
$(INSTALL) -m 0755 libspread.$(LIBVERSION).dylib $(DESTDIR)$(libdir)/libspread.$(LIBVERSION).dylib
- (cd $(DESTDIR)$(libdir); $(SOFTLINK) libspread.$(LIBVERSION).dylib libspread.dylib)
+ (cd $(DESTDIR)$(libdir); $(SOFTLINK) -f libspread.$(LIBVERSION).dylib libspread.dylib)
-libspread.so: $(LIBSP_SHOBJS)
- $(SHLD) -o $@ $(LIBSP_SHOBJS) $(SHLDFLAGS) $(SHLIBS)
@@ -44,9 +44,9 @@
install-libspread.so: libspread.so
$(INSTALL) -m 0755 libspread.so $(DESTDIR)$(libdir)/libspread.so.$(LIBVERSION)
-@@ -142,8 +147,11 @@
+@@ -143,8 +148,11 @@
$(INSTALL) -m 0755 libtspread.$(LIBVERSION).dylib $(DESTDIR)$(libdir)/libtspread.$(LIBVERSION).dylib
- (cd $(DESTDIR)$(libdir); $(SOFTLINK) libtspread.$(LIBVERSION).dylib libtspread.dylib)
+ (cd $(DESTDIR)$(libdir); $(SOFTLINK) -f libtspread.$(LIBVERSION).dylib libtspread.dylib)
-libtspread.so: $(LIBTSP_SHOBJS)
- $(SHLD) -o $@ $(LIBTSP_SHOBJS) $(SHLDFLAGS) $(SHLIBS) $(THLIBS)
@@ -58,7 +58,7 @@
install-libtspread.so: libtspread.so
$(INSTALL) -m 0755 libtspread.so $(DESTDIR)$(libdir)/libtspread.so.$(LIBVERSION)
-@@ -152,17 +160,17 @@
+@@ -153,17 +161,17 @@
spread$(EXEEXT): $(SPREADOBJS)
$(LD) -o $@ $(SPREADOBJS) $(LDFLAGS) $(LIBS)
@@ -82,7 +82,16 @@
spsimple_user$(EXEEXT): simple_user.o libspread.a
$(LD) -o $@ simple_user.o $(LDFLAGS) libspread.a $(LIBS)
-@@ -234,11 +242,6 @@
+@@ -192,7 +200,7 @@
+ fi
+
+ clean:
+- rm -f *.lo *.tlo *.to *.o *.a *.dylib $(TARGETS) spsimple_user
++ rm -f *.lo *.tlo *.to *.o *.a *.dylib $(TARGETS) spsimple_user *.so.$(LIBVERSION)
+ rm -f config.cache config.log docs/*.out core
+ rm -rf autom4te.cache
+
+@@ -247,11 +255,6 @@
done
if [ ! -d $(DESTDIR)$(sysconfdir) ]; then \
$(buildtoolsdir)/mkinstalldirs $(DESTDIR)$(sysconfdir); \
diff --git a/net/spread/files/patch-auth-ip.c b/net/spread/files/patch-auth-ip.c
index 4c49b4278833..278edc27a50c 100644
--- a/net/spread/files/patch-auth-ip.c
+++ b/net/spread/files/patch-auth-ip.c
@@ -1,8 +1,12 @@
--- auth-ip.c Sun Sep 22 12:56:52 2002
-+++ auth-ip.c Wed Nov 6 02:39:28 2002
-@@ -94,8 +94,8 @@
- if (NULL != (fp = fopen("./spread.access_ip", "r")) )
- Alarm( PRINT, "ip_init: using file: ./spread.access_ip\n");
++++ auth-ip.c Tue Aug 5 21:27:40 2003
+@@ -90,12 +90,9 @@
+ /* load spread.access_ip file */
+ if (NULL != (fp = fopen(file_name,"r")) )
+ Alarm( PRINT, "ip_init: using file: %s\n", file_name);
+- if (fp == NULL)
+- if (NULL != (fp = fopen("./spread.access_ip", "r")) )
+- Alarm( PRINT, "ip_init: using file: ./spread.access_ip\n");
if (fp == NULL)
- if (NULL != (fp = fopen("/etc/spread.access_ip", "r")) )
- Alarm( PRINT, "ip_init: using file: /etc/spread.access_ip\n");
diff --git a/net/spread/files/patch-auth-pword.c b/net/spread/files/patch-auth-pword.c
index 09a8e44cf372..c0bae4a7b0cf 100644
--- a/net/spread/files/patch-auth-pword.c
+++ b/net/spread/files/patch-auth-pword.c
@@ -1,8 +1,12 @@
--- auth-pword.c Sun Sep 22 12:56:52 2002
-+++ auth-pword.c Wed Nov 6 02:40:23 2002
-@@ -122,8 +122,8 @@
- if (NULL != (fp = fopen("./spread.access_pword", "r")) )
- Alarm( PRINT, "pword_init: using file: ./spread.access_pword\n");
++++ auth-pword.c Tue Aug 5 21:28:50 2003
+@@ -118,12 +118,9 @@
+ /* load spread.access_ip file */
+ if (NULL != (fp = fopen(file_name,"r")) )
+ Alarm( PRINT, "pword_init: using file: %s\n", file_name);
+- if (fp == NULL)
+- if (NULL != (fp = fopen("./spread.access_pword", "r")) )
+- Alarm( PRINT, "pword_init: using file: ./spread.access_pword\n");
if (fp == NULL)
- if (NULL != (fp = fopen("/etc/spread.access_pword", "r")) )
- Alarm( PRINT, "pword_init: using file: /etc/spread.access_pword\n");
diff --git a/net/spread/files/patch-configuration.c b/net/spread/files/patch-configuration.c
new file mode 100644
index 000000000000..b571a339aba8
--- /dev/null
+++ b/net/spread/files/patch-configuration.c
@@ -0,0 +1,12 @@
+--- configuration.c Sun Sep 22 12:56:52 2002
++++ configuration.c Tue Aug 5 21:24:19 2003
+@@ -128,9 +128,6 @@
+
+ if (NULL != (yyin = fopen(file_name,"r")) )
+ Alarm( PRINT, "Conf_init: using file: %s\n", file_name);
+- if (yyin == NULL)
+- if (NULL != (yyin = fopen("./spread.conf", "r")) )
+- Alarm( PRINT, "Conf_init: using file: ./spread.conf\n");
+ if (yyin == NULL)
+ if (NULL != (yyin = fopen(configfile_location, "r")) )
+ Alarm( PRINT, "Conf_init: using file: %s\n", configfile_location);
diff --git a/net/spread/files/patch-docs::spmonitor.1 b/net/spread/files/patch-docs::spmonitor.1
new file mode 100644
index 000000000000..982d5bb32913
--- /dev/null
+++ b/net/spread/files/patch-docs::spmonitor.1
@@ -0,0 +1,18 @@
+--- docs/spmonitor.1 Thu Dec 13 02:01:49 2001
++++ docs/spmonitor.1 Mon Dec 8 00:00:34 2003
+@@ -27,13 +27,11 @@
+ Use an alternate configuration file
+ .I config-file
+ instead of
+-.IR ./spread.conf .
++.IR /etc/spread.conf .
+ .SH FILES
+-.I ./spread.conf
++.I /etc/spread.conf
+ .RS
+ The default config file location.
+-.I /etc/spread.conf
+-is also searched if a local file is not found.
+ .SH BUGS
+ The spmonitor works by sending UDP packets to the Spread daemon, so if network
+ losses occur, commands or status reports can be lost. It can also lose reports
diff --git a/net/spread/files/patch-docs::spread.1 b/net/spread/files/patch-docs::spread.1
new file mode 100644
index 000000000000..6dca20e2b73d
--- /dev/null
+++ b/net/spread/files/patch-docs::spread.1
@@ -0,0 +1,18 @@
+--- docs/spread.1 Thu Dec 13 02:03:19 2001
++++ docs/spread.1 Mon Dec 8 00:00:20 2003
+@@ -20,13 +20,11 @@
+ Use an alternate configuration file
+ .I config-file
+ instead of
+-.IR ./spread.conf .
++.IR /etc/spread.conf .
+ .SH FILES
+-.I ./spread.conf
++.I /etc/spread.conf
+ .RS
+ The default config file location.
+-.I /etc/spread.conf
+-is also searched if a local file is not found.
+ .SH DIAGNOSTICS
+ The daemon will output some startup information to stdout
+ and any severe errors will also be output to stdout. Redirecting
diff --git a/net/spread/files/patch-perl::Spread::Spread.pm b/net/spread/files/patch-perl::Spread::Spread.pm
new file mode 100644
index 000000000000..a753b18f6b45
--- /dev/null
+++ b/net/spread/files/patch-perl::Spread::Spread.pm
@@ -0,0 +1,13 @@
+--- perl/Spread/Spread.pm Mon Dec 8 21:12:18 2003
++++ perl/Spread/Spread.pm Mon Dec 8 21:15:44 2003
+@@ -177,8 +177,8 @@
+
+ # Connect
+ my($mailbox, $private_group) = Spread::connect(
+- spread_name => '4444@host.domain.com',
+- private_name => 'mrcool',
++ { spread_name => '4803@host.domain.com',
++ private_name => 'mrcool', }
+ );
+
+ # Join and leave groups
diff --git a/net/spread/files/patch-sample.spread.conf b/net/spread/files/patch-sample.spread.conf
new file mode 100644
index 000000000000..1926dea8116c
--- /dev/null
+++ b/net/spread/files/patch-sample.spread.conf
@@ -0,0 +1,20 @@
+--- sample.spread.conf Mon Dec 8 01:26:39 2003
++++ sample.spread.conf Mon Dec 8 01:26:53 2003
+@@ -50,7 +50,7 @@
+ # cause the daemons to log to "spreadlog_machine1.mydomain.com.log" and
+ # "spreadlog_machine2.mydomain.com.log" respectively.
+
+-#EventLogFile = testlog.out
++EventLogFile = /var/log/spread.log
+
+ #Set whether to add a timestamp in front of all logged events or not.
+ # Default is no timestamps. Default format is "[%a %d %b %Y %H:%M:%S]".
+@@ -62,7 +62,7 @@
+
+ #EventTimeStamp
+ # or
+-#EventTimeStamp = "[%a %d %b %Y %H:%M:%S]"
++EventTimeStamp = "[%a %d %b %Y %H:%M:%S]"
+
+ #Set whether to allow dangerous monitor commands
+ # like "partition, flow_control, or kill"
diff --git a/net/spread/files/patch-session.c b/net/spread/files/patch-session.c
new file mode 100644
index 000000000000..c33d5523da84
--- /dev/null
+++ b/net/spread/files/patch-session.c
@@ -0,0 +1,11 @@
+--- session.c Tue Aug 5 21:35:52 2003
++++ session.c Tue Aug 5 21:31:30 2003
+@@ -406,7 +406,7 @@
+ Alarm( EXIT, "Sess_init: UNIX sock error\n" );
+
+ unix_addr.sun_family = AF_UNIX;
+- sprintf( name, "/tmp/%d",My.port );
++ sprintf( name, "%s/spread.sock", _PATH_SPREAD_PIDDIR );
+ strcpy( unix_addr.sun_path, name );
+ unlink( name );
+
diff --git a/net/spread/files/patch-sp.c b/net/spread/files/patch-sp.c
new file mode 100644
index 000000000000..bf1b2a7b8851
--- /dev/null
+++ b/net/spread/files/patch-sp.c
@@ -0,0 +1,11 @@
+--- sp.c Tue Aug 5 21:35:28 2003
++++ sp.c Tue Aug 5 21:24:19 2003
+@@ -551,7 +551,7 @@
+ Alarm( SESSION, "SP_connect: set sndbuf/rcvbuf to %d\n", 1024*(i-5) );
+
+ unix_addr.sun_family = AF_UNIX;
+- sprintf( unix_addr.sun_path, "/tmp/%d", port );
++ sprintf( unix_addr.sun_path, "%s/spread.sock", _PATH_SPREAD_PIDDIR );
+ while( ((ret = connect( s, (struct sockaddr *)&unix_addr, sizeof(unix_addr) )) == -1)
+ && ((sock_errno == EINTR) || (sock_errno == EAGAIN) || (sock_errno == EWOULDBLOCK)) )
+ {
diff --git a/net/spread/files/patch-spread.c b/net/spread/files/patch-spread.c
index 1ab2708b1f90..0de2385206a1 100644
--- a/net/spread/files/patch-spread.c
+++ b/net/spread/files/patch-spread.c
@@ -1,6 +1,15 @@
---- spread.c Sun Nov 10 00:17:59 2002
-+++ spread.c Sun Nov 10 00:18:42 2002
-@@ -65,6 +65,7 @@
+--- spread.c Thu Jun 19 00:31:23 2003
++++ spread.c Mon Dec 8 20:55:41 2003
+@@ -48,6 +48,8 @@
+ #include <pwd.h>
+ #include <unistd.h>
+ #include <sys/types.h>
++#include <errno.h>
++#include <stdlib.h>
+ #endif
+
+ #ifdef ARCH_PC_WIN95
+@@ -65,6 +67,7 @@
static void Invalid_privilege_decrease(char *user, char *group);
static void Usage(int argc, char *argv[]);
@@ -8,16 +17,19 @@
/* auth-null.c: */
void null_init(void);
-@@ -144,6 +145,8 @@
+@@ -144,6 +147,11 @@
#endif /* ARCH_PC_WIN95 */
++ if (daemon(0,0) == -1)
++ Alarm( EXIT, "Spread: couldn't daemonise: %d", strerror(errno) );
++
+ writepidfile();
+
/* initialize each valid authentication protocol */
null_init();
ip_init();
-@@ -193,6 +196,20 @@
+@@ -193,6 +201,20 @@
E_handle_events();
return 0;
diff --git a/net/spread/files/spread.sh b/net/spread/files/spread.sh
index ebeb5adf697f..adc11250484f 100644
--- a/net/spread/files/spread.sh
+++ b/net/spread/files/spread.sh
@@ -1,36 +1,34 @@
#!/bin/sh
#
# $FreeBSD$
+#
+
+# PROVIDE: spread
+# REQUIRE: LOGIN
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable spread:
+#
+#spread_enable="YES"
+#
+# See spread(1) for flags
+#
+
+. %%RC_SUBR%%
+
+name=spread
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/spread"
+command_args=""
+pidfile=/var/run/${name}.pid
+required_files=%%PREFIX%%/etc/${name}.conf
+
+# set defaults
+
+spread_enable=${spread_enable:-"NO"}
+spread_flags=${spread_flags:-""}
-if ! prefix=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the prefix" >&2
- exit 1
-fi
-spread=${prefix}/sbin/spread
-pidfile=/var/run/spread.pid
-out=/var/log/spread.out
-daemon=/usr/sbin/daemon
-
-case "$1" in
-start)
- if [ -x ${spread} ]; then
- echo -n ' spread'
- ${daemon} -c ${spread} >${out} 2>&1 <&-
- fi
- ;;
-stop)
- if [ -f ${pidfile} ]; then
- kill `cat ${pidfile}`
- echo -n ' spread'
- rm ${pidfile}
- else
- echo ' spread: not running'
- fi
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- exit 64
- ;;
-esac
-
-exit 0
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/spread/pkg-plist b/net/spread/pkg-plist
index 9401c691bfc1..ace659ce5f7d 100644
--- a/net/spread/pkg-plist
+++ b/net/spread/pkg-plist
@@ -2,7 +2,7 @@ bin/spflooder
bin/spmonitor
bin/sptuser
bin/spuser
-etc/rc.d/spread.sh.sample
+etc/rc.d/spread.sh
etc/spread.access_ip.sample
etc/spread.conf.sample
include/sp.h
@@ -14,18 +14,13 @@ lib/libspread.so.1
lib/libtspread.a
lib/libtspread.so
lib/libtspread.so.1
-lib/perl5/%%PERL_VERSION%%/man/man3/Spread.3.gz
%%SITE_PERL%%/%%PERL_ARCH%%/Spread.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/Spread.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/Spread.so
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/autosplit.ix
sbin/spread
-%%PORTDOCS%%share/doc/spread/perl/README
-%%PORTDOCS%%share/doc/spread/perl/test.pl
-%%PORTDOCS%%share/doc/spread/LICENSE
-%%PORTDOCS%%share/doc/spread/Readme.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/test.pl
@unexec rmdir /var/run/spread 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread 2>/dev/null || true
-%%PORTDOCS%%@dirrm share/doc/spread/perl
-%%PORTDOCS%%@dirrm share/doc/spread
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%