aboutsummaryrefslogtreecommitdiff
path: root/net/sshping
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-03-18 15:11:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-03-18 15:11:09 +0000
commit542e4bff5d6fe40724c6615861ce5cac1b3cf7a7 (patch)
treeb4f0e417ba2231fa7db0ff55c0276e05690c9d25 /net/sshping
parent606b871f73a997d34649da3ff8d4a70fbbd36386 (diff)
downloadports-542e4bff5d6fe40724c6615861ce5cac1b3cf7a7.tar.gz
ports-542e4bff5d6fe40724c6615861ce5cac1b3cf7a7.zip
- Use cmake and get rid of own do-build/do-install target
- Adjust package list according to cmake's man category preference - Sort USES - Adjust manpage section during build - Bump PORTREVISION due to package list change
Notes
Notes: svn path=/head/; revision=464921
Diffstat (limited to 'net/sshping')
-rw-r--r--net/sshping/Makefile17
-rw-r--r--net/sshping/files/patch-CMakeLists.txt20
2 files changed, 23 insertions, 14 deletions
diff --git a/net/sshping/Makefile b/net/sshping/Makefile
index b934f2cf8659..21d0b82ad584 100644
--- a/net/sshping/Makefile
+++ b/net/sshping/Makefile
@@ -4,6 +4,7 @@
PORTNAME= sshping
PORTVERSION= 0.1.3
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= net
MAINTAINER= ehaupt@FreeBSD.org
@@ -14,24 +15,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libssh.so:security/libssh
-USES= localbase:ldflags perl5
+USES= cmake localbase:ldflags perl5
USE_GITHUB= yes
USE_PERL5= build
GH_ACCOUNT= spook
-LDFLAGS+= -lssh
-
-PLIST_FILES= bin/sshping man/man1/sshping.1.gz
-
-do-build:
- ${CXX} ${CXXFLAGS} ${LDFLAGS} -I ${WRKSRC}/ext \
- ${WRKSRC}/src/sshping.cxx -o ${WRKSRC}/bin/sshping
- @pod2man ${WRKSRC}/doc/${PORTNAME}.pod ${WRKSRC}/doc/${PORTNAME}.1
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 \
- ${STAGEDIR}${MANPREFIX}/man/man1
+PLIST_FILES= bin/sshping man/man8/sshping.8.gz
.include <bsd.port.mk>
diff --git a/net/sshping/files/patch-CMakeLists.txt b/net/sshping/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..4fe19d318a18
--- /dev/null
+++ b/net/sshping/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2018-03-15 21:50:52 UTC
++++ CMakeLists.txt
+@@ -5,7 +5,7 @@ cmake_minimum_required(VERSION 2.8)
+ #find_package(libssh)
+
+ # Build the sshping binary
+-set(CMAKE_CXX_FLAGS "-I ../ext/ -Wall")
++set(CMAKE_CXX_FLAGS "-I ${CMAKE_CURRENT_SOURCE_DIR}/ext/ -Wall")
+ add_executable(${PROJECT_NAME} src/sshping.cxx)
+ target_link_libraries(${PROJECT_NAME} ssh)
+ install(TARGETS ${PROJECT_NAME} DESTINATION bin CONFIGURATIONS Release)
+@@ -16,7 +16,7 @@ if (P2M)
+ message(STATUS "pod2man found, use the 'man' target to build")
+ endif (P2M)
+ set(DOC_DIR ${CMAKE_SOURCE_DIR}/doc)
+-set(P2M_OPTS -c "ssh-based ping test utility" -d 2018-03-13 -r v0.1.3)
++set(P2M_OPTS --section=8 -c "ssh-based ping test utility" -d 2018-03-13 -r v0.1.3)
+ set(MAN_SRC ${DOC_DIR}/sshping.pod)
+ set(MAN_TGT ${DOC_DIR}/sshping.8)
+ add_custom_command(