aboutsummaryrefslogtreecommitdiff
path: root/net/svnup
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2017-06-15 20:55:54 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2017-06-15 20:55:54 +0000
commitfbadfe2f44616233630dae2866c719c7c2d5fc6f (patch)
treeb49509dee94d7349db36e07029325d0adf3f30fe /net/svnup
parent53eb9de1a853d78e0f17cff0ceef49f3ea8ff425 (diff)
Fix "400 Bad Request" with latest incarnation of project's svn
servers. Looks like it got somewhat stricter on the acceptable syntax. Bump PORTREVISION. Submitted by: John Mehr (maintainer)
Notes
Notes: svn path=/head/; revision=443640
Diffstat (limited to 'net/svnup')
-rw-r--r--net/svnup/Makefile2
-rw-r--r--net/svnup/files/patch-svnup.c70
2 files changed, 71 insertions, 1 deletions
diff --git a/net/svnup/Makefile b/net/svnup/Makefile
index b2e18165189b..c31be44bebd5 100644
--- a/net/svnup/Makefile
+++ b/net/svnup/Makefile
@@ -2,7 +2,7 @@
PORTNAME= svnup
PORTVERSION= 1.07
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://jcm.dsl.visi.com/freebsd/svnup/ \
LOCAL/jgh/net/${PORTNAME}/
diff --git a/net/svnup/files/patch-svnup.c b/net/svnup/files/patch-svnup.c
new file mode 100644
index 000000000000..1f24d71dc32d
--- /dev/null
+++ b/net/svnup/files/patch-svnup.c
@@ -0,0 +1,70 @@
+--- svnup.c.orig
++++ svnup.c
+@@ -51,7 +51,7 @@
+ #include <unistd.h>
+
+
+-#define SVNUP_VERSION "1.07"
++#define SVNUP_VERSION "1.07a"
+ #define BUFFER_UNIT 4096
+ #define COMMAND_BUFFER 32768
+ #define COMMAND_BUFFER_THRESHOLD 32000
+@@ -1539,7 +1539,6 @@
+ process_report_http(connector *connection, file_node ***file, int *file_count, int *file_max)
+ {
+ file_node *this_file;
+- struct stat local;
+ int revision_length, x;
+ char command[COMMAND_BUFFER + 1], *d, *end, *href, *md5, *path;
+ char *start, *temp, temp_buffer[BUFFER_UNIT], *value;
+@@ -1562,17 +1561,17 @@
+ "DAV: http://subversion.tigris.org/xmlns/dav/svn/log-revprops\r\n"
+ "Transfer-Encoding: chunked\r\n\r\n"
+ "%lx\r\n"
+- "<S:update-report xmlns:S=\"svn:\">\n"
+- "<S:src-path>/%s</S:src-path>\n"
+- "<S:target-revision>%d</S:target-revision>\n"
+- "<S:depth>unknown</S:depth>\n"
+- "<S:entry rev=\"%d\" depth=\"infinity\" start-empty=\"true\"></S:entry>\n"
+- "</S:update-report>\n"
++ "<S:update-report xmlns:S=\"svn:\">"
++ "<S:src-path>/%s</S:src-path>"
++ "<S:target-revision>%d</S:target-revision>"
++ "<S:depth>unknown</S:depth>"
++ "<S:entry rev=\"%d\" depth=\"infinity\" start-empty=\"true\"></S:entry>"
++ "</S:update-report>\r\n"
+ "\r\n0\r\n\r\n",
+ connection->root,
+ connection->address,
+ SVNUP_VERSION,
+- strlen(connection->branch) + revision_length + revision_length + strlen(SVNUP_VERSION) + 206,
++ strlen(connection->branch) + revision_length + revision_length + 205,
+ connection->branch,
+ connection->revision,
+ connection->revision);
+@@ -2389,9 +2388,9 @@
+
+ snprintf(temp_buffer,
+ BUFFER_UNIT,
+- "PROPFIND %s HTTP/1.1\n"
+- "Depth: 1\n"
+- "Host: %s\n\n",
++ "PROPFIND %s HTTP/1.1\r\n"
++ "Depth: 1\r\n"
++ "Host: %s\r\n\r\n",
+ file[f]->href,
+ connection.address);
+ } else temp_buffer[0] = '\0';
+@@ -2471,9 +2470,9 @@
+ if (connection.protocol >= HTTP)
+ snprintf(temp_buffer,
+ BUFFER_UNIT,
+- "GET %s HTTP/1.1\n"
+- "Host: %s\n"
+- "Connection: Keep-Alive\n\n",
++ "GET %s HTTP/1.1\r\n"
++ "Host: %s\r\n"
++ "Connection: Keep-Alive\r\n\r\n",
+ file[f]->href,
+ connection.address);
+