aboutsummaryrefslogtreecommitdiff
path: root/net/tcpdump
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-06-19 01:39:42 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-06-19 01:39:42 +0000
commit56614a74f44791625886eff0180b8d2c9b0e2056 (patch)
treed26b44ebbfd6d2671297f79ecbeed3a9f5e4de98 /net/tcpdump
parentb636db25a4b060fa1f7fca9a1b9d10a1b065fb7c (diff)
downloadports-56614a74f44791625886eff0180b8d2c9b0e2056.tar.gz
ports-56614a74f44791625886eff0180b8d2c9b0e2056.zip
Update to 4.3.0.
Don't specify major version for libpcap dependency. While here convert to new-style options.
Notes
Notes: svn path=/head/; revision=299597
Diffstat (limited to 'net/tcpdump')
-rw-r--r--net/tcpdump/Makefile43
-rw-r--r--net/tcpdump/distinfo4
2 files changed, 26 insertions, 21 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index bead9eec13cd..042a358131b5 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -6,59 +6,64 @@
#
PORTNAME= tcpdump
-PORTVERSION= 4.2.1
+PORTVERSION= 4.3.0
CATEGORIES= net ipv6
MASTER_SITES= http://www.tcpdump.org/release/
MAINTAINER= wxs@FreeBSD.org
COMMENT= Ubiquitous network traffic analysis tool
-LIB_DEPENDS= pcap.1:${PORTSDIR}/net/libpcap
+LIB_DEPENDS= pcap:${PORTSDIR}/net/libpcap
GNU_CONFIGURE= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= CRYPTO "Support IPSEC and TCPMD5" On \
- IPV6 "Support IPV6" On \
- SMB "Support SMB printer" On \
- SMI "Allow MIBs to be loaded on the fly" On \
- USER "Drop privileges to nobody" Off \
- CHROOT "Chroot support" Off
-
UNPRIV_USER?= nobody
CHROOTDIR?= /var/run/tcpdump
+OPTIONS_DEFINE= CRYPTO IPV6 SMB SMI USER CHROOT
+OPTIONS_DEFAULT= CRYPTO IPV6 SMB SMI
+
+CRYPTO_DESC= Support IPSEC and TCPMD5
+# This one is intentionally worded this way because the default
+# description implies that tcpdump would not capture SMB, which
+# is not true. It will just not print it if this option is off.
+SMB_DESC= Support printing SMB information
+SMI_DESC= Allow MIBs to be loaded on the fly
+USER_DESC= Drop privileges to nobody
+CHROOT_DESC= Chroot to /var/run/tcpdump (set CHROOTDIR to change)
+
.include <bsd.port.options.mk>
# The --without-crypto flag needs to be explicitly specified. The
# configure script gets confused if you specify --with-crypto and
# thinks this means you *don't* want crypto.
#
-.if defined(WITHOUT_CRYPTO)
-CONFIGURE_ARGS+= --without-crypto
-.else
+.if ${PORT_OPTIONS:MCRYPTO}
USE_OPENSSL= yes
+.else
+CONFIGURE_ARGS+= --without-crypto
.endif
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.endif
-.if defined(WITHOUT_SMB)
+.if empty(PORT_OPTIONS:MSMB)
CONFIGURE_ARGS+= --disable-smb
.endif
-.if defined(WITHOUT_SMI)
-CONFIGURE_ARGS+= --disable-smi
+.if ${PORT_OPTIONS:MSMI}
+LIB_DEPENDS+= smi:${PORTSDIR}/net-mgmt/libsmi
.else
-LIB_DEPENDS+= smi.2:${PORTSDIR}/net-mgmt/libsmi
+CONFIGURE_ARGS+= --disable-smi
.endif
-.if defined(WITH_USER)
+.if ${PORT_OPTIONS:MUSER}
CONFIGURE_ARGS+= --with-user=${UNPRIV_USER}
.endif
-.if defined(WITH_CHROOT)
+.if ${PORT_OPTIONS:MCHROOT}
CONFIGURE_ARGS+= --with-chroot=${CHROOTDIR}
.endif
diff --git a/net/tcpdump/distinfo b/net/tcpdump/distinfo
index bff03c61746b..8dbb2b6bde9b 100644
--- a/net/tcpdump/distinfo
+++ b/net/tcpdump/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tcpdump-4.2.1.tar.gz) = 5457e9a61e86efe62e88bc621903c2d1ab08dd688e9ac839c7bc2513ee4f9bff
-SIZE (tcpdump-4.2.1.tar.gz) = 887476
+SHA256 (tcpdump-4.3.0.tar.gz) = efd08b610210d39977ec3175fa82dad9fbd33587930081be2a905a712dba4286
+SIZE (tcpdump-4.3.0.tar.gz) = 887619