aboutsummaryrefslogtreecommitdiff
path: root/net/tightvnc
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-07-27 15:53:56 +0000
committerChris Rees <crees@FreeBSD.org>2013-07-27 15:53:56 +0000
commit4c082f93daffa48c418a347625e4edaedd6c4acc (patch)
treec9b2cabeb23f339f7880cde00f5c0ccf462dc663 /net/tightvnc
parentc43371dfb6780a4d2ae73db6830e6baf5259580c (diff)
downloadports-4c082f93daffa48c418a347625e4edaedd6c4acc.tar.gz
ports-4c082f93daffa48c418a347625e4edaedd6c4acc.zip
remove GCC requirement
PR: ports/179519 Submitted by: Kenta Suzumoto <kentas@hush.com> (also by 4721 below) add LICENSE remove shared library version from depends remove stale comment PR: ports/180063 Submitted by: 4721@hushmail.com Approved by: maintainer timeout (itetcu, 5 weeks)
Notes
Notes: svn path=/head/; revision=323793
Diffstat (limited to 'net/tightvnc')
-rw-r--r--net/tightvnc/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 6847c4c72e9e..c228c54a26a1 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -4,28 +4,27 @@
PORTNAME= tightvnc
PORTVERSION= 1.3.10
PORTREVISION= 3
-CATEGORIES= net
+CATEGORIES= net java
MASTER_SITES= SF/vnc-tight/TightVNC-unix/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}_unixsrc
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Enhanced version of VNC
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENCE.TXT
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= showrgb:${PORTSDIR}/x11/rgb \
xauth:${PORTSDIR}/x11/xauth \
xorg-fonts>=7.2:${PORTSDIR}/x11-fonts/xorg-fonts
MAKE_JOBS_UNSAFE= yes
-
CONFLICTS= tridiavnc-[0-9]* vnc-[0-9]*
-
WRKSRC= ${WRKDIR}/vnc_unixsrc
-
USES= imake shebangfix
SHEBANG_FILES= vncserver
CFLAGS+= -Wno-return-type
-USE_GCC= yes
USE_BZIP2= yes
USE_PERL5= yes
USE_XORG= xaw
@@ -37,9 +36,6 @@ MAN1= Xvnc.1 vncviewer.1 vncpasswd.1 vncconnect.1 vncserver.1
OPTIONS_DEFINE= JVNC_VIEWER
JVNC_VIEWER_DESC= Install Java-based vnc viewer
-#.include <bsd.port.pre.mk>
-
-### use me when 5.5, 6.1, 6.2R die or we do impement something in b.p.m
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJVNC_VIEWER}