aboutsummaryrefslogtreecommitdiff
path: root/net/tsocks/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-03-29 13:09:33 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-03-29 13:09:33 +0000
commit36f28f940ca23ddda9897a6bc3ba7c48bcdd8ebb (patch)
tree7550c0eb10e10d82747d6a17f742fccc3b097500 /net/tsocks/Makefile
parent06f54d1c5fa8eeba43d0cc50dc6ba3bf5934edfe (diff)
downloadports-36f28f940ca23ddda9897a6bc3ba7c48bcdd8ebb.tar.gz
ports-36f28f940ca23ddda9897a6bc3ba7c48bcdd8ebb.zip
Notes
Diffstat (limited to 'net/tsocks/Makefile')
-rw-r--r--net/tsocks/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net/tsocks/Makefile b/net/tsocks/Makefile
index fe0d292fa95d..5bf388b92cbd 100644
--- a/net/tsocks/Makefile
+++ b/net/tsocks/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tsocks
PORTVERSION= 1.8.b5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.8%20beta%205 \
http://ftp1.sourceforge.net/tsocks/ \
@@ -22,16 +22,16 @@ WRKSRC=${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b.*//}
CONFIGURE_ARGS= --with-conf=${PREFIX}/etc/tsocks.conf \
--libdir=${PREFIX}/lib
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES HOSTNAMES OLDMETHOD SOCKSDNS
-OPTIONS_DEFAULT= DEBUG HOSTNAMES
+OPTIONS_DEFINE= DOCS EXAMPLES HOSTNAMES MUTE OLDMETHOD SOCKSDNS
+OPTIONS_DEFAULT= HOSTNAMES
-DEBUG_DESC= Output error messages to stderr
HOSTNAMES_DESC= Enable DNS lookups
OLDMETHOD_DESC= Do not use RTLD_NEXT parameter to dlsym
+MUTE_DESC= Disable all error messages
SOCKSDNS_DESC= Intercept DNS requests and attempt to force them to use TCP
-DEBUG_CONFIGURE_OFF= --disable-debug
HOSTNAMES_CONFIGURE_OFF= --disable-hostnames
+MUTE_CONFIGURE_ON= --disable-debug
OLDMETHOD_CONFIGURE_ON= --enable-oldmethod
SOCKSDNS_CONFIGURE_ON= --enable-socksdns