aboutsummaryrefslogtreecommitdiff
path: root/net/unison-devel/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-30 12:52:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-30 12:52:16 +0000
commit7a98df2288890e1dc47f0630b3072f8e028b6d5c (patch)
tree64f47d20ea110e5b69a98e2dfbf50daed7debc0c /net/unison-devel/Makefile
parent3c2958a62b5d4a0b838919dcab2727c20d4ab7e2 (diff)
downloadports-7a98df2288890e1dc47f0630b3072f8e028b6d5c.tar.gz
ports-7a98df2288890e1dc47f0630b3072f8e028b6d5c.zip
Notes
Diffstat (limited to 'net/unison-devel/Makefile')
-rw-r--r--net/unison-devel/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
index b3de6afbdb4c..149126354848 100644
--- a/net/unison-devel/Makefile
+++ b/net/unison-devel/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= daniel+unison@pelleg.org
COMMENT= A user-level file synchronization tool
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+PATCH_DEPENDS= ${BUILD_DEPENDS}
USE_GMAKE= yes
MAKE_ARGS= UISTYLE=text CFLAGS=""
@@ -28,6 +29,16 @@ EXTRA_DOCS= unison-manual.dvi unison-manual.html \
unison-manual.pdf unison-manual.ps
.endif
+pre-patch:
+ @if [ `ocamlc -version | ${SED} -e s/\\\.//g -e s/\\\+.*//` -gt 307 ] ; then \
+ if ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/ocaml-external-patch-ab ; then \
+ ${TRUE} ; \
+ else \
+ ${ECHO_MSG} ">> Patch ocaml-external-patch-ab failed to apply cleanly." ; \
+ ${FALSE} ; \
+ fi; \
+ fi
+
post-install:
@${STRIP_CMD} ${PREFIX}/bin/unison
.if !defined(NOPORTDOCS)