aboutsummaryrefslogtreecommitdiff
path: root/net/unison232
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-29 09:38:57 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-29 09:38:57 +0000
commit3ae4fe6da729d668a82e3c814b6ff8d49df0d678 (patch)
tree873ea15d35b093b6d542ae621b2ded0e4d3c64c5 /net/unison232
parent4ae045f484b3d1e1082f4f4e4eea9a56f3d992f1 (diff)
downloadports-3ae4fe6da729d668a82e3c814b6ff8d49df0d678.tar.gz
ports-3ae4fe6da729d668a82e3c814b6ff8d49df0d678.zip
Convert unison ports to staging
Approved by: bsam (for net/unison-nox11) Approved by: mandree (implicit, for net/unison232)
Notes
Notes: svn path=/head/; revision=328659
Diffstat (limited to 'net/unison232')
-rw-r--r--net/unison232/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index adcc53edd841..76cf6f4fecd9 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -18,7 +18,7 @@ COMMENT= User-level file synchronization tool
LICENSE= GPLv3
PLIST_SUB= PORTVERSION=${PORTVERSION}
-USE_GMAKE= yes
+USES= gmake
WANT_GNOME= yes
MAKE_ARGS= CFLAGS=""
@@ -27,7 +27,6 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DOCS X11
OPTIONS_DEFAULT= DOCS X11
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -69,20 +68,18 @@ post-build:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
- cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
.if ${PORT_OPTIONS:MX11}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-text ${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}-text
- ${MKDIR} ${DESKTOPDIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${DESKTOPDIR}/${PORTNAME}${PKGNAMESUFFIX}.desktop
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-text ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}-text
+ ${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}/${PORTNAME}${PKGNAMESUFFIX}.desktop
-update-desktop-database > /dev/null
- @${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${PREFIX}/share/pixmaps/${PORTNAME}${PKGNAMESUFFIX}.png
+ @${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}${PKGNAMESUFFIX}.png
.endif
.include <bsd.port.mk>