aboutsummaryrefslogtreecommitdiff
path: root/net/unison240
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-01-01 18:17:12 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-01-01 18:17:12 +0000
commit142119cea21bbd967e7e46f66c978de3dbba89ac (patch)
tree682d79ec0c188d2aefb05fb714b670338bcd7eb2 /net/unison240
parent103d4f3e416d5d3b360c5961d9588907d1b4d8a0 (diff)
downloadports-142119cea21bbd967e7e46f66c978de3dbba89ac.tar.gz
ports-142119cea21bbd967e7e46f66c978de3dbba89ac.zip
Notes
Diffstat (limited to 'net/unison240')
-rw-r--r--net/unison240/Makefile80
-rw-r--r--net/unison240/distinfo8
-rw-r--r--net/unison240/files/unison.desktop.in12
-rw-r--r--net/unison240/pkg-descr11
-rw-r--r--net/unison240/pkg-message4
-rw-r--r--net/unison240/pkg-message.nox113
-rw-r--r--net/unison240/pkg-plist10
7 files changed, 128 insertions, 0 deletions
diff --git a/net/unison240/Makefile b/net/unison240/Makefile
new file mode 100644
index 000000000000..3ee3a5b9806e
--- /dev/null
+++ b/net/unison240/Makefile
@@ -0,0 +1,80 @@
+# Created by: Dan Pelleg <dpelleg+unison@cs.cmu.edu>
+# $FreeBSD$
+
+PORTNAME= unison
+PORTVERSION= 2.40.128
+CATEGORIES= net
+MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
+PKGNAMESUFFIX= 240
+DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
+
+MAINTAINER?= madpilot@FreeBSD.org
+COMMENT?= User-level file synchronization tool
+
+LICENSE= GPLv3
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+USES= gmake
+WANT_GNOME= yes
+MAKE_ARGS= CFLAGS=""
+
+MAKE_JOBS_UNSAFE= yes
+ALL_TARGET= unison all
+
+DOCS= BUGS.txt NEWS README
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+EXTRA_DOCS= unison-${PORTVERSION}-manual.html \
+ unison-${PORTVERSION}-manual.pdf unison-${PORTVERSION}-manual.ps
+
+OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFAULT?= DOCS X11
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
+MAKE_ARGS+= UISTYLE=gtk2
+PLIST_SUB+= TEXT=""
+BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
+ lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2 \
+ icotool:${PORTSDIR}/graphics/icoutils
+RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+PATCH_DEPENDS+= ${BUILD_DEPENDS}
+CONFLICTS+= ocaml-nox11*
+SUB_FILES+= ${PORTNAME}.desktop
+.else
+MAKE_ARGS+= UISTYLE=text
+PLIST_SUB+= TEXT="@comment "
+BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
+PATCH_DEPENDS+= ${BUILD_DEPENDS}
+PKGMESSAGE= ${PKGDIR}/pkg-message.nox11
+.endif
+
+.if ${PORT_OPTIONS:MX11}
+post-patch:
+ @${REINPLACE_CMD} -Ee 's@(\+|/)(lablgtk2)@\1site-lib/\2@' \
+ ${WRKSRC}/Makefile.OCaml
+
+post-build:
+ @${ECHO} Building text-only version
+ @${ECHO} ${WRKSRC}
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC} CFLAGS="" UISTYLE=text NAME=unison-text
+ @cd ${WRKSRC}/win32rc && ${LOCALBASE}/bin/icotool -x U.ico
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${STAGEDIR}${DOCSDIR}
+.if ${PORT_OPTIONS:MX11}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-text ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}-text
+ @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}/${PORTNAME}${PKGNAMESUFFIX}.desktop
+ ${INSTALL_DATA} ${WRKSRC}/win32rc/U_4_48x48x32.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}${PKGNAMESUFFIX}.png
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/unison240/distinfo b/net/unison240/distinfo
new file mode 100644
index 000000000000..3b01539798d9
--- /dev/null
+++ b/net/unison240/distinfo
@@ -0,0 +1,8 @@
+SHA256 (unison-2.40.128/unison-2.40.128.tar.gz) = 2c979f3bcdc92fb6b009e9e79a6c973a70689e9b646341fff3ca8a220889efbf
+SIZE (unison-2.40.128/unison-2.40.128.tar.gz) = 2717542
+SHA256 (unison-2.40.128/unison-2.40.128-manual.html) = 8cd3901dffab27203fab1702a7eb25555539f1b566ebe08036aef695f39e8593
+SIZE (unison-2.40.128/unison-2.40.128-manual.html) = 267099
+SHA256 (unison-2.40.128/unison-2.40.128-manual.pdf) = ad6ea7afdd07515193c1546c530f5ed997618ee44fc4dc6907ce6abe8e8d4293
+SIZE (unison-2.40.128/unison-2.40.128-manual.pdf) = 496607
+SHA256 (unison-2.40.128/unison-2.40.128-manual.ps) = 2f3b8508355ad1853be0e8af547a86404bb0efe58e150aea1a83218d86374781
+SIZE (unison-2.40.128/unison-2.40.128-manual.ps) = 753150
diff --git a/net/unison240/files/unison.desktop.in b/net/unison240/files/unison.desktop.in
new file mode 100644
index 000000000000..0f8a0aef730c
--- /dev/null
+++ b/net/unison240/files/unison.desktop.in
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Unison 2.40
+GenericName=File-synchronization tool
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=GTK;Utility;
+Exec=unison240
+Icon=unison240.png
+Comment=Synchronize files (directories) over different disks (hosts)
+Comment[ru]=Синхронизация файлов (каталогов) на нескольких дисках (компьютерах)
diff --git a/net/unison240/pkg-descr b/net/unison240/pkg-descr
new file mode 100644
index 000000000000..ba302a0f4ae6
--- /dev/null
+++ b/net/unison240/pkg-descr
@@ -0,0 +1,11 @@
+Unison is a file-synchronization tool for Unix and Windows. It allows two
+replicas of a collection of files and directories to be stored on different
+hosts (or different disks on the same host), modified separately, and then
+brought up to date by propagating the changes in each replica to the other.
+
+Unison shares a number of features with tools such as configuration
+management packages (CVS, PRCS, etc.) distributed filesystems (Coda, etc.)
+uni-directional mirroring utilities (rsync, etc.) and other synchronizers
+(Intellisync, Reconcile, etc).
+
+WWW: http://www.cis.upenn.edu/~bcpierce/unison/
diff --git a/net/unison240/pkg-message b/net/unison240/pkg-message
new file mode 100644
index 000000000000..3c1cfd40d2c0
--- /dev/null
+++ b/net/unison240/pkg-message
@@ -0,0 +1,4 @@
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+Together with a gtk-enabled version, a text-only unison-text binary
+is installed as it depends on a smaller number of libraries.
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
diff --git a/net/unison240/pkg-message.nox11 b/net/unison240/pkg-message.nox11
new file mode 100644
index 000000000000..fe8b86b9b4eb
--- /dev/null
+++ b/net/unison240/pkg-message.nox11
@@ -0,0 +1,3 @@
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+A text-only unison binary is installed.
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
diff --git a/net/unison240/pkg-plist b/net/unison240/pkg-plist
new file mode 100644
index 000000000000..f4ef70fad4d9
--- /dev/null
+++ b/net/unison240/pkg-plist
@@ -0,0 +1,10 @@
+bin/unison240
+%%TEXT%%share/applications/unison240.desktop
+%%TEXT%%bin/unison240-text
+%%TEXT%%share/pixmaps/unison240.png
+%%PORTDOCS%%%%DOCSDIR%%/BUGS.txt
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.html
+%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.ps