aboutsummaryrefslogtreecommitdiff
path: root/net/unison
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-05-31 21:12:14 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-05-31 21:12:14 +0000
commit68e1d1d6bac0b47fedea2eb0dc2d1b449e7a973d (patch)
treee34babc2d103058a4353e9cc46ab56239c643555 /net/unison
parent3cccaae6f232fabf7cc92d7e6aa1b54c2495cf58 (diff)
downloadports-68e1d1d6bac0b47fedea2eb0dc2d1b449e7a973d.tar.gz
ports-68e1d1d6bac0b47fedea2eb0dc2d1b449e7a973d.zip
- Convert to new options framework
- Remove uneeded double quotes - While here fix various portlint warnings - Indent make conditionals and loop Approved by: Boris Samorodov <bsam@FreeBSD.org> (net/unison-nox11 maintainer) Approved by: Matthias Andree <mandree@FreeBSD.org> (implicit, net/unison232 maintainer) Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=297905
Diffstat (limited to 'net/unison')
-rw-r--r--net/unison/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 4122f3706a34..32585686146c 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -16,30 +16,29 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= madpilot@FreeBSD.org
COMMENT= A user-level file synchronization tool
+LICENSE= GPLv3
+
PLIST_SUB= PORTVERSION=${PORTVERSION}
USE_GMAKE= yes
WANT_GNOME= yes
MAKE_ARGS= CFLAGS=""
-CONFLICTS= unison-devel-[0-9]* unison-nox11-[0-9]*
+CONFLICTS?= unison-devel-[0-9]* unison-nox11-[0-9]*
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= unison all
-LICENSE= GPLv3
+OPTIONS_DEFINE= DOCS GTK2
+OPTIONS_DEFAULT?= DOCS GTK2
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
DOCS= BUGS.txt NEWS README
EXTRA_DOCS= unison-${PORTVERSION}-manual.html \
unison-${PORTVERSION}-manual.pdf unison-${PORTVERSION}-manual.ps
.endif
-.if !defined(WITHOUT_GTK2) && !defined(WITHOUT_X11)
-WITH_GTK2= yes
-.endif
-
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
MAKE_ARGS+= UISTYLE=gtk2
PLIST_SUB+= TEXT=""
BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
@@ -56,7 +55,7 @@ BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
PATCH_DEPENDS+= ${BUILD_DEPENDS}
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
post-build:
@${ECHO} Building text-only version
@${ECHO} ${WRKSRC}
@@ -67,12 +66,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unison ${PREFIX}/bin
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${DOCSDIR}
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
@${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
@${MKDIR} ${DESKTOPDIR}
@${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${DESKTOPDIR}
@@ -82,4 +81,4 @@ post-install:
@${CAT} ${PKGMESSAGE}.nox11
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>