aboutsummaryrefslogtreecommitdiff
path: root/net/unison
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-26 01:42:33 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-26 01:42:33 +0000
commitf92095b090e2a8f46159297f6e1156cf0bded937 (patch)
treeac384d4fc0a6c05788860a863d82757b0b106e59 /net/unison
parentf3476b61693d5901f1169898fd989b104cc8b1ad (diff)
downloadports-f92095b090e2a8f46159297f6e1156cf0bded937.tar.gz
ports-f92095b090e2a8f46159297f6e1156cf0bded937.zip
Add new port of unison 2.5.1, a utility for synchronizing files
which works both on local disks and over a network (can use ssh). PR: 22264 Submitted by: Dan Pelleg <dpelleg+unison@cs.cmu.edu>
Notes
Notes: svn path=/head/; revision=34243
Diffstat (limited to 'net/unison')
-rw-r--r--net/unison/Makefile27
-rw-r--r--net/unison/distinfo1
-rw-r--r--net/unison/files/patch-aa27
-rw-r--r--net/unison/pkg-comment1
-rw-r--r--net/unison/pkg-descr15
-rw-r--r--net/unison/pkg-plist1
6 files changed, 72 insertions, 0 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
new file mode 100644
index 000000000000..256eb12ed317
--- /dev/null
+++ b/net/unison/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: unison
+# Date created: 4 October 2000
+# Whom: Dan Pelleg <dpelleg+unison@cs.cmu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unison
+PORTVERSION= 2.5.1
+CATEGORIES= net
+MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/stable/unison-${PORTVERSION}/
+DISTNAME= src
+DIST_SUBDIR= unison
+
+MAINTAINER= Dan Pelleg <dpelleg+unison@cs.cmu.edu>
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_GMAKE= yes
+MAKE_ARGS= UISTYLE=text CFLAGS=""
+
+post-install:
+ strip ${PREFIX}/bin/unison
+
+.include <bsd.port.mk>
diff --git a/net/unison/distinfo b/net/unison/distinfo
new file mode 100644
index 000000000000..28b5f9fb75bc
--- /dev/null
+++ b/net/unison/distinfo
@@ -0,0 +1 @@
+MD5 (unison/src.tar.gz) = e7e1f701d8d2c22e25380550ca8d60f4
diff --git a/net/unison/files/patch-aa b/net/unison/files/patch-aa
new file mode 100644
index 000000000000..6c45ce1d18b1
--- /dev/null
+++ b/net/unison/files/patch-aa
@@ -0,0 +1,27 @@
+--- Makefile.orig Mon Sep 25 19:04:31 2000
++++ Makefile Wed Oct 25 20:48:53 2000
+@@ -62,12 +62,12 @@
+ ######################################################################
+ # Installation
+
+-INSTALLDIR = $(HOME)/bin/
++INSTALLDIR = ${PREFIX}/bin/
+
+ install: $(NAME)$(EXEC_EXT)
+- -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
++# -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
+ cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
+- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(VERSION)$(EXEC_EXT)
++# cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(VERSION)$(EXEC_EXT)
+
+ ######################################################################
+ # Demo
+@@ -204,7 +204,7 @@
+ tags:
+ -$(ETAGS) *.ml *.mli
+
+-all:: TAGS
++# all:: TAGS
+
+ TAGS:
+ $(MAKE) tags
diff --git a/net/unison/pkg-comment b/net/unison/pkg-comment
new file mode 100644
index 000000000000..140bbf544904
--- /dev/null
+++ b/net/unison/pkg-comment
@@ -0,0 +1 @@
+A user-level file synchronization tool
diff --git a/net/unison/pkg-descr b/net/unison/pkg-descr
new file mode 100644
index 000000000000..5ae58aebb642
--- /dev/null
+++ b/net/unison/pkg-descr
@@ -0,0 +1,15 @@
+Unison is a file-synchronization tool for Unix and Windows. It allows two
+replicas of a collection of files and directories to be stored on different
+hosts (or different disks on the same host), modified separately, and then
+brought up to date by propagating the changes in each replica to the other.
+
+Unison shares a number of features with tools such as configuration
+management packages (CVS, PRCS, etc.) distributed filesystems (Coda, etc.)
+uni-directional mirroring utilities (rsync, etc.) and other synchronizers
+(Intellisync, Reconcile, etc).
+
+WWW: http://www.cis.upenn.edu/~bcpierce/unison/
+
+- Dan Pelleg
+
+dpelleg+unison@cs.cmu.edu
diff --git a/net/unison/pkg-plist b/net/unison/pkg-plist
new file mode 100644
index 000000000000..31b7bedb59e4
--- /dev/null
+++ b/net/unison/pkg-plist
@@ -0,0 +1 @@
+bin/unison