aboutsummaryrefslogtreecommitdiff
path: root/net/unix2tcp/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-12 09:31:06 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-12 09:31:06 +0000
commitb2bc00209776bf66d42c3a6e6e0957909ad91bf6 (patch)
tree8912b43ee860b155bef85c5f1d9c38d72a8a8817 /net/unix2tcp/Makefile
parent8eb3d1a3708da0a9aca5306f2c8cb984bac4184c (diff)
downloadports-b2bc00209776bf66d42c3a6e6e0957909ad91bf6.tar.gz
ports-b2bc00209776bf66d42c3a6e6e0957909ad91bf6.zip
Notes
Diffstat (limited to 'net/unix2tcp/Makefile')
-rw-r--r--net/unix2tcp/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/unix2tcp/Makefile b/net/unix2tcp/Makefile
new file mode 100644
index 000000000000..0b70cba17702
--- /dev/null
+++ b/net/unix2tcp/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: unix2tcp
+# Date created: Thu Jan 30, 2003
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= unix2tcp
+PORTVERSION= 0.7.2
+CATEGORIES= net
+MASTER_SITES= http://ahriman.bucharest.roedu.net/unix2tcp/
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= A connection forwarder that converts Unix sockets into TCP sockets
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} -I. ${PORTNAME}.c -c &&\
+ ${CC} -I. list.c -c && \
+ ${CC} ${PORTNAME}.o list.o -o ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>