aboutsummaryrefslogtreecommitdiff
path: root/net/wireguard
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-02-25 20:41:22 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-02-25 20:41:22 +0000
commit76b6791de0f152d57ab6924764fd789408fdf8d4 (patch)
tree3e881f098ea3b1f79779765d73f74bf8b92e484a /net/wireguard
parent7464557d7e8bc969614214da29a7f072f047e52a (diff)
downloadports-76b6791de0f152d57ab6924764fd789408fdf8d4.tar.gz
ports-76b6791de0f152d57ab6924764fd789408fdf8d4.zip
net/wireguard: Update to 1.0.20210223 and introduce options
Due to a bug which was fixed in this release both net/wireguard and net/wireguard-go need to be updated or wg-quick will hang at the next start. PR: 253537
Notes
Notes: svn path=/head/; revision=566557
Diffstat (limited to 'net/wireguard')
-rw-r--r--net/wireguard/Makefile22
-rw-r--r--net/wireguard/distinfo6
-rw-r--r--net/wireguard/pkg-plist10
3 files changed, 25 insertions, 13 deletions
diff --git a/net/wireguard/Makefile b/net/wireguard/Makefile
index bd7b2b73feb8..777927961c4e 100644
--- a/net/wireguard/Makefile
+++ b/net/wireguard/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= wireguard
-PORTVERSION= 1.0.20200827
+PORTVERSION= 1.0.20210223
CATEGORIES= net net-vpn
MASTER_SITES= https://git.zx2c4.com/wireguard-tools/snapshot/
DISTNAME= wireguard-tools-${PORTVERSION}
@@ -12,18 +12,30 @@ COMMENT= Fast, modern and secure VPN Tunnel
LICENSE= GPLv2
LICENSE_FILE= ${WRKDIR}/${DISTNAME}/COPYING
-RUN_DEPENDS= bash:shells/bash \
- wireguard-go:net/wireguard-go
-
USES= gmake tar:xz
USE_RC_SUBR= ${PORTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-MAKE_ARGS= WITH_WGQUICK=yes WITH_BASHCOMPLETION=yes
+MAKE_ARGS+= WITH_SYSTEMDUNITS=no DEBUG=no
MAKE_ENV+= MANDIR="${MANPREFIX}/man" \
SYSCONFDIR="${PREFIX}/etc"
+OPTIONS_DEFINE= BASHCOMPLETION WGQUICK
+OPTIONS_DEFAULT=BASHCOMPLETION WGQUICK
+OPTIONS_SUB= yes
+
+BASHCOMPLETION_DESC= Command completion files for Bash shell
+BASHCOMPLETION_RUN_DEPENDS= bash:shells/bash
+BASHCOMPLETION_MAKE_ARGS= WITH_BASHCOMPLETION=yes
+BASHCOMPLETION_MAKE_ARGS_OFF= WITH_BASHCOMPLETION=no
+
+WGQUICK_DESC= wg-quick(8) userland utility
+WGQUICK_RUN_DEPENDS= bash:shells/bash \
+ wireguard-go:net/wireguard-go
+WGQUICK_MAKE_ARGS= WITH_WGQUICK=yes
+WGQUICK_MAKE_ARGS_OFF= WITH_WGQUICK=no
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/completion/wg-quick.bash-completion \
diff --git a/net/wireguard/distinfo b/net/wireguard/distinfo
index 5377588c6ffb..602bd859646c 100644
--- a/net/wireguard/distinfo
+++ b/net/wireguard/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598771471
-SHA256 (wireguard-tools-1.0.20200827.tar.xz) = 51bc85e33a5b3cf353786ae64b0f1216d7a871447f058b6137f793eb0f53b7fd
-SIZE (wireguard-tools-1.0.20200827.tar.xz) = 94788
+TIMESTAMP = 1614269282
+SHA256 (wireguard-tools-1.0.20210223.tar.xz) = 1f72da217044622d79e0bab57779e136a3df795e3761a3fc1dc0941a9055877c
+SIZE (wireguard-tools-1.0.20210223.tar.xz) = 95444
diff --git a/net/wireguard/pkg-plist b/net/wireguard/pkg-plist
index 55eb941b4468..9c46a9c7f280 100644
--- a/net/wireguard/pkg-plist
+++ b/net/wireguard/pkg-plist
@@ -1,7 +1,7 @@
bin/wg
-bin/wg-quick
-man/man8/wg-quick.8.gz
+%%WGQUICK%%bin/wg-quick
+%%WGQUICK%%man/man8/wg-quick.8.gz
man/man8/wg.8.gz
-share/bash-completion/completions/wg
-share/bash-completion/completions/wg-quick
-@dir etc/wireguard
+%%BASHCOMPLETION%%share/bash-completion/completions/wg
+%%BASHCOMPLETION%%share/bash-completion/completions/wg-quick
+%%WGQUICK%%@dir etc/wireguard