aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2018-04-08 15:47:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2018-04-08 15:47:15 +0000
commit13aef227963b6e7b69383f0aa4bb4924716d542b (patch)
tree7081298605997099f83a72f8cc9762551ef49e9a /net/wireshark/Makefile
parent7c95466d81a23e09c243f07684c5a2a759f658d8 (diff)
Notes
Diffstat (limited to 'net/wireshark/Makefile')
-rw-r--r--net/wireshark/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 71fe811c1260..55b037a9eac7 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME?= wireshark
-PORTVERSION= 2.4.5
+PORTVERSION= 2.4.6
PORTREVISION?= 0
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
@@ -27,12 +27,15 @@ DATADIR_NAME= wireshark
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
GNU_CONFIGURE= yes
-USES= alias cpe gettext-runtime gmake libtool pathfix perl5 \
- pkgconfig python:build ssl tar:xz
+USES= alias cpe gettext-runtime gmake libtool localbase pathfix \
+ perl5 pkgconfig python:build ssl tar:xz
USE_PERL5= build
USE_GNOME= glib20 libxml2
CONFIGURE_ARGS+= --program-transform-name="" \
- --with-ssl=${OPENSSLBASE}
+ --with-ssl=${OPENSSLBASE} \
+ --with-lz4 \
+ --with-nghttp2 \
+ --with-snappy
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
@@ -43,7 +46,6 @@ LIB_DEPENDS+= libgpg-error.so:security/libgpg-error \
libsnappy.so:archivers/snappy
CFLAGS+= -funit-at-a-time
-LIBS+= -L${LOCALBASE}/lib
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
@@ -62,7 +64,7 @@ PLIST_SUB+= ${x:tu}=bin/$x \
.endif
.endfor
-OPTIONS_DEFINE= RTP SNMP IPV6 GEOIP LUA DECRYPT ANDROIDDUMP CARES
+OPTIONS_DEFINE= RTP SNMP GEOIP LUA DECRYPT ANDROIDDUMP CARES
OPTIONS_RADIO= GUI
OPTIONS_SINGLE= KERBEROS
@@ -100,8 +102,6 @@ GEOIP_LIB_DEPENDS= libGeoIP.so:net/GeoIP
DECRYPT_LIB_DEPENDS= libgnutls.so:security/gnutls \
libgcrypt.so:security/libgcrypt
-IPV6_CONFIGURE_ENABLE= ipv6
-
KRB_NONE_CONFIGURE_ON= --without-krb5
KRB_NONE_CONFIGURE_OFF= --with-krb5
KRB_NONE_CONFIGURE_ENV_OFF= KRB5_CONFIG=${KRB5CONFIG}
@@ -114,7 +114,7 @@ RTP_CONFIGURE_WITH= portaudio spandsp
SNMP_CONFIGURE_WITH= libsmi
CARES_CONFIGURE_WITH= c-ares
GEOIP_CONFIGURE_WITH= geoip
-DECRYPT_CONFIGURE_WITH= gnutls gcrypt
+DECRYPT_CONFIGURE_WITH= gnutls
ANDROIDDUMP_CONFIGURE_ON=--enable-androiddump=yes
ANDROIDDUMP_CONFIGURE_OFF=--enable-androiddump=no