aboutsummaryrefslogtreecommitdiff
path: root/net/wireshark
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2018-05-28 19:30:57 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2018-05-28 19:30:57 +0000
commitb4fa0e237656bf811af7f864d914215fa0240d96 (patch)
tree866f7a6332234d0db0c32c25714eb5254038691a /net/wireshark
parent8f7e762fdeb6220feb34f84e7c1b0934e427bba7 (diff)
downloadports-b4fa0e237656bf811af7f864d914215fa0240d96.tar.gz
ports-b4fa0e237656bf811af7f864d914215fa0240d96.zip
Fix an undefined symbol error in tshark.
The l16mono codec was installed as a regular plugin, and this generated a bogus undefined symbol error. PR: 228051 Submitted by: Sergey Akhmatov <sergey@akhmatov.ru> Obtained from: https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14638
Notes
Notes: svn path=/head/; revision=471063
Diffstat (limited to 'net/wireshark')
-rw-r--r--net/wireshark/Makefile2
-rw-r--r--net/wireshark/files/patch-plugins_codecs_l16__mono_CMakeLists.txt11
-rw-r--r--net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.am11
-rw-r--r--net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.in150
-rw-r--r--net/wireshark/pkg-plist2
5 files changed, 174 insertions, 2 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 7ab73479ef4f..65f6b708d8ca 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= wireshark
PORTVERSION= 2.6.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
diff --git a/net/wireshark/files/patch-plugins_codecs_l16__mono_CMakeLists.txt b/net/wireshark/files/patch-plugins_codecs_l16__mono_CMakeLists.txt
new file mode 100644
index 000000000000..595103269653
--- /dev/null
+++ b/net/wireshark/files/patch-plugins_codecs_l16__mono_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- plugins/codecs/l16_mono/CMakeLists.txt.orig 2018-05-22 12:49:38 UTC
++++ plugins/codecs/l16_mono/CMakeLists.txt
+@@ -28,7 +28,7 @@ set_source_files_properties(
+ )
+
+ include_directories(
+- ${CMAKE_SOURCE_DIR}/codec
++ ${CMAKE_SOURCE_DIR}/codecs
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+
diff --git a/net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.am b/net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.am
new file mode 100644
index 000000000000..619f88f1ea22
--- /dev/null
+++ b/net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.am
@@ -0,0 +1,11 @@
+--- plugins/codecs/l16_mono/Makefile.am.orig 2018-05-22 12:50:18 UTC
++++ plugins/codecs/l16_mono/Makefile.am
+@@ -26,7 +26,7 @@ NONGENERATED_REGISTER_C_FILES = \
+ NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+-wiretap_plugin_LTLIBRARIES = l16mono.la
++codecs_plugin_LTLIBRARIES = l16mono.la
+
+ l16mono_la_SOURCES = \
+ $(SRC_FILES) \
diff --git a/net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.in b/net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.in
new file mode 100644
index 000000000000..01c7468677c4
--- /dev/null
+++ b/net/wireshark/files/patch-plugins_codecs_l16__mono_Makefile.in
@@ -0,0 +1,150 @@
+--- plugins/codecs/l16_mono/Makefile.in.orig 2018-05-22 16:01:15 UTC
++++ plugins/codecs/l16_mono/Makefile.in
+@@ -197,8 +197,8 @@ am__uninstall_files_from_dir = { \
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
+-am__installdirs = "$(DESTDIR)$(wiretap_plugindir)"
+-LTLIBRARIES = $(wiretap_plugin_LTLIBRARIES)
++am__installdirs = "$(DESTDIR)$(codecs_plugindir)"
++LTLIBRARIES = $(codecs_plugin_LTLIBRARIES)
+ l16mono_la_LIBADD =
+ am__objects_1 = l16mono_la-l16decode.lo
+ am__objects_2 = $(am__objects_1)
+@@ -523,7 +523,6 @@ rawshark_bin = @rawshark_bin@
+ rawshark_man = @rawshark_man@
+ reordercap_bin = @reordercap_bin@
+ reordercap_man = @reordercap_man@
+-runstatedir = @runstatedir@
+ sbindir = @sbindir@
+ sharedstatedir = @sharedstatedir@
+ sharkd_bin = @sharkd_bin@
+@@ -741,7 +740,7 @@ NONGENERATED_REGISTER_C_FILES = \
+ NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES)
+
+-wiretap_plugin_LTLIBRARIES = l16mono.la
++codecs_plugin_LTLIBRARIES = l16mono.la
+ l16mono_la_SOURCES = \
+ $(SRC_FILES) \
+ $(HEADER_FILES)
+@@ -794,33 +793,33 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ $(am__aclocal_m4_deps):
+
+-install-wiretap_pluginLTLIBRARIES: $(wiretap_plugin_LTLIBRARIES)
++install-codecs_pluginLTLIBRARIES: $(codecs_plugin_LTLIBRARIES)
+ @$(NORMAL_INSTALL)
+- @list='$(wiretap_plugin_LTLIBRARIES)'; test -n "$(wiretap_plugindir)" || list=; \
++ @list='$(codecs_plugin_LTLIBRARIES)'; test -n "$(codecs_plugindir)" || list=; \
+ list2=; for p in $$list; do \
+ if test -f $$p; then \
+ list2="$$list2 $$p"; \
+ else :; fi; \
+ done; \
+ test -z "$$list2" || { \
+- echo " $(MKDIR_P) '$(DESTDIR)$(wiretap_plugindir)'"; \
+- $(MKDIR_P) "$(DESTDIR)$(wiretap_plugindir)" || exit 1; \
+- echo " $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 '$(DESTDIR)$(wiretap_plugindir)'"; \
+- $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 "$(DESTDIR)$(wiretap_plugindir)"; \
++ echo " $(MKDIR_P) '$(DESTDIR)$(codecs_plugindir)'"; \
++ $(MKDIR_P) "$(DESTDIR)$(codecs_plugindir)" || exit 1; \
++ echo " $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 '$(DESTDIR)$(codecs_plugindir)'"; \
++ $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=install $(INSTALL) $(INSTALL_STRIP_FLAG) $$list2 "$(DESTDIR)$(codecs_plugindir)"; \
+ }
+
+-uninstall-wiretap_pluginLTLIBRARIES:
++uninstall-codecs_pluginLTLIBRARIES:
+ @$(NORMAL_UNINSTALL)
+- @list='$(wiretap_plugin_LTLIBRARIES)'; test -n "$(wiretap_plugindir)" || list=; \
++ @list='$(codecs_plugin_LTLIBRARIES)'; test -n "$(codecs_plugindir)" || list=; \
+ for p in $$list; do \
+ $(am__strip_dir) \
+- echo " $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=uninstall rm -f '$(DESTDIR)$(wiretap_plugindir)/$$f'"; \
+- $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=uninstall rm -f "$(DESTDIR)$(wiretap_plugindir)/$$f"; \
++ echo " $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=uninstall rm -f '$(DESTDIR)$(codecs_plugindir)/$$f'"; \
++ $(LIBTOOL) $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=uninstall rm -f "$(DESTDIR)$(codecs_plugindir)/$$f"; \
+ done
+
+-clean-wiretap_pluginLTLIBRARIES:
+- -test -z "$(wiretap_plugin_LTLIBRARIES)" || rm -f $(wiretap_plugin_LTLIBRARIES)
+- @list='$(wiretap_plugin_LTLIBRARIES)'; \
++clean-codecs_pluginLTLIBRARIES:
++ -test -z "$(codecs_plugin_LTLIBRARIES)" || rm -f $(codecs_plugin_LTLIBRARIES)
++ @list='$(codecs_plugin_LTLIBRARIES)'; \
+ locs=`for p in $$list; do echo $$p; done | \
+ sed 's|^[^/]*$$|.|; s|/[^/]*$$||; s|$$|/so_locations|' | \
+ sort -u`; \
+@@ -830,7 +829,7 @@ clean-wiretap_pluginLTLIBRARIES:
+ }
+
+ l16mono.la: $(l16mono_la_OBJECTS) $(l16mono_la_DEPENDENCIES) $(EXTRA_l16mono_la_DEPENDENCIES)
+- $(AM_V_CCLD)$(l16mono_la_LINK) -rpath $(wiretap_plugindir) $(l16mono_la_OBJECTS) $(l16mono_la_LIBADD) $(LIBS)
++ $(AM_V_CCLD)$(l16mono_la_LINK) -rpath $(codecs_plugindir) $(l16mono_la_OBJECTS) $(l16mono_la_LIBADD) $(LIBS)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)
+@@ -972,7 +971,7 @@ check: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) check-am
+ all-am: Makefile $(LTLIBRARIES)
+ installdirs:
+- for dir in "$(DESTDIR)$(wiretap_plugindir)"; do \
++ for dir in "$(DESTDIR)$(codecs_plugindir)"; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+ install: $(BUILT_SOURCES)
+@@ -1010,7 +1009,7 @@ maintainer-clean-generic:
+ -test -z "$(BUILT_SOURCES)" || rm -f $(BUILT_SOURCES)
+ clean: clean-am
+
+-clean-am: clean-generic clean-libtool clean-wiretap_pluginLTLIBRARIES \
++clean-am: clean-codecs_pluginLTLIBRARIES clean-generic clean-libtool \
+ mostlyclean-am
+
+ distclean: distclean-am
+@@ -1031,7 +1030,7 @@ info: info-am
+
+ info-am:
+
+-install-data-am: install-wiretap_pluginLTLIBRARIES
++install-data-am: install-codecs_pluginLTLIBRARIES
+
+ install-dvi: install-dvi-am
+
+@@ -1077,24 +1076,24 @@ ps: ps-am
+
+ ps-am:
+
+-uninstall-am: uninstall-wiretap_pluginLTLIBRARIES
++uninstall-am: uninstall-codecs_pluginLTLIBRARIES
+
+ .MAKE: all check install install-am install-strip
+
+-.PHONY: CTAGS GTAGS TAGS all all-am check check-am clean clean-generic \
+- clean-libtool clean-wiretap_pluginLTLIBRARIES cscopelist-am \
+- ctags ctags-am distclean distclean-compile distclean-generic \
+- distclean-libtool distclean-tags distdir dvi dvi-am html \
+- html-am info info-am install install-am install-data \
+- install-data-am install-dvi install-dvi-am install-exec \
+- install-exec-am install-html install-html-am install-info \
+- install-info-am install-man install-pdf install-pdf-am \
+- install-ps install-ps-am install-strip \
+- install-wiretap_pluginLTLIBRARIES installcheck installcheck-am \
++.PHONY: CTAGS GTAGS TAGS all all-am check check-am clean \
++ clean-codecs_pluginLTLIBRARIES clean-generic clean-libtool \
++ cscopelist-am ctags ctags-am distclean distclean-compile \
++ distclean-generic distclean-libtool distclean-tags distdir dvi \
++ dvi-am html html-am info info-am install install-am \
++ install-codecs_pluginLTLIBRARIES install-data install-data-am \
++ install-dvi install-dvi-am install-exec install-exec-am \
++ install-html install-html-am install-info install-info-am \
++ install-man install-pdf install-pdf-am install-ps \
++ install-ps-am install-strip installcheck installcheck-am \
+ installdirs maintainer-clean maintainer-clean-generic \
+ mostlyclean mostlyclean-compile mostlyclean-generic \
+ mostlyclean-libtool pdf pdf-am ps ps-am tags tags-am uninstall \
+- uninstall-am uninstall-wiretap_pluginLTLIBRARIES
++ uninstall-am uninstall-codecs_pluginLTLIBRARIES
+
+ .PRECIOUS: Makefile
+
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index 34e07463fee7..1e6327d6620b 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -650,6 +650,7 @@ lib/libwsutil.so.9.0.0
%%ANDROIDDUMP_LIB%%lib/wireshark/extcap/androiddump
%%RANDPKTDUMP_LIB%%lib/wireshark/extcap/randpktdump
%%UDPDUMP_LIB%%lib/wireshark/extcap/udpdump
+lib/wireshark/plugins/2.6/codecs/l16mono.so
lib/wireshark/plugins/2.6/epan/ethercat.so
lib/wireshark/plugins/2.6/epan/gryphon.so
lib/wireshark/plugins/2.6/epan/irda.so
@@ -662,7 +663,6 @@ lib/wireshark/plugins/2.6/epan/unistim.so
lib/wireshark/plugins/2.6/epan/wimax.so
lib/wireshark/plugins/2.6/epan/wimaxasncp.so
lib/wireshark/plugins/2.6/epan/wimaxmacphy.so
-lib/wireshark/plugins/2.6/wiretap/l16mono.so
lib/wireshark/plugins/2.6/wiretap/usbdump.so
libdata/pkgconfig/wireshark.pc
%%ANDROIDDUMP_MAN%%man/man1/androiddump.1.gz