aboutsummaryrefslogtreecommitdiff
path: root/net/wol
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-07 18:00:59 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-07 18:00:59 +0000
commitba285848624bc37a09be5139f14313ffbee97f55 (patch)
treea0b383f48033baa49f4cd39e953b61f9b5caa58b /net/wol
parent1fe2fee346339b4d5460565e9896b4d5ba2bc8ad (diff)
downloadports-ba285848624bc37a09be5139f14313ffbee97f55.tar.gz
ports-ba285848624bc37a09be5139f14313ffbee97f55.zip
utilize USE_GETOPT_LONG
Add missing iconv dependency Clarify COMMENT and pkg-descr Silence configure warning by using CONFIGURE_TARGET PR: 51873 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Notes
Notes: svn path=/head/; revision=80391
Diffstat (limited to 'net/wol')
-rw-r--r--net/wol/Makefile25
-rw-r--r--net/wol/pkg-descr32
-rw-r--r--net/wol/pkg-plist5
3 files changed, 43 insertions, 19 deletions
diff --git a/net/wol/Makefile b/net/wol/Makefile
index bfb358a012ba..e834d8ceb31f 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -8,19 +8,30 @@
PORTNAME= wol
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ahh
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Wake On LAN client
+MAINTAINER= sergei@kolobov.com
+COMMENT= Tool to wake up Wake-On-LAN compliant computers
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ iconv.3:${PORTSDIR}/converters/libiconv
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -liconv -lgnugetopt"
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+DOCS= AUTHORS NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/net/wol/pkg-descr b/net/wol/pkg-descr
index 9d82c30099fd..d87712cf6d33 100644
--- a/net/wol/pkg-descr
+++ b/net/wol/pkg-descr
@@ -1,14 +1,22 @@
-wol implements Wake On LAN functionality in a small program. It wakes up
-hardware that is Magic Packet compliant.
+wol implements Wake-On-LAN functionality in a small program.
+It wakes up hardware that is Magic Packet compliant.
+
+Consider you have a sleeping or turned-off computer
+and you want to wake it up remotely. Just type:
+
+ # wol <MAC-ADDRESS>
+
+and the host wakes up (OK, it will boot ;-).
Features:
- Wakes up various NIC's (tested)
- 3COM 3C905c
- Intel EtherExpress Pro 100
- Linksys Etherfast LNE100TX
- Realtek LFE8139
- LevelOne FNC-0107TX
- Wake up from file (same as /etc/ethers and an enhanced format)
- Sleeping between two wake ups (measured in milliseconds)
-
-WWW: http://ahh.sourceforge.net/wol/
+- Wakes up various NIC's (tested)
+ - 3COM 3C905c
+ - Intel EtherExpress Pro 100
+ - Linksys Etherfast LNE100TX
+ - Realtek LFE8139
+ - LevelOne FNC-0107TX
+- Wake up from file (same as /etc/ethers and an enhanced format)
+- Sleeping between two wake ups (measured in milliseconds)
+
+Author: Thomas Krennwallner <krennwallner@aon.at>
+WWW: http://ahh.sourceforge.net/wol/
diff --git a/net/wol/pkg-plist b/net/wol/pkg-plist
index 4c20455a3ac0..24ebf225638a 100644
--- a/net/wol/pkg-plist
+++ b/net/wol/pkg-plist
@@ -3,6 +3,11 @@ bin/wol-dhcpdconf
@unexec install-info --delete %D/info/wol.info %D/info/dir
info/wol.info
@exec install-info %D/info/wol.info %D/info/dir
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
share/locale/de/LC_MESSAGES/wol.mo
share/locale/fr/LC_MESSAGES/wol.mo
share/locale/it/LC_MESSAGES/wol.mo