aboutsummaryrefslogtreecommitdiff
path: root/net/xbone/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-15 03:28:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-15 03:28:47 +0000
commit9b646cc7a2b381c41ebeb6012075a98b0b884bd8 (patch)
tree87217e3b26c4dcd9cd5f3b70a52691028173b7c5 /net/xbone/Makefile
parent81f9f9ff32b51d1f832218c1fa59293bebde96e9 (diff)
downloadports-9b646cc7a2b381c41ebeb6012075a98b0b884bd8.tar.gz
ports-9b646cc7a2b381c41ebeb6012075a98b0b884bd8.zip
Notes
Diffstat (limited to 'net/xbone/Makefile')
-rw-r--r--net/xbone/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/net/xbone/Makefile b/net/xbone/Makefile
index 5234a91a82bf..dba87e6bf8eb 100644
--- a/net/xbone/Makefile
+++ b/net/xbone/Makefile
@@ -6,20 +6,13 @@
#
PORTNAME= XBone
-PORTVERSION= 3.0
+PORTVERSION= 3.1.1
CATEGORIES= net perl5
MASTER_SITES= http://www.isi.edu/xbone/software/xbone/
MAINTAINER= xbone@isi.edu
COMMENT= Deploys and manages IP-based VPNs (aka "virtual Internets")
-USE_GMAKE= yes
-IS_INTERACTIVE= yes
-NO_BUILD= yes
-USE_PERL5= yes
-
-INSTALL_TARGET= node
-
BUILD_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
${SITE_PERL}/${PERL_ARCH}/IO/Socket/Multicast.pm:${PORTSDIR}/net/p5-IO-Socket-Multicast \
@@ -36,7 +29,15 @@ BUILD_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
- ${SITE_PERL}/${PERL_ARCH}/Socket6.pm:${PORTSDIR}/net/p5-Socket6
+ ${SITE_PERL}/${PERL_ARCH}/Socket6.pm:${PORTSDIR}/net/p5-Socket6 \
+ ${SITE_PERL}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl
+
+USE_GMAKE= yes
+IS_INTERACTIVE= yes
+NO_BUILD= yes
+USE_PERL5= yes
+
+INSTALL_TARGET= node
.include <bsd.port.pre.mk>
@@ -44,10 +45,7 @@ BUILD_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
FORBIDDEN= "X-Bone ${PORTVERSION} does not support FreeBSD prior to 4.7"
.endif
-USE_PERL5= yes
-NO_BUILD= yes
-
-MAN5= XB_Params.pm.5 xbone.conf.5
-MAN8= X-Bone.8 xb-node-daemon.8 xb-config.8
+MAN5= XB_Params.pm.5 xbone.conf.5 xbone-gui.conf.5
+MAN8= X-Bone.8 xb-node-daemon.8 xb-config.8 xb-gui-config.8 xbonectl.8
.include <bsd.port.post.mk>