aboutsummaryrefslogtreecommitdiff
path: root/net/xtraceroute/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2000-02-18 03:22:47 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2000-02-18 03:22:47 +0000
commit95386b01218276fe3da4d68325c5414759d61988 (patch)
tree3bf9ea8662d5aad554cb2133eec229ef964b8090 /net/xtraceroute/Makefile
parent9c65fcfe109174dd90762ae2cddfb7ca326fa0ab (diff)
downloadports-95386b01218276fe3da4d68325c5414759d61988.tar.gz
ports-95386b01218276fe3da4d68325c5414759d61988.zip
Notes
Diffstat (limited to 'net/xtraceroute/Makefile')
-rw-r--r--net/xtraceroute/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net/xtraceroute/Makefile b/net/xtraceroute/Makefile
new file mode 100644
index 000000000000..e238bfacb180
--- /dev/null
+++ b/net/xtraceroute/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: xtraceroute
+# Version required: 0.8.14
+# Date created: 17 February 2000
+# Whom: Maxim Sobolev <sobomax@altavista.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= xtraceroute-0.8.14
+CATEGORIES= net
+MASTER_SITES= http://www.dtek.chalmers.se/~d3august/xt/dl/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DATAFILES}
+
+MAINTAINER= sobomax@altavista.net
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ MesaGL.14:${PORTSDIR}/graphics/Mesa3 \
+ gtkgl.4:${PORTSDIR}/x11-toolkits/gtkglarea \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-GL-prefix=${X11BASE}/lib \
+ --with-lib-MesaGL
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+DATAFILES= ndg_files.tar.gz
+
+MAN1= xtraceroute.1
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/hosts.cache ${PREFIX}/share/xtraceroute
+ ${INSTALL_DATA} ${WRKDIR}/networks.cache ${PREFIX}/share/xtraceroute
+
+.include <bsd.port.mk>