aboutsummaryrefslogtreecommitdiff
path: root/net/ztelnet/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-06-14 16:00:12 +0000
committerSteve Price <steve@FreeBSD.org>1998-06-14 16:00:12 +0000
commit4da4406492cde7d547d718525c46bed2b3b1bb40 (patch)
treef54d19330e7c676d83324a9f7d71c07982a4c876 /net/ztelnet/Makefile
parent6e7b3ce4b77fc218a465adb102a1f3a5a9f942e5 (diff)
downloadports-4da4406492cde7d547d718525c46bed2b3b1bb40.tar.gz
ports-4da4406492cde7d547d718525c46bed2b3b1bb40.zip
Notes
Diffstat (limited to 'net/ztelnet/Makefile')
-rw-r--r--net/ztelnet/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/net/ztelnet/Makefile b/net/ztelnet/Makefile
index 4adf6c243013..cf4b88dd70d7 100644
--- a/net/ztelnet/Makefile
+++ b/net/ztelnet/Makefile
@@ -1,20 +1,23 @@
# New ports collection makefile for: ztelnet
-# Version required: 1.0p2
+# Version required: 1.0p3
# Date created: 15 Mar 1998
# Whom: CHOI Junho <junker@jazz.snu.ac.kr>
#
-# $Id: Makefile,v 1.4 1998/03/18 19:05:33 obrien Exp $
+# $Id: Makefile,v 1.5 1998/03/19 06:12:38 obrien Exp $
#
# In this ports..
# - new compilation diff for FreeBSD(now we can upload!)
# - linux patch(implied -8 and stairway effect) is applied
-# NOTE: in post-patch, we can ignore warnings.
+# - improved sz and rz patch, and new ztelnet manpage(cmascott patch)
+# Thanks to Carl Mascott <cmascott@world.std.com>
+# NOTE: in first post-patch, we can ignore warnings.
DISTNAME= ztelnet2
-PKGNAME= ztelnet-1.0p2
+PKGNAME= ztelnet-1.0p3
CATEGORIES= net
-MASTER_SITES= ftp://jazz.snu.ac.kr/pub/unix/util/net/
-DISTFILES= ztelnet-linux.tar.gz ztelnet-patch.tar.gz
+MASTER_SITES= ftp://jazz.snu.ac.kr/pub/unix/util/net/ztelnet/
+DISTFILES= ztelnet-linux.tar.gz ztelnet-patch.tar.gz \
+ ztelnet-patch-cmascott.tar.gz
MAINTAINER= junker@jazz.snu.ac.kr
@@ -23,9 +26,14 @@ PATCH_STRIP= -p1
MAN1= ztelnet.1
post-patch:
+ # we can ignore warnings
@( cd ${WRKSRC}/ztelnet && \
${PATCH} -s -p1 < ${WRKSRC}/ztelnet.patch || \
true ) > /dev/null 2>&1
+ # but it is not
+ @cd ${WRKSRC}/ztelnet && \
+ ${PATCH} -s -p1 < ${WRKSRC}/rz.patch && \
+ ${PATCH} -s -p1 < ${WRKSRC}/sz.patch
do-build:
@cd ${WRKSRC}/ztelnet && \
@@ -36,6 +44,6 @@ do-install:
@cd ${WRKSRC}/ztelnet; \
${MKDIR} ${PREFIX}/bin; \
${INSTALL_PROGRAM} telnet/telnet ${PREFIX}/bin/ztelnet
- ${INSTALL_MAN} ${WRKDIR}/ztelnet/telnet/telnet.1 ${PREFIX}/man/man1/ztelnet.1
+ ${INSTALL_MAN} ${WRKSRC}/ztelnet.1 ${PREFIX}/man/man1/ztelnet.1
.include <bsd.port.mk>