aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:10:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:10:03 +0000
commit0e9172d28c1bdd6822d27685c9f3aaefc148daab (patch)
tree14bf30d5fe149c09670f6517e05402b9ec2a86c4 /net
parentb25b5d7146aae550c982f2ebe198c14dd0487f50 (diff)
downloadports-0e9172d28c1bdd6822d27685c9f3aaefc148daab.tar.gz
ports-0e9172d28c1bdd6822d27685c9f3aaefc148daab.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-geopy/Makefile30
-rw-r--r--net/py-geopy/distinfo3
-rw-r--r--net/py-geopy/pkg-descr12
4 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bd93073bcf2c..7016054f25ad 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1017,6 +1017,7 @@
SUBDIR += py-eventlet
SUBDIR += py-flask-xml-rpc
SUBDIR += py-gdown
+ SUBDIR += py-geopy
SUBDIR += py-gntp
SUBDIR += py-gspread
SUBDIR += py-h11
diff --git a/net/py-geopy/Makefile b/net/py-geopy/Makefile
new file mode 100644
index 000000000000..3f74afa4beb0
--- /dev/null
+++ b/net/py-geopy/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= geopy
+PORTVERSION= 2.1.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python Geocoding Toolbox
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= geographiclib>=1.49<2:astro/geographiclib
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}async_generator>=0:devel/py-async_generator@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=3.10:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-aiohttp>=0:devel/py-pytest-aiohttp@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
+
+.include <bsd.port.mk>
diff --git a/net/py-geopy/distinfo b/net/py-geopy/distinfo
new file mode 100644
index 000000000000..2aca262642a3
--- /dev/null
+++ b/net/py-geopy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614794184
+SHA256 (geopy-2.1.0.tar.gz) = 892b219413e7955587b029949af3a1949c6fbac9d5ad17b79d850718f6a9550f
+SIZE (geopy-2.1.0.tar.gz) = 107778
diff --git a/net/py-geopy/pkg-descr b/net/py-geopy/pkg-descr
new file mode 100644
index 000000000000..b7e20734b161
--- /dev/null
+++ b/net/py-geopy/pkg-descr
@@ -0,0 +1,12 @@
+geopy is a Python client for several popular geocoding web services.
+
+geopy makes it easy for Python developers to locate the coordinates of
+addresses, cities, countries, and landmarks across the globe using third-party
+geocoders and other data sources.
+
+geopy includes geocoder classes for the OpenStreetMap Nominatim, Google
+Geocoding API (V3), and many other geocoding services. The full list is
+available on the Geocoders doc section. Geocoder classes are located in
+geopy.geocoders.
+
+WWW: https://github.com/geopy/geopy