aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-10-12 10:23:58 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-10-12 10:23:58 +0000
commit1ae3dc300cfa457566308c59fed040f45043df09 (patch)
tree1c40b5c7f8800f4839dfb7c37f68ab6917a00709 /net
parent6192b3b66a74fd2481011f5a3aee000c3a1e8003 (diff)
downloadports-1ae3dc300cfa457566308c59fed040f45043df09.tar.gz
ports-1ae3dc300cfa457566308c59fed040f45043df09.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-glanceclient/Makefile32
-rw-r--r--net/py-glanceclient/distinfo3
-rw-r--r--net/py-glanceclient/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 494f7599f94a..d4b506a5a682 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -962,6 +962,7 @@
SUBDIR += py-dugong
SUBDIR += py-ec2-cli-tools
SUBDIR += py-eventlet
+ SUBDIR += py-glanceclient
SUBDIR += py-gntp
SUBDIR += py-gspread
SUBDIR += py-gspreadsheet
diff --git a/net/py-glanceclient/Makefile b/net/py-glanceclient/Makefile
new file mode 100644
index 000000000000..9c7e885b16b8
--- /dev/null
+++ b/net/py-glanceclient/Makefile
@@ -0,0 +1,32 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= glanceclient
+PORTVERSION= 2.5.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= Client for the OpenStack Glance API
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0:devel/py-prettytable \
+ ${PYTHON_PKGNAMEPREFIX}keystoneclient>=0:net/py-keystoneclient \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}warlock>=0:devel/py-warlock \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.16.0:devel/py-oslo.utils
+
+USES= python shebangfix
+SHEBANG_FILES= glanceclient/tests/functional/hooks/post_test_hook.sh
+USE_PYTHON= distutils autoplist noegginfo
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,install_requires.*,,' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/net/py-glanceclient/distinfo b/net/py-glanceclient/distinfo
new file mode 100644
index 000000000000..511fe89ff44f
--- /dev/null
+++ b/net/py-glanceclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475931722
+SHA256 (python-glanceclient-2.5.0.tar.gz) = 8c510a089fb4dc8355d5db0de608361888b5e4e0c81e0d153ae1b1366bfb8a08
+SIZE (python-glanceclient-2.5.0.tar.gz) = 157864
diff --git a/net/py-glanceclient/pkg-descr b/net/py-glanceclient/pkg-descr
new file mode 100644
index 000000000000..74510513ee8e
--- /dev/null
+++ b/net/py-glanceclient/pkg-descr
@@ -0,0 +1,5 @@
+This is a client for the OpenStack Glance API. There's a Python
+API (the glanceclient module), and a command-line script (glance).
+Each implements 100% of the OpenStack Glance API.
+
+WWW: https://pypi.python.org/pypi/python-glanceclient