aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-11-11 21:26:34 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-11-11 21:26:34 +0000
commit20a59f99d75ee1c48376ca71797a67d89946798c (patch)
tree15c6a77a7ff4737ff6a68fea2779a8e44aa3a77b /net
parentef48806ec07738e418fb9d23f6205ff1d5036381 (diff)
- Work around issue with modern versions of perl/libwww
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=372466
Diffstat (limited to 'net')
-rw-r--r--net/vmware-vsphere-cli/Makefile2
-rw-r--r--net/vmware-vsphere-cli/files/patch-lib__VMware__share__VMware__VICommon.pm43
2 files changed, 44 insertions, 1 deletions
diff --git a/net/vmware-vsphere-cli/Makefile b/net/vmware-vsphere-cli/Makefile
index bf5dce735c52..655dd7efe499 100644
--- a/net/vmware-vsphere-cli/Makefile
+++ b/net/vmware-vsphere-cli/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vmware-vsphere-cli
PORTVERSION= 5.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= #http://communities.vmware.com/community/vmtn/developer/downloads
DISTNAME= VMware-vSphere-Perl-SDK-${PORTVERSION}-${DISTREL}.i386
diff --git a/net/vmware-vsphere-cli/files/patch-lib__VMware__share__VMware__VICommon.pm b/net/vmware-vsphere-cli/files/patch-lib__VMware__share__VMware__VICommon.pm
new file mode 100644
index 000000000000..e54c2115eb8e
--- /dev/null
+++ b/net/vmware-vsphere-cli/files/patch-lib__VMware__share__VMware__VICommon.pm
@@ -0,0 +1,43 @@
+--- lib/VMware/share/VMware/VICommon.pm.orig 2014-11-11 21:22:23 UTC
++++ lib/VMware/share/VMware/VICommon.pm
+@@ -424,16 +424,6 @@
+ my $url = shift;
+ my %supportedapiversions;
+ if ($url =~ s|http(s?)://(.*)/sdk.*|http$1://$2/sdk/vimService.wsdl|i) {
+- if ($1 eq "s") {
+- eval {
+- require Crypt::SSLeay;
+- Crypt::SSLeay->import();
+- };
+- if ($@) {
+- die "Crypt::SSLeay is required for https connections, but could not be loaded: $@";
+- }
+- }
+-
+ my $temp_addr = $2;
+ if ($temp_addr =~ /:/) {
+ if (($temp_addr =~ tr/:/:/) > 1) {
+@@ -501,23 +491,11 @@
+
+ sub query_server_version {
+ BEGIN {
+- #To remove SSL Warning, switching from IO::Socket::SSL to Net::SSL
+- $ENV{PERL_NET_HTTPS_SSL_SOCKET_CLASS} = "Net::SSL";
+ #To remove host verification
+ $ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;
+ }
+ my $url = shift;
+ if ($url =~ s|http(s?)://(.*)/sdk.*|http$1://$2/sdk/vimService.wsdl|i) {
+- # bug 288336
+- if ($1 eq "s") {
+- eval {
+- require Crypt::SSLeay;
+- Crypt::SSLeay->import();
+- };
+- if ($@) {
+- die "Crypt::SSLeay is required for https connections, but could not be loaded: $@";
+- }
+- }
+ # no IPv6 support yet
+ my $temp_addr = $2;
+ if ($temp_addr =~ /:/) {