aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-04-10 15:52:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-04-10 15:52:45 +0000
commit28a0cf7f793adca844e301bb0f9b60277d8bab90 (patch)
tree5c197824ce425ea56291685487cebd090434feb4 /net
parent0d3d6dfa221d50fcbbf175032d93ebf45b5f6ff4 (diff)
downloadports-28a0cf7f793adca844e301bb0f9b60277d8bab90.tar.gz
ports-28a0cf7f793adca844e301bb0f9b60277d8bab90.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/pear-SOAP/Makefile47
1 files changed, 4 insertions, 43 deletions
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index e6a599165f52..c36ca11e681e 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -9,59 +9,20 @@ PORTNAME= SOAP
PORTVERSION= 0.13.0
CATEGORIES= net www pear
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR SOAP Client/Server for PHP
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
LATEST_LINK= pear-SOAP
OPTIONS= PEAR_MAIL "PEAR::Mail support" off \
PEAR_MAIL_MIME "PEAR::Mail::Mime support" off \
PEAR_NET_DIME "PEAR::Net::DIME support" off
-CATEGORY= SOAP
-FILES= SOAP/Base.php SOAP/Client.php SOAP/Disco.php \
- SOAP/Fault.php SOAP/Parser.php \
- SOAP/Server.php SOAP/Transport.php SOAP/Value.php \
- SOAP/WSDL.php \
- SOAP/Transport/HTTP.php SOAP/Transport/SMTP.php \
- SOAP/Transport/TCP.php SOAP/Transport/TEST.php \
- SOAP/Server/Email.php SOAP/Server/Email_Gateway.php \
- SOAP/Server/TCP.php SOAP/Server/TCP/Handler.php \
- SOAP/Type/dateTime.php SOAP/Type/duration.php \
- SOAP/Type/hexBinary.php \
- tools/genproxy.php
-EXAMPLES= attachment.php client.php com_client.php \
- disco_server.php email_client.php email_gateway.php \
- email_pop_gateway.php email_pop_server.php \
- email_server.php example_server.php \
- example_types.php server.php server2.php smtp.php \
- stockquote.php tcp_client.php tcp_daemon.pl \
- tcp_server.php wsdl_client.php
-_EXAMPLESDIR= example
-TESTS= AllTests.php bug1927.phpt bug4523.phpt \
- bug11013.phpt bug12615.phpt bug12880.phpt \
- bug14756.phpt bug16968.phpt bug16968.wsdl \
- dateTime.phpt example.wsdl \
- example_server.phpt example_server_php5.phpt \
- parser.phpt qnames_1.phpt qnames_2.phpt \
- smtp.php SOAP_BugsTest.php test.utility.php \
- wsdl.phpt xmethods.php \
- deserialize/array.phpt deserialize/multiref_1.phpt \
- deserialize/multiref_2.phpt deserialize/multiref_3.phpt \
- deserialize/multiref_4.phpt deserialize/null.phpt \
- deserialize/string.phpt deserialize/struct_1.phpt \
- deserialize/struct_2.phpt deserialize/struct_3.phpt \
- deserialize/struct_4.phpt \
- serialize/string_1.phpt serialize/string_2.phpt \
- serialize/string_doc.phpt serialize/string_doc_literal_1.phpt \
- serialize/string_literal_1.phpt \
- serialize/struct_1.phpt serialize/struct_2.phpt \
- serialize/struct_3.phpt \
- serialize/struct_doc_literal_1.phpt \
- serialize/struct_literal_1.phpt
+PEAR_AUTOINSTALL=yes
.include <bsd.port.pre.mk>