aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2008-09-04 23:09:51 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2008-09-04 23:09:51 +0000
commit35c62df75b5ed765a70ae93a3da55feb76ea77a1 (patch)
treef9d5728dd46c3ffe36b6c3c35f3b2fe9914aa3cd /net
parenta750421cbfef5b66297628d7e65a120211389d5a (diff)
downloadports-35c62df75b5ed765a70ae93a3da55feb76ea77a1.tar.gz
ports-35c62df75b5ed765a70ae93a3da55feb76ea77a1.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/samba3/Makefile30
-rw-r--r--net/samba3/distinfo6
-rw-r--r--net/samba3/files/patch-lib__replace__repdir_getdirentries.c15
-rw-r--r--net/samba3/pkg-plist1
4 files changed, 12 insertions, 40 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 50e1342cb646..d9d460a9f2ff 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= samba
-PORTVERSION?= 3.0.31
-PORTREVISION= 1
+PORTVERSION?= 3.0.32
+PORTREVISION= 0
PORTEPOCH?= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SAMBA}
@@ -69,7 +69,6 @@ OPTIONS= LDAP "With LDAP support" on \
SYSLOG "With Syslog support" off \
QUOTAS "With Disk quota support" off \
UTMP "With UTMP accounting support" on \
- MSDFS "With MSDFS support" on \
PAM_SMBPASS "With PAM authentication vs passdb backends" off \
CLUSTER "With experimental cluster support" off \
DNSUPDATE "With dynamic DNS update(require ADS)" off \
@@ -110,6 +109,10 @@ CONFIGURE_ARGS+= --with-pam --with-readline --with-sendfile-support \
IGNORE= doesn't compile when tdb is installed. Uninstall databases/tdb port
.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
# Let process generate meaningful backtrace on core dump
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
@@ -128,9 +131,9 @@ SUB_LIST+= CUPSD="@comment "
.if defined(WITH_MAX_DEBUG)
LIB_DEPENDS+= dmalloc.1:${PORTSDIR}/devel/dmalloc
-CPPFLAGS+= -g -I${LOCALBASE}/include
-LDFLAGS+= -g -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS+= -g
+LDFLAGS+= -g
+#CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+= --enable-debug --enable-socket-wrapper \
--enable-developer --enable-krb5developer \
--enable-dmalloc --with-profiling-data
@@ -158,12 +161,6 @@ CONFIGURE_ARGS+= --with-utmp
CONFIGURE_ARGS+= --without-utmp
.endif
-.if defined(WITH_MSDFS)
-CONFIGURE_ARGS+= --with-msdfs
-.else
-CONFIGURE_ARGS+= --without-msdfs
-.endif
-
.if !defined(WITHOUT_WINBIND)
CONFIGURE_ARGS+= --with-winbind
PLIST_SUB+= WINBIND=""
@@ -229,15 +226,6 @@ CONFIGURE_ARGS+= --with-aio-support
CONFIGURE_ARGS+= --without-aio-support
.endif
-.if defined(WITH_SMBSH)
-IGNORE= broken IPC and code. Disable SMBSH support
-CONFIGURE_ARGS+= --with-smbwrapper
-PLIST_SUB+= SMBSH=""
-.else
-CONFIGURE_ARGS+= --without-smbwrapper
-PLIST_SUB+= SMBSH="@comment "
-.endif
-
.if defined(WITH_CLUSTER)
CONFIGURE_ARGS+= --with-cluster-support
.else
diff --git a/net/samba3/distinfo b/net/samba3/distinfo
index cbb5c7764ae4..9fdf1d1fa68c 100644
--- a/net/samba3/distinfo
+++ b/net/samba3/distinfo
@@ -1,3 +1,3 @@
-MD5 (samba-3.0.31.tar.gz) = 165abaf4522c70031d9a76fbb638ca06
-SHA256 (samba-3.0.31.tar.gz) = b44f0b0fd79a25b2e6c3f3836a615c5c7d55ac65c460bd68be6380ec77abc28e
-SIZE (samba-3.0.31.tar.gz) = 20514191
+MD5 (samba-3.0.32.tar.gz) = be13b8dbe2785212dba49e7ced352f30
+SHA256 (samba-3.0.32.tar.gz) = 8a7f50e0e85eb0c5c5a9bee7d464367afe09366e66a162cdbb4f13860c0fecd6
+SIZE (samba-3.0.32.tar.gz) = 21679285
diff --git a/net/samba3/files/patch-lib__replace__repdir_getdirentries.c b/net/samba3/files/patch-lib__replace__repdir_getdirentries.c
deleted file mode 100644
index 87072b5fb43b..000000000000
--- a/net/samba3/files/patch-lib__replace__repdir_getdirentries.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- lib/replace/repdir_getdirentries.c.orig Fri Sep 14 05:21:51 2007
-+++ lib/replace/repdir_getdirentries.c Fri Sep 14 05:22:13 2007
-@@ -129,11 +129,7 @@
- d->ofs = 0;
- d->nbytes = 0;
- }
-- /* this relies on seekpos always being a multiple of
-- DIR_BUF_SIZE. Is that always true on BSD systems? */
-- if (d->seekpos & (DIR_BUF_SIZE-1)) {
-- abort();
-- }
-+ /* abort() */
- return d->seekpos + d->ofs;
- }
-
diff --git a/net/samba3/pkg-plist b/net/samba3/pkg-plist
index d65e9cd1b04e..fb7bf8dbbda1 100644
--- a/net/samba3/pkg-plist
+++ b/net/samba3/pkg-plist
@@ -21,7 +21,6 @@ bin/tdbbackup
bin/tdbdump
bin/tdbtool
bin/testparm
-%%SMBSH%%bin/smbsh
%%SMBTORTURE%%bin/smbtorture
%%WINBIND%%bin/wbinfo
sbin/smbd