aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGeorge V. Neville-Neil <gnn@FreeBSD.org>2012-04-11 21:00:51 +0000
committerGeorge V. Neville-Neil <gnn@FreeBSD.org>2012-04-11 21:00:51 +0000
commit39062bb78856a87f926e4e707e43f5119d521b1b (patch)
tree993db2d21bc900229227422007686c0cfd78e833 /net
parentc52f3b5260abb8e11686a1b7337e22bcb08a4104 (diff)
downloadports-39062bb78856a87f926e4e707e43f5119d521b1b.tar.gz
ports-39062bb78856a87f926e4e707e43f5119d521b1b.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ptpd2-devel/Makefile36
-rw-r--r--net/ptpd2-devel/distinfo2
-rw-r--r--net/ptpd2-devel/files/ptpd2.in24
-rw-r--r--net/ptpd2-devel/pkg-descr4
-rw-r--r--net/ptpd2/Makefile1
6 files changed, 68 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8d08dfc9f1c7..33f9cae75b48 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -852,6 +852,7 @@
SUBDIR += prtunnel
SUBDIR += ptpd
SUBDIR += ptpd2
+ SUBDIR += ptpd2-devel
SUBDIR += ptunnel
SUBDIR += pure-sockets
SUBDIR += pvm
diff --git a/net/ptpd2-devel/Makefile b/net/ptpd2-devel/Makefile
new file mode 100644
index 000000000000..a0f12cf5d159
--- /dev/null
+++ b/net/ptpd2-devel/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ptpd
+# Date created: 11 April 2012
+# Whom: George V. Neville-Neil <gnn@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ptpd
+DISTVERSION= 2-RC-0
+CATEGORIES= net
+MASTER_SITES= SF/${PORTNAME}/$(PORTNAME)/2-RC/
+
+MAINTAINER= gnn@FreeBSD.org
+COMMENT= Release candidate for the precision time protocol IEEE 1588-2008
+
+LICENSE= BSD
+
+WRKSRC= ${WRKDIR}/ptpd-${DISTVERSION}/src
+
+CONFLICTS= ptpd-2.[0-9].*
+PLIST_FILES= sbin/ptpd2
+PORTDOCS= *
+
+USE_RC_SUBR= ptpd2
+
+MAN8= ptpd2.8
+
+do-install::
+ ${INSTALL_PROGRAM} ${WRKSRC}/ptpd2 ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MANPREFIX}/man/man8/${MAN8}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKDIR}/ptpd-${DISTVERSION}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ptpd2-devel/distinfo b/net/ptpd2-devel/distinfo
new file mode 100644
index 000000000000..6eab81a2d5fd
--- /dev/null
+++ b/net/ptpd2-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ptpd-2-RC-0.tar.gz) = b479215983e1e82bd8917e885035fd8ff944b87461cee0af08791e21a8e78c4e
+SIZE (ptpd-2-RC-0.tar.gz) = 631328
diff --git a/net/ptpd2-devel/files/ptpd2.in b/net/ptpd2-devel/files/ptpd2.in
new file mode 100644
index 000000000000..cf5c6652e851
--- /dev/null
+++ b/net/ptpd2-devel/files/ptpd2.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/net/ptpd2-devel/files/ptpd2.in,v 1.1 2012-04-11 21:00:51 gnn Exp $
+#
+# PROVIDE: ptpd
+# REQUIRE: NETWORKING DAEMON
+# KEYWORD: nojail
+#
+# Add the following lines to /etc/rc.conf to enable ptpd
+#
+# ptpd_enable (bool): Set to "NO" by default
+# Set it to "YES" to enable ptpd
+
+. /etc/rc.subr
+
+name="ptpd2"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/${name}"
+
+ptpd2_enable=${ptpd2_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/ptpd2-devel/pkg-descr b/net/ptpd2-devel/pkg-descr
new file mode 100644
index 000000000000..ccf6f7a2b77b
--- /dev/null
+++ b/net/ptpd2-devel/pkg-descr
@@ -0,0 +1,4 @@
+This port follows the release candidates from the PTP project. If you
+want the official, released, version of ptp please see net/ptpd2.
+
+WWW: http://ptpd.sourceforge.net/
diff --git a/net/ptpd2/Makefile b/net/ptpd2/Makefile
index ee84767ffc88..86dd5e25b9c7 100644
--- a/net/ptpd2/Makefile
+++ b/net/ptpd2/Makefile
@@ -9,6 +9,7 @@ PORTNAME= ptpd
DISTVERSION= 2.2.0
CATEGORIES= net
MASTER_SITES= SF
+CONFLICTS= ptpd-2.r.*
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Implementation of the precision time protocol IEEE 1588-2008