aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-06-18 07:07:37 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-06-18 07:07:37 +0000
commit398505ca28cbea68cbaf35cbaa63de735e642d30 (patch)
tree979981f88be121db87d89c9d636dae2e9277d481 /net
parentaae3ec4909846313d8f01dd7d8d2875796826f88 (diff)
downloadports-398505ca28cbea68cbaf35cbaa63de735e642d30.tar.gz
ports-398505ca28cbea68cbaf35cbaa63de735e642d30.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-ldap3/Makefile21
-rw-r--r--net/py-ldap3/distinfo2
-rw-r--r--net/py-ldap3/pkg-descr6
4 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f26fde3e1eac..451cb51afc19 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -915,6 +915,7 @@
SUBDIR += py-iplib
SUBDIR += py-kombu
SUBDIR += py-ldap2
+ SUBDIR += py-ldap3
SUBDIR += py-ldaptor
SUBDIR += py-libcloud
SUBDIR += py-libdnet
diff --git a/net/py-ldap3/Makefile b/net/py-ldap3/Makefile
new file mode 100644
index 000000000000..8fc4507880e1
--- /dev/null
+++ b/net/py-ldap3/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= ldap3
+PORTVERSION= 0.9.8.4
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Strictly RFC 4511 conforming LDAP V3 pure Python client
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>0:${PORTSDIR}/devel/py-asn1
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-ldap3/distinfo b/net/py-ldap3/distinfo
new file mode 100644
index 000000000000..a380b132636e
--- /dev/null
+++ b/net/py-ldap3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ldap3-0.9.8.4.tar.gz) = d9efa7f6d4bd4e83201229c6200dcac852e61f23272840065c6ef23b115a0c6a
+SIZE (ldap3-0.9.8.4.tar.gz) = 263317
diff --git a/net/py-ldap3/pkg-descr b/net/py-ldap3/pkg-descr
new file mode 100644
index 000000000000..170cb112d72b
--- /dev/null
+++ b/net/py-ldap3/pkg-descr
@@ -0,0 +1,6 @@
+ldap3 is a pure Python LDAP 3 client library strictly conforming to RFC4511
+released under the LGPL v3 open source license. RFC4511 is the current LDAP
+specification (June 2006) from IETF and obsoletes the previous LDAP RFCs
+2251, 2830, 3771 (December 1997)
+
+WWW: https://github.com/cannatag/ldap3