aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-01 03:22:27 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-01 03:22:27 +0000
commit3fdb725a98282f35666a27a476f8ac6d9205cd81 (patch)
tree335e48ab2481aa7c28838ccbb210366c42c3b8a6 /net
parent245051bca7274722145c6a2fbf7c3091cd6ca639 (diff)
downloadports-3fdb725a98282f35666a27a476f8ac6d9205cd81.tar.gz
ports-3fdb725a98282f35666a27a476f8ac6d9205cd81.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/libetherx/Makefile23
-rw-r--r--net/libetherx/distinfo1
-rw-r--r--net/libetherx/files/patch-aa11
-rw-r--r--net/libetherx/pkg-comment1
-rw-r--r--net/libetherx/pkg-descr6
-rw-r--r--net/libetherx/pkg-plist7
6 files changed, 49 insertions, 0 deletions
diff --git a/net/libetherx/Makefile b/net/libetherx/Makefile
new file mode 100644
index 000000000000..41b84ef1eac8
--- /dev/null
+++ b/net/libetherx/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libetherx
+# Date created: 4 April 2000
+# Whom: Kostya Lukin <lukin@okbmei.msk.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libetherx
+PORTVERSION= 0.9
+CATEGORIES= net
+MASTER_SITES= http://download.jabber.org/dists/0.9/final/
+
+MAINTAINER= lukin@okbmei.msk.su
+
+LIB_DEPENDS= jabber.0:${PORTSDIR}/net/libjabber \
+ pth.13:${PORTSDIR}/devel/pth \
+ adns.0:${PORTSDIR}/net/adns
+
+USE_LIBTOOL= yes
+
+MAN1= etherx-config.1
+
+.include <bsd.port.mk>
diff --git a/net/libetherx/distinfo b/net/libetherx/distinfo
new file mode 100644
index 000000000000..9d480c64d631
--- /dev/null
+++ b/net/libetherx/distinfo
@@ -0,0 +1 @@
+MD5 (libetherx-0.9.tar.gz) = 6cb1b78587d74b53b684dde2b3a3b6af
diff --git a/net/libetherx/files/patch-aa b/net/libetherx/files/patch-aa
new file mode 100644
index 000000000000..e1d848d34a32
--- /dev/null
+++ b/net/libetherx/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.orig Tue Mar 28 13:59:55 2000
++++ configure Mon Apr 10 20:02:14 2000
+@@ -2264,7 +2264,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-ladns $LIBS"
++LIBS="-ladns "-L$prefix/lib" $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2270 "configure"
+ #include "confdefs.h"
diff --git a/net/libetherx/pkg-comment b/net/libetherx/pkg-comment
new file mode 100644
index 000000000000..870ff83c2dd0
--- /dev/null
+++ b/net/libetherx/pkg-comment
@@ -0,0 +1 @@
+Library that routes XML streams among agents
diff --git a/net/libetherx/pkg-descr b/net/libetherx/pkg-descr
new file mode 100644
index 000000000000..e99a38d95589
--- /dev/null
+++ b/net/libetherx/pkg-descr
@@ -0,0 +1,6 @@
+Originally, the etherx daemon routed XML streams among agents.
+Now the etherx daemon has morphed into a library that allows any agent
+to become the daemon if the daemon is not found.
+
+You can learn more about Etherx at
+WWW: http://etherx.jabber.org/
diff --git a/net/libetherx/pkg-plist b/net/libetherx/pkg-plist
new file mode 100644
index 000000000000..eb6bcf84049c
--- /dev/null
+++ b/net/libetherx/pkg-plist
@@ -0,0 +1,7 @@
+bin/etherx-config
+include/etherx.h
+lib/libetherx.a
+lib/libetherx.so
+lib/libetherx.so.0
+@exec /sbin/ldconfig -m %B
+@unexec /sbin/ldconfig -R