aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-10-11 19:56:43 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-10-11 19:56:43 +0000
commit4132f141959d58970d9469d7c881ebfa1bf81038 (patch)
tree8324bbf9c5a39d7defce9fc781e6e3e7bfc0deec /net
parentab3d3fbf4551fad8bd397d511e299a89c7240c28 (diff)
downloadports-4132f141959d58970d9469d7c881ebfa1bf81038.tar.gz
ports-4132f141959d58970d9469d7c881ebfa1bf81038.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/self-service-password/Makefile18
-rw-r--r--net/self-service-password/distinfo5
-rw-r--r--net/self-service-password/pkg-descr2
-rw-r--r--net/self-service-password/pkg-plist5
4 files changed, 18 insertions, 12 deletions
diff --git a/net/self-service-password/Makefile b/net/self-service-password/Makefile
index eb3765cfcf37..1dbd41560a72 100644
--- a/net/self-service-password/Makefile
+++ b/net/self-service-password/Makefile
@@ -2,23 +2,22 @@
# $FreeBSD$
PORTNAME= self-service-password
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9
CATEGORIES= net www
-MASTER_SITES= http://tools.ltb-project.org/attachments/download/497/
-DISTNAME= ltb-project-${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@bsdserwis.com
COMMENT= Set of PHP-scripts to change LDAP password over the web
LICENSE= GPLv2
-NO_BUILD= yes
-NO_ARCH= yes
+USE_GITHUB= yes
+GH_ACCOUNT= ltb-project
-USE_PHP= ldap openssl session hash hash mcrypt mbstring filter
+USES= php:web
+USE_PHP= filter hash ldap mbstring mcrypt openssl session
-WANT_PHP_WEB= yes
+NO_BUILD= yes
+NO_ARCH= yes
CFGDIR= conf
CFGFILE= config.inc.php
@@ -31,8 +30,9 @@ SUB_FILES= pkg-message
post-extract:
@${MV} ${WRKSRC}/${CFGDIR}/${CFGFILE} ${WRKSRC}/${CFGDIR}/${CFGFILE}.sample
+ @${RM} -r ${WRKSRC}/packaging/
do-install:
- @cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/
+ @cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/ "-not -name checklang.pl"
.include <bsd.port.mk>
diff --git a/net/self-service-password/distinfo b/net/self-service-password/distinfo
index 4e48c0a4e68c..23a769d15541 100644
--- a/net/self-service-password/distinfo
+++ b/net/self-service-password/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ltb-project-self-service-password-0.8.tar.gz) = e26d299ed6d2352056d545c3c5c826d296ff7a6152434db25196982dc14359d3
-SIZE (ltb-project-self-service-password-0.8.tar.gz) = 63084
+TIMESTAMP = 1476215618
+SHA256 (ltb-project-self-service-password-0.9_GH0.tar.gz) = 7f265f2c5acdbfecaace6f2b3fe27300c2550886a9343dd09e8fba3ab8550766
+SIZE (ltb-project-self-service-password-0.9_GH0.tar.gz) = 77598
diff --git a/net/self-service-password/pkg-descr b/net/self-service-password/pkg-descr
index 31e872634758..10da2cd19292 100644
--- a/net/self-service-password/pkg-descr
+++ b/net/self-service-password/pkg-descr
@@ -3,4 +3,4 @@ anywhere-accessible, multi-language service to change your LDAP password.
Since it is a web application, this LDAP browser works on many platforms,
making change of your LDAP/AD password accessible from any location.
-WWW: http://ltb-project.org/wiki/documentation/self-service-password/latest/start
+WWW: http://ltb-project.org/wiki/documentation/self-service-password
diff --git a/net/self-service-password/pkg-plist b/net/self-service-password/pkg-plist
index 062d05396d77..aa25f3b0c457 100644
--- a/net/self-service-password/pkg-plist
+++ b/net/self-service-password/pkg-plist
@@ -3,6 +3,7 @@
@sample %%WWWDIR%%/conf/config.inc.php.sample
%%WWWDIR%%/index.php
%%WWWDIR%%/lang/ca.inc.php
+%%WWWDIR%%/lang/cn.inc.php
%%WWWDIR%%/lang/de.inc.php
%%WWWDIR%%/lang/en.inc.php
%%WWWDIR%%/lang/es.inc.php
@@ -11,7 +12,11 @@
%%WWWDIR%%/lang/nl.inc.php
%%WWWDIR%%/lang/pl.inc.php
%%WWWDIR%%/lang/pt-BR.inc.php
+%%WWWDIR%%/lang/pt-PT.inc.php
%%WWWDIR%%/lang/ru.inc.php
+%%WWWDIR%%/lang/sk.inc.php
+%%WWWDIR%%/lang/sl.inc.php
+%%WWWDIR%%/lang/zh-CN.inc.php
%%WWWDIR%%/lib/detectbrowserlanguage.php
%%WWWDIR%%/lib/functions.inc.php
%%WWWDIR%%/lib/recaptchalib.php