aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-05-04 10:25:35 +0000
committerRene Ladan <rene@FreeBSD.org>2014-05-04 10:25:35 +0000
commit496193d869a804c89a9888cf31ea076b3fb7eead (patch)
treef36a7ceda39de4cc8499f4d21fac5bd37c6e666e /net
parenta0f79f2d13daa19f590bd568811873d1497bbfbc (diff)
downloadports-496193d869a804c89a9888cf31ea076b3fb7eead.tar.gz
ports-496193d869a804c89a9888cf31ea076b3fb7eead.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/wackamole/Makefile18
-rw-r--r--net/wackamole/distinfo2
-rw-r--r--net/wackamole/files/patch-alarm.c20
-rw-r--r--net/wackamole/files/patch-config_gram.y11
-rw-r--r--net/wackamole/files/patch-configuration.c11
-rw-r--r--net/wackamole/files/patch-defines.h28
-rw-r--r--net/wackamole/files/patch-wackamole.c20
-rw-r--r--net/wackamole/pkg-descr15
-rw-r--r--net/wackamole/pkg-plist6
10 files changed, 0 insertions, 132 deletions
diff --git a/net/Makefile b/net/Makefile
index ca5efdfb7a7a..1d2c276e4508 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1240,7 +1240,6 @@
SUBDIR += vortex
SUBDIR += vserver
SUBDIR += vtun
- SUBDIR += wackamole
SUBDIR += wackford-squeers
SUBDIR += wakeonlan
SUBDIR += whois
diff --git a/net/wackamole/Makefile b/net/wackamole/Makefile
deleted file mode 100644
index bc90faaf7941..000000000000
--- a/net/wackamole/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-# Created by: Marcin Cieslak <saper@system.pl>
-# $FreeBSD$
-
-PORTNAME= wackamole
-PORTVERSION= 2.1.4
-CATEGORIES= net
-MASTER_SITES= http://mirrors.omniti.com/wackamole/
-
-MAINTAINER= saper@saper.info
-COMMENT= Peer-to-peer high availability cluster
-
-LIB_DEPENDS= spread.1:${PORTSDIR}/net/spread
-
-GNU_CONFIGURE= yes
-
-CONFIGURE_ENV+= YACC=${YACC}
-
-.include <bsd.port.mk>
diff --git a/net/wackamole/distinfo b/net/wackamole/distinfo
deleted file mode 100644
index 775d66315987..000000000000
--- a/net/wackamole/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (wackamole-2.1.4.tar.gz) = ee22b581bc150eeb358ac1a1e53776121a249383c6a68319c148ea51b4668c73
-SIZE (wackamole-2.1.4.tar.gz) = 139767
diff --git a/net/wackamole/files/patch-alarm.c b/net/wackamole/files/patch-alarm.c
deleted file mode 100644
index 298786187c42..000000000000
--- a/net/wackamole/files/patch-alarm.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- alarm.c.orig 2011-05-12 02:48:08.000000000 +0200
-+++ alarm.c 2011-05-12 02:48:40.000000000 +0200
-@@ -93,7 +93,7 @@
- timestamp[length] = ' ';
- #ifdef HAVE_SYSLOG_H
- if(syslog_flag)
-- syslog(LOG_NOTICE, timestamp);
-+ syslog(LOG_NOTICE, "%s", timestamp);
- else
- #endif
- fwrite(timestamp, length+1, sizeof(char), stdout);
-@@ -105,7 +105,7 @@
- int len = strlen(message)+100;
- s = malloc(len);/*estimation*/
- vsnprintf(s,len,message, ap);
-- syslog(LOG_NOTICE, s);
-+ syslog(LOG_NOTICE, "%s", s);
- free(s);
- }
- else
diff --git a/net/wackamole/files/patch-config_gram.y b/net/wackamole/files/patch-config_gram.y
deleted file mode 100644
index 33165689d5b9..000000000000
--- a/net/wackamole/files/patch-config_gram.y
+++ /dev/null
@@ -1,11 +0,0 @@
---- config_gram.y.orig 2011-05-12 02:54:26.000000000 +0200
-+++ config_gram.y 2011-05-12 02:55:18.000000000 +0200
-@@ -106,7 +106,7 @@
- SPIT("Setting Group: %s\n", Spread_group); }
- | W_LOG W_EQUALS W_STRING
- | W_CONTROL W_EQUALS W_STRING
-- { snprintf(control_socket, MAXPATHLEN, $3.string); }
-+ { snprintf(control_socket, MAXPATHLEN, "%s", $3.string); }
- | W_MATURE W_EQUALS W_TIMEINTERVAL
- { Maturity_timeout.sec = $3.tv.tv_sec;
- Maturity_timeout.usec = 0;
diff --git a/net/wackamole/files/patch-configuration.c b/net/wackamole/files/patch-configuration.c
deleted file mode 100644
index 0d12d3ef1ee8..000000000000
--- a/net/wackamole/files/patch-configuration.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- configuration.c.orig 2011-05-12 02:55:52.000000000 +0200
-+++ configuration.c 2011-05-12 02:56:03.000000000 +0200
-@@ -43,7 +43,7 @@
- char my_local_host_name[255];
- static const size_t my_local_host_name_len=255;
- struct hostent *hent;
-- int i, full;
-+ int full;
- Num_prefer = 0;
-
- if (File_name && File_name[0] && (NULL != (fp = fopen(File_name,"r"))) )
diff --git a/net/wackamole/files/patch-defines.h b/net/wackamole/files/patch-defines.h
deleted file mode 100644
index 11846f389a6c..000000000000
--- a/net/wackamole/files/patch-defines.h
+++ /dev/null
@@ -1,28 +0,0 @@
---- defines.h.orig 2005-03-30 21:56:58.000000000 +0200
-+++ defines.h 2011-05-12 02:51:55.000000000 +0200
-@@ -13,6 +13,9 @@
- #ifdef HAVE_STRINGS_H
- #include <strings.h>
- #endif
-+#ifdef HAVE_STRING_H
-+#include <string.h>
-+#endif
- #ifdef HAVE_ERRNO_H
- #include <errno.h>
- #endif
-@@ -59,12 +62,12 @@
- #ifdef HAVE_NET_ROUTE_H
- #include <net/route.h>
- #endif
--#ifdef HAVE_PCAP_H
--#include <pcap.h>
--#endif
- #ifdef HAVE_NET_BPF_H
- #include <net/bpf.h>
- #endif
-+#ifdef HAVE_PCAP_H
-+#include <pcap.h>
-+#endif
- #ifdef HAVE_NET_ETHERNET_H
- #include <net/ethernet.h>
- #endif
diff --git a/net/wackamole/files/patch-wackamole.c b/net/wackamole/files/patch-wackamole.c
deleted file mode 100644
index b2d2b36e9957..000000000000
--- a/net/wackamole/files/patch-wackamole.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- wackamole.c.orig 2011-05-12 02:43:02.000000000 +0200
-+++ wackamole.c 2011-05-12 02:46:20.000000000 +0200
-@@ -911,7 +911,7 @@
- wack_alarm(PRINT, "%d %s", __LINE__, if_error());
- else {
- char buffer[16];
-- snprintf(buffer, 16, inet_ntoa(iface.ipaddr));
-+ snprintf(buffer, 16, "%s", inet_ntoa(iface.ipaddr));
- wack_alarm(PRINT, " UP: %s:%s/%s",
- iface.ifname,buffer,inet_ntoa(iface.netmask));
- }
-@@ -954,7 +954,7 @@
- }
- } else {
- char buffer[16];
-- snprintf(buffer, 16, inet_ntoa(idown.ipaddr));
-+ snprintf(buffer, 16, "%s", inet_ntoa(idown.ipaddr));
- wack_alarm(PRINT, "DOWN: %s:%s/%s",
- idown.ifname,buffer,inet_ntoa(idown.netmask));
- }
diff --git a/net/wackamole/pkg-descr b/net/wackamole/pkg-descr
deleted file mode 100644
index ffd27dd41b80..000000000000
--- a/net/wackamole/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-Wackamole is an application that helps with making a cluster highly
-available.
-
-It manages a bunch of virtual IPs, that should be available
-to the outside world at all times. Wackamole ensures that a single
-machine within a cluster is listening on each virtual IP address
-that Wackamole manages. If it discovers that particular machines
-within the cluster are not alive, it will almost immediately ensure
-that other machines acquire these public IPs.
-At no time will more than one machine listen on any virtual IP.
-
-Wackamole also works toward achieving a balanced distribution of
-number IPs on the machine within the cluster it manages.
-
-WWW: http://www.backhand.org/wackamole/
diff --git a/net/wackamole/pkg-plist b/net/wackamole/pkg-plist
deleted file mode 100644
index 3d0150b96760..000000000000
--- a/net/wackamole/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-etc/wackamole.conf.sample
-sbin/wackamole
-sbin/wackatrl
-man/man5/wackamole.conf.5.gz
-man/man8/wackamole.8.gz
-man/man8/wackatrl.8.gz