aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2008-02-22 13:50:33 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2008-02-22 13:50:33 +0000
commit4e20dc2276fa5fc9a73bb41dc1bc9fccc8c3f097 (patch)
treeee7731ece7e93bf6c4d50371a5f65541ba4bfdd5 /net
parent934175c3217de04d056fcf33cdfd5af019e6b494 (diff)
downloadports-4e20dc2276fa5fc9a73bb41dc1bc9fccc8c3f097.tar.gz
ports-4e20dc2276fa5fc9a73bb41dc1bc9fccc8c3f097.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/spnetkit/Makefile30
-rw-r--r--net/spnetkit/distinfo3
-rw-r--r--net/spnetkit/files/patch-Makefile8
-rw-r--r--net/spnetkit/files/patch-spnklog.cpp11
-rw-r--r--net/spnetkit/files/patch-spnksocket.hpp10
-rw-r--r--net/spnetkit/files/patch-testhttpcli.cpp11
-rw-r--r--net/spnetkit/files/patch-testmemcli.cpp11
-rw-r--r--net/spnetkit/files/patch-testmemproto.cpp11
-rw-r--r--net/spnetkit/pkg-descr7
-rw-r--r--net/spnetkit/pkg-plist25
11 files changed, 128 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5367a84e3413..b6456939c734 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -850,6 +850,7 @@
SUBDIR += socketpipe
SUBDIR += socks5
SUBDIR += splatd
+ SUBDIR += spnetkit
SUBDIR += spoofer
SUBDIR += spread
SUBDIR += spread-j
diff --git a/net/spnetkit/Makefile b/net/spnetkit/Makefile
new file mode 100644
index 000000000000..e446ae8be22c
--- /dev/null
+++ b/net/spnetkit/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: spnetkit
+# Date created: 18 Feb 2008
+# Whom: vanilla@
+#
+# $FreeBSD$
+#
+
+PORTNAME= spnetkit
+PORTVERSION= 0.2.0
+CATEGORIES= net
+MASTER_SITES= http://spnetkit.googlecode.com/files/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= A C++ wrapper for BSD-style sockets
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/spnetkit
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+ALL_TARGET= all ssl
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/spnetkit
+ @${INSTALL} ${WRKSRC}/*.hpp ${PREFIX}/include/spnetkit
+ @${INSTALL} ${WRKSRC}/libspnetkit.so.0 ${PREFIX}/lib
+ @${LN} -s ${PREFIX}/lib/libspnetkit.so.0 ${PREFIX}/lib/libspnetkit.so
+ @${INSTALL} ${WRKSRC}/libspnetkit_s.so.0 ${PREFIX}/lib
+ @${LN} -s ${PREFIX}/lib/libspnetkit_s.so.0 ${PREFIX}/lib/libspnetkit_s.so
+
+.include <bsd.port.mk>
diff --git a/net/spnetkit/distinfo b/net/spnetkit/distinfo
new file mode 100644
index 000000000000..931e148c846f
--- /dev/null
+++ b/net/spnetkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (spnetkit-0.2.0.src.tar.gz) = 8fccddbc8bd5de9a498ce6eaecb9cfc1
+SHA256 (spnetkit-0.2.0.src.tar.gz) = a37c30936e764f47b70459c20a13f0a0d75842d9a0856a7c8e9962ba89c47455
+SIZE (spnetkit-0.2.0.src.tar.gz) = 48207
diff --git a/net/spnetkit/files/patch-Makefile b/net/spnetkit/files/patch-Makefile
new file mode 100644
index 000000000000..815d11f6db9a
--- /dev/null
+++ b/net/spnetkit/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig 2008-02-18 14:11:22.000000000 +0800
++++ Makefile 2008-02-18 14:10:32.000000000 +0800
+@@ -1,3 +1,5 @@
++version = 0
++
+ include ../port/port.mk
+
+ #--------------------------------------------------------------------
diff --git a/net/spnetkit/files/patch-spnklog.cpp b/net/spnetkit/files/patch-spnklog.cpp
new file mode 100644
index 000000000000..c4784107c742
--- /dev/null
+++ b/net/spnetkit/files/patch-spnklog.cpp
@@ -0,0 +1,11 @@
+--- spnklog.cpp.orig 2008-02-18 12:19:32.000000000 +0800
++++ spnklog.cpp 2008-02-18 12:19:41.000000000 +0800
+@@ -107,7 +107,7 @@
+ snprintf( logText, sizeof( logText ),
+ "%04i-%02i-%02i %02i:%02i:%02i #%i ",
+ 1900 + tmTime.tm_year, tmTime.tm_mon+1, tmTime.tm_mday,
+- tmTime.tm_hour, tmTime.tm_min, tmTime.tm_sec, (int)pthread_self() );
++ tmTime.tm_hour, tmTime.tm_min, tmTime.tm_sec, pthread_self() );
+ }
+
+ if( mIsLogPriName ) {
diff --git a/net/spnetkit/files/patch-spnksocket.hpp b/net/spnetkit/files/patch-spnksocket.hpp
new file mode 100644
index 000000000000..6635eedcf42b
--- /dev/null
+++ b/net/spnetkit/files/patch-spnksocket.hpp
@@ -0,0 +1,10 @@
+--- spnksocket.hpp.orig 2008-02-18 12:21:26.000000000 +0800
++++ spnksocket.hpp 2008-02-18 12:21:43.000000000 +0800
+@@ -6,6 +6,7 @@
+ #ifndef __spnksocket_hpp__
+ #define __spnksocket_hpp__
+
++#include <sys/time.h>
+ #include <sys/socket.h>
+
+ class SP_NKSocket {
diff --git a/net/spnetkit/files/patch-testhttpcli.cpp b/net/spnetkit/files/patch-testhttpcli.cpp
new file mode 100644
index 000000000000..79d6b440b907
--- /dev/null
+++ b/net/spnetkit/files/patch-testhttpcli.cpp
@@ -0,0 +1,11 @@
+--- testhttpcli.cpp.orig 2008-02-18 12:22:11.000000000 +0800
++++ testhttpcli.cpp 2008-02-18 12:24:00.000000000 +0800
+@@ -35,7 +35,7 @@
+
+ int main( int argc, char * argv[] )
+ {
+- assert ( sigset ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
++ assert ( signal ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
+
+ SP_NKLog::init4test( "testhttpcli" );
+ SP_NKLog::setLogLevel( LOG_DEBUG );
diff --git a/net/spnetkit/files/patch-testmemcli.cpp b/net/spnetkit/files/patch-testmemcli.cpp
new file mode 100644
index 000000000000..eccf81a36176
--- /dev/null
+++ b/net/spnetkit/files/patch-testmemcli.cpp
@@ -0,0 +1,11 @@
+--- testmemcli.cpp.orig 2008-02-18 12:24:33.000000000 +0800
++++ testmemcli.cpp 2008-02-18 12:24:40.000000000 +0800
+@@ -98,7 +98,7 @@
+
+ int main( int argc, char * argv[] )
+ {
+- assert ( sigset ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
++ assert ( signal ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
+
+ const char * config = "testmemcli.ini";
+ int loops = 100;
diff --git a/net/spnetkit/files/patch-testmemproto.cpp b/net/spnetkit/files/patch-testmemproto.cpp
new file mode 100644
index 000000000000..60cac773d7b1
--- /dev/null
+++ b/net/spnetkit/files/patch-testmemproto.cpp
@@ -0,0 +1,11 @@
+--- testmemproto.cpp.orig 2008-02-18 12:24:14.000000000 +0800
++++ testmemproto.cpp 2008-02-18 12:24:24.000000000 +0800
+@@ -138,7 +138,7 @@
+
+ int main( int argc, char * argv[] )
+ {
+- assert ( sigset ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
++ assert ( signal ( SIGPIPE, SIG_IGN ) != SIG_ERR ) ;
+
+ const char * host = "127.0.0.1";
+ int port = 11211, loops = 100;
diff --git a/net/spnetkit/pkg-descr b/net/spnetkit/pkg-descr
new file mode 100644
index 000000000000..de15a1d8642f
--- /dev/null
+++ b/net/spnetkit/pkg-descr
@@ -0,0 +1,7 @@
+spnetkit is a C++ wrapper for BSD-style sockets.
+It implements the TCP, UDP, SSL transport layer protocols.
+Implemented application layer protocols are HTTP client, SMTP client,
+POP3 client and memcached client. Features include an inifile reader,
+base64 codec.
+
+WWW: http://code.google.com/p/spnetkit/
diff --git a/net/spnetkit/pkg-plist b/net/spnetkit/pkg-plist
new file mode 100644
index 000000000000..d96d698549cc
--- /dev/null
+++ b/net/spnetkit/pkg-plist
@@ -0,0 +1,25 @@
+include/spnetkit/spnkbase64.hpp
+include/spnetkit/spnkendpoint.hpp
+include/spnetkit/spnkfile.hpp
+include/spnetkit/spnkhash.hpp
+include/spnetkit/spnkhttpcli.hpp
+include/spnetkit/spnkhttpmsg.hpp
+include/spnetkit/spnkini.hpp
+include/spnetkit/spnklist.hpp
+include/spnetkit/spnklog.hpp
+include/spnetkit/spnkmemcli.hpp
+include/spnetkit/spnkmemobj.hpp
+include/spnetkit/spnkpop3cli.hpp
+include/spnetkit/spnkreader.hpp
+include/spnetkit/spnksmtpaddr.hpp
+include/spnetkit/spnksmtpcli.hpp
+include/spnetkit/spnksocket.hpp
+include/spnetkit/spnksocketpool.hpp
+include/spnetkit/spnksslsocket.hpp
+include/spnetkit/spnkstr.hpp
+include/spnetkit/spnktime.hpp
+lib/libspnetkit.so
+lib/libspnetkit.so.0
+lib/libspnetkit_s.so
+lib/libspnetkit_s.so.0
+@dirrm include/spnetkit