aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-19 00:03:18 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-19 00:03:18 +0000
commit5dbaeddbcb84562363ed94714c91738410f730ed (patch)
treee627763d8f541c4d4961876a26457cdaa1be7183 /net
parent159b9d4db22cad7383d0eb8e3ddb8bae6c8c6c36 (diff)
downloadports-5dbaeddbcb84562363ed94714c91738410f730ed.tar.gz
ports-5dbaeddbcb84562363ed94714c91738410f730ed.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/freeswitch-devel/Makefile33
1 files changed, 19 insertions, 14 deletions
diff --git a/net/freeswitch-devel/Makefile b/net/freeswitch-devel/Makefile
index 7e512aabddc2..1d5926470d43 100644
--- a/net/freeswitch-devel/Makefile
+++ b/net/freeswitch-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= freeswitch
-PORTVERSION= 1.2
+PORTVERSION= 1.2.1
CATEGORIES= net
MASTER_SITES= # none
PKGNAMESUFFIX= -devel
@@ -23,19 +23,24 @@ CONFLICTS= freeswitch-core-[0-9]*
NO_WRKSUBDIR= yes
NO_BUILD= yes
-OPTIONS= VANILLA "Vanilla Dialplan Configs" off \
- SBC "Session Border Conroller configs" off \
- INSIDEOUT "Inside Out Basic Dialplan Configs" off \
- CURL "Curl dialplan configs" off \
- SOUNDS "Sound files for use with FreeSwitch PBX" off \
- MUSIC "Music on hold for use with FreeSwitch PBX" off \
- PIZZADEMO "Install Pizza Shop voice demo" off \
- SCRIPTS "Install Freeswitch various scripts" off
+OPTIONS_DEFINE= VANILLA SBC INSIDEOUT CURL SOUNDS MUSIC PIZZADEMO SCRIPTS
+
+VANILLA_DESC= Vanilla Dialplan Configs
+SBC_DESC= Session Border Conroller configs
+INSIDEOUT_DESC= Inside Out Basic Dialplan Configs
+CURL_DESC= Curl dialplan configs
+SOUNDS_DESC= Sound files for use with FreeSwitch PBX
+MUSIC_DESC= Music on hold for use with FreeSwitch PBX
+PIZZADEMO_DESC= Install Pizza Shop voice demo
+SCRIPTS_DESC= Install Freeswitch various scripts
+
+OPTIONS_DEFAULT= VANILLA SOUNDS MUSIC
+NO_OPTIONS_SORT= yes
.include <bsd.port.options.mk>
.for conf in vanilla sbc insideout curl
-. if defined(WITH_${conf:U})
+.if ${PORT_OPTIONS:M${conf:U}}
CNF?= ${conf}
. if ${CNF} == ${conf}
RUN_DEPENDS+= ${LOCALBASE}/etc/freeswitch/conf/.${conf}:${PORTSDIR}/net/freeswitch-${conf}-devel
@@ -46,19 +51,19 @@ IGNORE= will not allow multiple configuration options selected
.endfor
.undef CNF
-.if defined(WITH_SOUNDS)
+.if ${PORT_OPTIONS:MSOUNDS}
RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-sounds:${PORTSDIR}/audio/freeswitch-sounds
.endif
-.if defined(WITH_MUSIC)
+.if ${PORT_OPTIONS:MMUSIC}
RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-music:${PORTSDIR}/audio/freeswitch-music
.endif
-.if defined(WITH_PIZZADEMO)
+.if ${PORT_OPTIONS:MPIZZADEMO}
RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.pizza:${PORTSDIR}/misc/freeswitch-pizzademo-devel
.endif
-.if defined(WITH_SCRIPTS)
+.if ${PORT_OPTIONS:MSCRIPTS}
RUN_DEPENDS+= ${LOCALBASE}/etc/freeswitch/scripts/.freeswitch-scripts:${PORTSDIR}/misc/freeswitch-scripts-devel
.endif