aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-02 11:58:21 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-02 11:58:21 +0000
commit8b4093cba5775260e98d51f74cd187fb9af825a8 (patch)
tree4a28bf50f532fa82a149cbc3f9c041d48a23921b /net
parentf38d6cb92bbd96d100bae02b23ace94acea1cf8e (diff)
downloadports-8b4093cba5775260e98d51f74cd187fb9af825a8.tar.gz
ports-8b4093cba5775260e98d51f74cd187fb9af825a8.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/bctoolbox/Makefile2
-rw-r--r--net/chrony/Makefile2
-rw-r--r--net/h323plus/Makefile2
-rw-r--r--net/kamailio/Makefile13
-rw-r--r--net/libp0f/Makefile2
-rw-r--r--net/linphone/Makefile2
-rw-r--r--net/mosquitto/Makefile2
-rw-r--r--net/openggsn/Makefile2
-rw-r--r--net/openntpd/Makefile2
-rw-r--r--net/opensips/Makefile15
-rw-r--r--net/whois/Makefile2
-rw-r--r--net/yate/Makefile2
12 files changed, 23 insertions, 25 deletions
diff --git a/net/bctoolbox/Makefile b/net/bctoolbox/Makefile
index e2049494fe0b..72524d8b7e0d 100644
--- a/net/bctoolbox/Makefile
+++ b/net/bctoolbox/Makefile
@@ -22,7 +22,7 @@ INSTALL_TARGET= install-strip
USES= libtool pathfix pkgconfig
USE_LDCONFIG= yes
-post-stage:
+post-install:
${RM} ${STAGEDIR}${PREFIX}/libdata/pkgconfig/bctoolbox-tester.pc
.include <bsd.port.mk>
diff --git a/net/chrony/Makefile b/net/chrony/Makefile
index 293dca76bcee..e8535d865865 100644
--- a/net/chrony/Makefile
+++ b/net/chrony/Makefile
@@ -40,7 +40,7 @@ OPTIONS_DEFINE= IPV6
IPV6_CATEGORIES= ipv6
IPV6_CONFIGURE_OFF= --disable-ipv6
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chronyc
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/chronyd
${INSTALL_DATA} ${EXTRAPORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/net/h323plus/Makefile b/net/h323plus/Makefile
index 1448ed522474..a497f45a6b96 100644
--- a/net/h323plus/Makefile
+++ b/net/h323plus/Makefile
@@ -27,7 +27,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE=yes
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libh323.so.1.26.5
.include <bsd.port.mk>
diff --git a/net/kamailio/Makefile b/net/kamailio/Makefile
index 21ef4360092f..0e90d9aeec24 100644
--- a/net/kamailio/Makefile
+++ b/net/kamailio/Makefile
@@ -136,7 +136,12 @@ pre-build:
do-build:
cd ${WRKSRC} && ${GMAKE} ${ALL_TARGET}
-post-stage:
+do-install:
+ cd ${WRKSRC} && ${GMAKE} ${INSTALL_TARGET}
+.if ! ${PORT_OPTIONS:MMYSQL} && ! ${PORT_OPTIONS:MPGSQL}
+ ${RMDIR} ${STAGEDIR}${PREFIX}/share/${PORTNAME}
+.endif
+
# Strip modules in lib/kamailio/modules
@${ECHO_CMD} "Stripping modules in ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/modules/"
@@ -195,10 +200,4 @@ post-stage:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/${k}
.endfor
-do-install:
- cd ${WRKSRC} && ${GMAKE} ${INSTALL_TARGET}
-.if ! ${PORT_OPTIONS:MMYSQL} && ! ${PORT_OPTIONS:MPGSQL}
- ${RMDIR} ${STAGEDIR}${PREFIX}/share/${PORTNAME}
-.endif
-
.include <bsd.port.mk>
diff --git a/net/libp0f/Makefile b/net/libp0f/Makefile
index 1b319f6e2864..e77d5380d362 100644
--- a/net/libp0f/Makefile
+++ b/net/libp0f/Makefile
@@ -19,7 +19,7 @@ INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig tar:tgz
USE_LDCONFIG= yes
-post-stage:
+post-install:
${RM} ${STAGEDIR}${LOCALBASE}/bin/p0f
${MV} ${STAGEDIR}/etc/p0f ${STAGEDIR}${LOCALBASE}/etc/libp0f
${RM} -r ${STAGEDIR}/etc
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 017f50a1b8bc..06a6b95c368b 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -58,7 +58,7 @@ VIDEO_CONFIGURE_ENABLE= video
CONFIGURE_ARGS+=--enable-debug
.endif
-post-stage:
+post-install:
${RM} -r ${STAGEDIR}${PREFIX}/share/gnome
.include <bsd.port.mk>
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 44d653fce4e7..53babc78ee60 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -33,7 +33,7 @@ post-patch:
${REINPLACE_CMD} -e '/ldconfig/d' ${WRKSRC}/src/CMakeLists.txt \
${WRKSRC}/lib/CMakeLists.txt ${WRKSRC}/lib/cpp/CMakeLists.txt
-post-stage:
+post-install:
# Adjust configuration files
${MV} ${STAGEDIR}${ETCDIR}/mosquitto.conf ${STAGEDIR}${ETCDIR}/mosquitto.conf.sample
${MV} ${STAGEDIR}${ETCDIR}/pwfile.example ${STAGEDIR}${ETCDIR}/pwfile.sample
diff --git a/net/openggsn/Makefile b/net/openggsn/Makefile
index 6c59c25a61c2..950121521844 100644
--- a/net/openggsn/Makefile
+++ b/net/openggsn/Makefile
@@ -22,7 +22,7 @@ USE_LDCONFIG= yes
post-patch:
${ECHO_CMD} ${PORTVERSION} > ${WRKSRC}/.tarball-version
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgtp.so.0
.include <bsd.port.mk>
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index 56eb52892345..6378604954f4 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -27,7 +27,7 @@ pre-build:
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/src/ntpd.conf.5 ${WRKSRC}/src/ntpd.8
-post-stage:
+post-install:
cd ${STAGEDIR}${PREFIX}/etc && ${MV} ntpd.conf ntpd.conf.sample
.include <bsd.port.pre.mk>
diff --git a/net/opensips/Makefile b/net/opensips/Makefile
index c16c3015381d..22b0d41ff637 100644
--- a/net/opensips/Makefile
+++ b/net/opensips/Makefile
@@ -173,20 +173,19 @@ do-build:
do-install:
cd ${WRKSRC} && ${OPENSIPS_MAKE_ENV} ${GMAKE} ${INSTALL_TARGET}
-do-install-TESTS-on:
- (cp -r ${WRKSRC}/test ${STAGEDIR}${PREFIX}/tests/opensips)
-
-do-install-EXAMPLES-on:
- (cp -r ${WRKSRC}/examples ${STAGEDIR}${PREFIX}/share/examples/opensips)
-
-post-stage:
@${REINPLACE_CMD} -e "s|^# MD5=.*|MD5=\"md5\"|" ${STAGEDIR}${PREFIX}/etc/opensips/opensipsctlrc.sample
@${REINPLACE_CMD} -e "s|^# GREP=.*|GREP=\"${LOCALBASE}/bin/grep\"|" ${STAGEDIR}${PREFIX}/etc/opensips/opensipsctlrc.sample
@${REINPLACE_CMD} -e "s|^# MD5=.*|MD5=\"md5\"|" ${STAGEDIR}${PREFIX}/etc/opensips/osipsconsolerc.sample
@${REINPLACE_CMD} -e "s|^# GREP=.*|GREP=\"${LOCALBASE}/bin/egrep\"|" ${STAGEDIR}${PREFIX}/etc/opensips/osipsconsolerc.sample
(cp ${FILESDIR}/opensips.cfg.sample ${STAGEDIR}${ETCDIR}/opensips.cfg.sample)
-post-stage-RADIUS-on:
+do-install-TESTS-on:
+ (cp -r ${WRKSRC}/test ${STAGEDIR}${PREFIX}/tests/opensips)
+
+do-install-EXAMPLES-on:
+ (cp -r ${WRKSRC}/examples ${STAGEDIR}${PREFIX}/share/examples/opensips)
+
+post-install-RADIUS-on:
(mv ${STAGEDIR}${ETCDIR}/dictionary.opensips ${STAGEDIR}${ETCDIR}/dictionary.opensips.sample)
# Strip binaries in sbin
diff --git a/net/whois/Makefile b/net/whois/Makefile
index 90a5837cb2c6..5619e0c29d12 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -40,7 +40,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|# define ENABLE_NLS||" ${WRKSRC}/config.h
.endif
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mwhois
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mkpasswd
diff --git a/net/yate/Makefile b/net/yate/Makefile
index 9718c4f734ec..e63f2b8c9724 100644
--- a/net/yate/Makefile
+++ b/net/yate/Makefile
@@ -87,7 +87,7 @@ SQLITE_USES= pkgconfig sqlite
post-extract:
@${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
-post-stage:
+post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/yate
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libyate*.so.5.5.0
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/yate/*.yate