aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2020-02-10 16:25:53 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2020-02-10 16:25:53 +0000
commit9cd91869c79562ceea52c20dd112b71cfcea83fb (patch)
tree44f04bd119e460a34de5c9c8f03257806b2fb97c /net
parent0057d69d9fb01650a48b872e52e0e70242969ac0 (diff)
downloadports-9cd91869c79562ceea52c20dd112b71cfcea83fb.tar.gz
ports-9cd91869c79562ceea52c20dd112b71cfcea83fb.zip
- Fix starting daemon in integrated configuration mode
- While here, add 'dynamicrouting' to RC's PROVIDE and fix Makefile order PR: 239497 Submitted by: Nicolas Deffayet <nicolas@deffayet.com>
Notes
Notes: svn path=/head/; revision=525713
Diffstat (limited to 'net')
-rw-r--r--net/frr5/Makefile7
-rw-r--r--net/frr5/files/frr.in10
2 files changed, 11 insertions, 6 deletions
diff --git a/net/frr5/Makefile b/net/frr5/Makefile
index ddaf4970fde3..7c126c2826b5 100644
--- a/net/frr5/Makefile
+++ b/net/frr5/Makefile
@@ -2,8 +2,8 @@
PORTNAME= frr
PORTVERSION= 5.0.2
-PORTREVISION= 2
DISTVERSIONPREFIX= frr-
+PORTREVISION= 3
CATEGORIES= net
PKGNAMESUFFIX= 5
@@ -13,13 +13,14 @@ COMMENT= IP routing protocol suite including BGP, IS-IS, OSPF and RIP
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= autoreconf bison compiler:c++11-lang gmake pkgconfig libtool \
+ makeinfo python:2.7,build readline
+
BUILD_DEPENDS= gawk:lang/gawk
LIB_DEPENDS= libjson-c.so:devel/json-c
CONFLICTS= openbgpd openospfd zebra quagga frr6 frr7
-USES= autoreconf bison compiler:c++11-lang gmake pkgconfig libtool \
- makeinfo python:2.7,build readline
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/net/frr5/files/frr.in b/net/frr5/files/frr.in
index 5587d75ac907..81bd04f3934a 100644
--- a/net/frr5/files/frr.in
+++ b/net/frr5/files/frr.in
@@ -3,7 +3,7 @@
# $FreeBSD$
#
-# PROVIDE: frr
+# PROVIDE: frr dynamicrouting
# REQUIRE: netif routing
# KEYWORD: nojailvnet shutdown
@@ -92,12 +92,16 @@ do_cmd()
frr_cmd=$1
for daemon in ${frr_daemons}; do
command=%%PREFIX%%/sbin/${daemon}
- required_files=%%ETCDIR%%/${daemon}.conf
+ if checkyesno frr_vtysh_boot; then
+ required_files=%%ETCDIR%%/frr.conf
+ else
+ required_files=%%ETCDIR%%/${daemon}.conf
+ fi
pidfile=/var/run/frr/${daemon}.pid
if [ ${frr_cmd} = "restart" ] || [ ${frr_cmd} = "start" ]; then
check_config
fi
- if [ ${frr_cmd} = "start" ] && ! [ -f ${required_files} ]; then
+ if [ ${frr_cmd} = "start" ] && ! [ -f ${required_files} ] && ! checkyesno frr_vtysh_boot; then
continue
fi
if [ ${frr_cmd} = "stop" ] && [ -z $(check_process ${command}) ]; then