aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 10:52:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 10:52:14 +0000
commita0504ed8f952e186fd0fc2cbe1364a313d1be023 (patch)
treee0824ed0768cb62db23a22dbed5d334979962899 /net
parent5c8879d7b706e1b61bf20f9ffa1e98d8e0fc1afc (diff)
downloadports-a0504ed8f952e186fd0fc2cbe1364a313d1be023.tar.gz
ports-a0504ed8f952e186fd0fc2cbe1364a313d1be023.zip
Diffstat (limited to 'net')
-rw-r--r--net/py-transip/Makefile3
-rw-r--r--net/py-transip/files/patch-setup.py11
2 files changed, 13 insertions, 1 deletions
diff --git a/net/py-transip/Makefile b/net/py-transip/Makefile
index f7f5248ce0c3..1eef0383662e 100644
--- a/net/py-transip/Makefile
+++ b/net/py-transip/Makefile
@@ -2,6 +2,7 @@
PORTNAME= transip
PORTVERSION= 2.1.2
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}suds-jurko>=0:net/py-suds-jurko@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}suds>=0:net/py-suds@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/net/py-transip/files/patch-setup.py b/net/py-transip/files/patch-setup.py
new file mode 100644
index 000000000000..b4977240d480
--- /dev/null
+++ b/net/py-transip/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-03-29 13:27:50 UTC
++++ setup.py
+@@ -44,7 +44,7 @@ setup(
+ install_requires=[
+ 'requests',
+ 'cryptography',
+- 'suds-jurko',
++ 'suds',
+ ],
+ classifiers=[
+ 'Development Status :: 4 - Beta',