aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /net
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/pear-Auth_RADIUS/Makefile2
-rw-r--r--net/pear-Horde_Kolab_Server/Makefile2
-rw-r--r--net/pear-Net_CDDB/Makefile12
-rw-r--r--net/pear-Net_DNSBL/Makefile16
-rw-r--r--net/pear-Net_Dict/Makefile8
-rw-r--r--net/pear-Net_Finger/Makefile4
-rw-r--r--net/pear-Net_Geo/Makefile8
-rw-r--r--net/pear-Net_GeoIP/Makefile8
-rw-r--r--net/pear-Net_NNTP/Makefile4
-rw-r--r--net/pear-Net_Nmap/Makefile4
-rw-r--r--net/pear-Net_POP3/Makefile4
-rw-r--r--net/pear-Net_SMS/Makefile8
-rw-r--r--net/pear-Net_SMTP/Makefile6
-rw-r--r--net/pear-Net_Sieve/Makefile4
-rw-r--r--net/pear-Net_Vpopmaild/Makefile8
-rw-r--r--net/pear-Net_Whois/Makefile2
-rw-r--r--net/pear-SOAP/Makefile10
-rw-r--r--net/pear-Services_Twitter/Makefile4
-rw-r--r--net/pear-XML_RPC2/Makefile8
-rw-r--r--net/pecl-oauth2/Makefile1
20 files changed, 61 insertions, 62 deletions
diff --git a/net/pear-Auth_RADIUS/Makefile b/net/pear-Auth_RADIUS/Makefile
index 4dedf58a5b62..cf01780f8166 100644
--- a/net/pear-Auth_RADIUS/Makefile
+++ b/net/pear-Auth_RADIUS/Makefile
@@ -11,6 +11,6 @@ COMMENT= PEAR wrapper classes for the RADIUS PECL
LICNSE= BSD3CLAUSE
USE_PHP= radius
-USES= pear php
+USES= pear php:flavors
.include <bsd.port.mk>
diff --git a/net/pear-Horde_Kolab_Server/Makefile b/net/pear-Horde_Kolab_Server/Makefile
index 6a1e5f903c9d..49f4cf25545f 100644
--- a/net/pear-Horde_Kolab_Server/Makefile
+++ b/net/pear-Horde_Kolab_Server/Makefile
@@ -4,7 +4,7 @@
PORTNAME= Horde_Kolab_Server
DISTVERSION= 2.0.5
CATEGORIES= net www pear
-PKGNAMEPREFIX= pear-
+PKGNAMEPREFIX= ${PEAR_PKGNAMEPREFIX}
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde library for manipulating the Kolab user database
diff --git a/net/pear-Net_CDDB/Makefile b/net/pear-Net_CDDB/Makefile
index a3e84c896943..bdd6e5231df9 100644
--- a/net/pear-Net_CDDB/Makefile
+++ b/net/pear-Net_CDDB/Makefile
@@ -8,12 +8,12 @@ CATEGORIES= net audio www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR class that access and query CDDB audio-CD servers
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket \
- ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request \
- ${PEARDIR}/MDB2.php:databases/pear-MDB2
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket \
- ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request \
- ${PEARDIR}/MDB2.php:databases/pear-MDB2
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR} \
+ ${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR} \
+ ${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
USES= dos2unix pear
diff --git a/net/pear-Net_DNSBL/Makefile b/net/pear-Net_DNSBL/Makefile
index 42c24b660b97..f396f7ec49d2 100644
--- a/net/pear-Net_DNSBL/Makefile
+++ b/net/pear-Net_DNSBL/Makefile
@@ -11,14 +11,14 @@ COMMENT= PEAR DNSBL Checker
LICENSE= PHP30
-BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite \
- ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP \
- ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2 \
- ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
-RUN_DEPENDS:= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite \
- ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP \
- ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2 \
- ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
+BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
+RUN_DEPENDS:= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_Dict/Makefile b/net/pear-Net_Dict/Makefile
index 36398aeda4e1..9a3f8a32b582 100644
--- a/net/pear-Net_Dict/Makefile
+++ b/net/pear-Net_Dict/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= net www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR interface to the DICT protocol
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket \
- ${PEARDIR}/Cache.php:sysutils/pear-Cache
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket \
- ${PEARDIR}/Cache.php:sysutils/pear-Cache
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR} \
+ ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR} \
+ ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_Finger/Makefile b/net/pear-Net_Finger/Makefile
index 102e6c2cf92a..9c9bc356ad13 100644
--- a/net/pear-Net_Finger/Makefile
+++ b/net/pear-Net_Finger/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= net www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR class that provides a tool for querying finger servers
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_Geo/Makefile b/net/pear-Net_Geo/Makefile
index b67b14975b63..db027c93b297 100644
--- a/net/pear-Net_Geo/Makefile
+++ b/net/pear-Net_Geo/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= net pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= Geographical locations based on Internet address
-BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
-RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
+BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_GeoIP/Makefile b/net/pear-Net_GeoIP/Makefile
index 8abd569655e9..8d2a2a4b47d9 100644
--- a/net/pear-Net_GeoIP/Makefile
+++ b/net/pear-Net_GeoIP/Makefile
@@ -10,10 +10,10 @@ DISTNAME= Net_GeoIP-1.0.0RC1
MAINTAINER= joneum@FreeBSD.org
COMMENT= Library to perform geo-location lookups of IP addresses
-BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
-RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
+BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_NNTP/Makefile b/net/pear-Net_NNTP/Makefile
index 013d9ba17ed4..10c83f4bbcbf 100644
--- a/net/pear-Net_NNTP/Makefile
+++ b/net/pear-Net_NNTP/Makefile
@@ -14,8 +14,8 @@ LICENSE_NAME= W3C IPR SOFTWARE NOTICE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
NO_ARCH= yes
diff --git a/net/pear-Net_Nmap/Makefile b/net/pear-Net_Nmap/Makefile
index 17fc3295ea28..1a911ea01f15 100644
--- a/net/pear-Net_Nmap/Makefile
+++ b/net/pear-Net_Nmap/Makefile
@@ -10,8 +10,8 @@ COMMENT= Simple Wrapper Class for the Nmap Utility
LICENSE= LGPL3
-BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:devel/pear-XML_Parser
-RUN_DEPENDS:= ${PEARDIR}/XML/Parser.php:devel/pear-XML_Parser
+BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:devel/pear-XML_Parser@${PHP_FLAVOR}
+RUN_DEPENDS:= ${PEARDIR}/XML/Parser.php:devel/pear-XML_Parser@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_POP3/Makefile b/net/pear-Net_POP3/Makefile
index 6a674b7f082b..b69881ed43e2 100644
--- a/net/pear-Net_POP3/Makefile
+++ b/net/pear-Net_POP3/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= net pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= Provides a POP3 class to access POP3 server
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_SMS/Makefile b/net/pear-Net_SMS/Makefile
index d428628bbb8d..51bbea46f3ec 100644
--- a/net/pear-Net_SMS/Makefile
+++ b/net/pear-Net_SMS/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= net pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR SMS functionality
-BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail \
- ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
-RUN_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail \
- ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
+BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
USE_PHP= gettext
USES= pear php
diff --git a/net/pear-Net_SMTP/Makefile b/net/pear-Net_SMTP/Makefile
index 2c68680c1443..b453a7006e0c 100644
--- a/net/pear-Net_SMTP/Makefile
+++ b/net/pear-Net_SMTP/Makefile
@@ -10,8 +10,8 @@ COMMENT= PEAR class that provides an implementation of the SMTP protocol
LICENSE= BSD2CLAUSE
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
NO_ARCH= yes
USES= pear
@@ -19,6 +19,6 @@ USES= pear
OPTIONS_DEFINE= PEAR_AUTH_SASL
PEAR_AUTH_SASL_DESC= PEAR::Auth_SASL support
-PEAR_AUTH_SASL_BUILD_DEPENDS= ${PEARDIR}/Auth/SASL.php:security/pear-Auth_SASL
+PEAR_AUTH_SASL_BUILD_DEPENDS= ${PEARDIR}/Auth/SASL.php:security/pear-Auth_SASL@${PHP_FLAVOR}
.include <bsd.port.mk>
diff --git a/net/pear-Net_Sieve/Makefile b/net/pear-Net_Sieve/Makefile
index 0e94422c0d02..9933fd9f50db 100644
--- a/net/pear-Net_Sieve/Makefile
+++ b/net/pear-Net_Sieve/Makefile
@@ -10,8 +10,8 @@ COMMENT= PEAR class to handle talking to timsieved
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_Vpopmaild/Makefile b/net/pear-Net_Vpopmaild/Makefile
index 0d8281780176..894160104860 100644
--- a/net/pear-Net_Vpopmaild/Makefile
+++ b/net/pear-Net_Vpopmaild/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= net mail pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR Class for accessing Vpopmail's vpopmaild daemon
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket \
- ${PEARDIR}/Log.php:sysutils/pear-Log
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket \
- ${PEARDIR}/Log.php:sysutils/pear-Log
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR} \
+ ${PEARDIR}/Log.php:sysutils/pear-Log@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR} \
+ ${PEARDIR}/Log.php:sysutils/pear-Log@${PHP_FLAVOR}
USES= pear
diff --git a/net/pear-Net_Whois/Makefile b/net/pear-Net_Whois/Makefile
index 398e02eb49b2..4833906976e2 100644
--- a/net/pear-Net_Whois/Makefile
+++ b/net/pear-Net_Whois/Makefile
@@ -10,6 +10,6 @@ COMMENT= Tool to query internet domain name services
USES= pear
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:net/pear-Net_Socket@${PHP_FLAVOR}
.include <bsd.port.mk>
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index d0ffd4fb1e60..fe986994d02a 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= net www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR SOAP Client/Server for PHP
-BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
-RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
USES= pear
@@ -18,8 +18,8 @@ PEAR_MAIL_DESC= PEAR::Mail support
PEAR_MAIL_MIME_DESC= PEAR::Mail::Mime support
PEAR_NET_DIME_DESC= PEAR::Net::DIME support
-PEAR_MAIL_BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail
-PEAR_MAIL_MIME_BUILD_DEPENDS= ${PEARDIR}/Mail/mime.php:mail/pear-Mail_Mime
-PEAR_NET_DIME_BUILD_DEPENDS= ${PEARDIR}/Net/DIME.php:net/pear-Net_DIME
+PEAR_MAIL_BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail@${PHP_FLAVOR}
+PEAR_MAIL_MIME_BUILD_DEPENDS= ${PEARDIR}/Mail/mime.php:mail/pear-Mail_Mime@${PHP_FLAVOR}
+PEAR_NET_DIME_BUILD_DEPENDS= ${PEARDIR}/Net/DIME.php:net/pear-Net_DIME@${PHP_FLAVOR}
.include <bsd.port.mk>
diff --git a/net/pear-Services_Twitter/Makefile b/net/pear-Services_Twitter/Makefile
index d0b6f69a9361..bea94f052e45 100644
--- a/net/pear-Services_Twitter/Makefile
+++ b/net/pear-Services_Twitter/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= net www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PHP interface to Twitter's API
-BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
-RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
USE_PHP= json simplexml mbstring
diff --git a/net/pear-XML_RPC2/Makefile b/net/pear-XML_RPC2/Makefile
index 083671dc3b8a..9a067ab75a26 100644
--- a/net/pear-XML_RPC2/Makefile
+++ b/net/pear-XML_RPC2/Makefile
@@ -10,10 +10,10 @@ COMMENT= XML-RPC client/server library
LICENSE= PHP301
-BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite \
- ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
-RUN_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite \
- ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
+BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
USE_PHP= curl
USES= pear
diff --git a/net/pecl-oauth2/Makefile b/net/pecl-oauth2/Makefile
index 94d187fa0c80..e8af3c2b34f9 100644
--- a/net/pecl-oauth2/Makefile
+++ b/net/pecl-oauth2/Makefile
@@ -3,7 +3,6 @@
PORTNAME= oauth
PORTVERSION= 2.0.2
CATEGORIES= net pear
-PKGNAMESUFFIX= 2
MAINTAINER= dbaio@FreeBSD.org
COMMENT= Php interface to the OAuth Protocol