aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-11-01 15:18:55 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-11-01 15:18:55 +0000
commitacc59885c0fb4ea82d7060279e4951d8aec72189 (patch)
treeb50c81f07721bf63b8481aa22e76f4c88f041065 /net
parent5ffbb2f7a774fc7e2ec96b43bcca1e3323c48957 (diff)
downloadports-acc59885c0fb4ea82d7060279e4951d8aec72189.tar.gz
ports-acc59885c0fb4ea82d7060279e4951d8aec72189.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/tiny-network-utilities/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/tiny-network-utilities/Makefile b/net/tiny-network-utilities/Makefile
index 711cbd098bc7..f3e1c236ec73 100644
--- a/net/tiny-network-utilities/Makefile
+++ b/net/tiny-network-utilities/Makefile
@@ -25,6 +25,12 @@ FILES_EXEC= tiny-dhcp-server tiny-udp-proxy tiny-udp-anti-nat
FILES_LIB= net_checksums tiny_utils
PLIST_FILES= $(FILES_EXEC:%=bin/%) $(FILES_LIB:%=${PYTHON_SITELIBDIR}/%.py)
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
do-install:
.for file_exec in ${FILES_EXEC}
${INSTALL_SCRIPT} ${WRKSRC}/${file_exec}.py \
@@ -36,4 +42,4 @@ do-install:
${STAGEDIR}${PYTHON_SITELIBDIR}/${file_lib}.py
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>