aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-13 18:00:10 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-12-13 18:00:10 +0000
commitb6c31f0d282547d3e98b450ced5267fee2d83621 (patch)
tree9ed4a61751be66799c93cdc7b3a0b90ab0f6e9f0 /net
parentcce92f80e10be221dd41db52c5f645b2ed5810ec (diff)
downloadports-b6c31f0d282547d3e98b450ced5267fee2d83621.tar.gz
ports-b6c31f0d282547d3e98b450ced5267fee2d83621.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ip2location/Makefile23
-rw-r--r--net/ip2location/distinfo2
-rw-r--r--net/ip2location/pkg-descr9
-rw-r--r--net/ip2location/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f54f216b84c0..6971c97e897f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -225,6 +225,7 @@
SUBDIR += ilbc
SUBDIR += imapproxy
SUBDIR += iodine
+ SUBDIR += ip2location
SUBDIR += ip6_int
SUBDIR += ipgrab
SUBDIR += iplog
diff --git a/net/ip2location/Makefile b/net/ip2location/Makefile
new file mode 100644
index 000000000000..067053e9133c
--- /dev/null
+++ b/net/ip2location/Makefile
@@ -0,0 +1,23 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= ip2location
+PORTVERSION= 6.0.3
+CATEGORIES= net
+MASTER_SITES= http://www.ip2location.com/downloads/
+DISTNAME= ${PORTNAME}-c-${PORTVERSION}
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= C library to find user\'s location
+
+LICENSE= LGPL3
+
+USES= libtool:keepla perl5
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+post-configure:
+ (cd ${WRKSRC}/data && ${MAKE} convert)
+
+.include <bsd.port.mk>
diff --git a/net/ip2location/distinfo b/net/ip2location/distinfo
new file mode 100644
index 000000000000..3709b86d0b58
--- /dev/null
+++ b/net/ip2location/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ip2location-c-6.0.3.tar.gz) = 3bd2a46544c7a433c55f96b602bc35a9f7782e2b0addfdbe9eb8ecaa717f7f10
+SIZE (ip2location-c-6.0.3.tar.gz) = 3145564
diff --git a/net/ip2location/pkg-descr b/net/ip2location/pkg-descr
new file mode 100644
index 000000000000..0097640cd774
--- /dev/null
+++ b/net/ip2location/pkg-descr
@@ -0,0 +1,9 @@
+IP2Location is a C library that enables the user to find the country, region,
+city, latitude, longitude, zip code, time zone, ISP, domain name, connection
+type, area code, weather, mobile network, elevation, usage type by IP address
+or hostname originates from. It contains a demo IP2Location IP-COUNTRY BIN
+database which consists of real data for IP address range 0.0.0.0 to 99.255.
+255.255. This database contains IP address blocks as key and countries as
+values.
+
+WWW: http://www.ip2location.com/c.aspx
diff --git a/net/ip2location/pkg-plist b/net/ip2location/pkg-plist
new file mode 100644
index 000000000000..5e231230aae9
--- /dev/null
+++ b/net/ip2location/pkg-plist
@@ -0,0 +1,9 @@
+include/IP2Loc_DBInterface.h
+include/IP2Location.h
+lib/libIP2Location.a
+lib/libIP2Location.la
+lib/libIP2Location.so
+lib/libIP2Location.so.1
+lib/libIP2Location.so.1.0.0
+share/IP2Loc/IP-COUNTRY.BIN
+share/IP2Loc/IPV6-COUNTRY.BIN