aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:18:49 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:36:18 +0000
commitb8c44cdd27ca8eacb5361e6d1914b17378d3b046 (patch)
tree4c06b6aacfb1127e2d5bab19f17eb7bf594978ab /net
parentd309ae870be12d19e8d2b93ecd85f019212edaca (diff)
downloadports-b8c44cdd27ca8eacb5361e6d1914b17378d3b046.tar.gz
ports-b8c44cdd27ca8eacb5361e6d1914b17378d3b046.zip
Diffstat (limited to 'net')
-rw-r--r--net/rubygem-activestorage61/Makefile3
-rw-r--r--net/rubygem-activestorage61/files/patch-activestorage.gemspec13
-rw-r--r--net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb13
-rw-r--r--net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb13
4 files changed, 41 insertions, 1 deletions
diff --git a/net/rubygem-activestorage61/Makefile b/net/rubygem-activestorage61/Makefile
index 267fa6c25b1a..06423baafb44 100644
--- a/net/rubygem-activestorage61/Makefile
+++ b/net/rubygem-activestorage61/Makefile
@@ -2,6 +2,7 @@
PORTNAME= activestorage
PORTVERSION= 6.1.3.1
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= RG
PKGNAMESUFFIX= 61
@@ -17,7 +18,7 @@ RUN_DEPENDS= rubygem-actionpack61>=${PORTVERSION}:www/rubygem-actionpack61 \
rubygem-activerecord61>=${PORTVERSION}:databases/rubygem-activerecord61 \
rubygem-activesupport61>=${PORTVERSION}:devel/rubygem-activesupport61 \
rubygem-marcel>=1.0.0<1.1:devel/rubygem-marcel \
- rubygem-mini_mime>=1.0.2<1.1:mail/rubygem-mini_mime
+ rubygem-mini_mime>=1.1.0:mail/rubygem-mini_mime
USES= gem
USE_RUBY= yes
diff --git a/net/rubygem-activestorage61/files/patch-activestorage.gemspec b/net/rubygem-activestorage61/files/patch-activestorage.gemspec
new file mode 100644
index 000000000000..ae0cc38a9872
--- /dev/null
+++ b/net/rubygem-activestorage61/files/patch-activestorage.gemspec
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/rails/rails/commit/b80a2bdeb955c81649e483f2f020a3d5f407c2f9
+
+--- activestorage.gemspec.orig 2021-04-24 11:45:24 UTC
++++ activestorage.gemspec
+@@ -28,7 +28,7 @@ Gem::Specification.new do |s|
+ s.add_runtime_dependency(%q<activejob>.freeze, ["= 6.1.3.1"])
+ s.add_runtime_dependency(%q<activerecord>.freeze, ["= 6.1.3.1"])
+ s.add_runtime_dependency(%q<marcel>.freeze, ["~> 1.0.0"])
+- s.add_runtime_dependency(%q<mini_mime>.freeze, ["~> 1.0.2"])
++ s.add_runtime_dependency(%q<mini_mime>.freeze, [">= 1.1.0"])
+ else
+ s.add_dependency(%q<activesupport>.freeze, ["= 6.1.3.1"])
+ s.add_dependency(%q<actionpack>.freeze, ["= 6.1.3.1"])
diff --git a/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb b/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb
new file mode 100644
index 000000000000..5e5ac0de6d53
--- /dev/null
+++ b/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant.rb
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/rails/rails/commit/b80a2bdeb955c81649e483f2f020a3d5f407c2f9
+
+--- app/models/active_storage/variant.rb.orig 2021-04-24 11:45:24 UTC
++++ app/models/active_storage/variant.rb
+@@ -89,7 +89,7 @@ class ActiveStorage::Variant
+ end
+
+ def filename
+- ActiveStorage::Filename.new "#{blob.filename.base}.#{variation.format}"
++ ActiveStorage::Filename.new "#{blob.filename.base}.#{variation.format.downcase}"
+ end
+
+ alias_method :content_type_for_serving, :content_type
diff --git a/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb b/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb
new file mode 100644
index 000000000000..bc1dc981240d
--- /dev/null
+++ b/net/rubygem-activestorage61/files/patch-app-models-active_storage-variant_with_record.rb
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/rails/rails/commit/b80a2bdeb955c81649e483f2f020a3d5f407c2f9
+
+--- app/models/active_storage/variant_with_record.rb.orig 2021-04-24 11:45:24 UTC
++++ app/models/active_storage/variant_with_record.rb
+@@ -33,7 +33,7 @@ class ActiveStorage::VariantWithRecord
+ def transform_blob
+ blob.open do |input|
+ variation.transform(input) do |output|
+- yield io: output, filename: "#{blob.filename.base}.#{variation.format}",
++ yield io: output, filename: "#{blob.filename.base}.#{variation.format.downcase}",
+ content_type: variation.content_type, service_name: blob.service.name
+ end
+ end