aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-05-02 16:01:11 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-05-02 16:01:11 +0000
commitbe6901feb18a14daca6823beedec65a23d5e07f4 (patch)
treed6bcd10a69aeeb068e2afc4354302229755e5332 /net
parentd2a08d488543abee5991dc090bbdd20fd5c6bf5a (diff)
downloadports-be6901feb18a14daca6823beedec65a23d5e07f4.tar.gz
ports-be6901feb18a14daca6823beedec65a23d5e07f4.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/asterisk15/Makefile5
-rw-r--r--net/asterisk15/distinfo6
-rw-r--r--net/asterisk15/files/patch-configure132
-rw-r--r--net/asterisk15/files/patch-main_asterisk.c11
-rw-r--r--net/asterisk15/pkg-plist1
5 files changed, 45 insertions, 110 deletions
diff --git a/net/asterisk15/Makefile b/net/asterisk15/Makefile
index 9d531aa604eb..415f3469e858 100644
--- a/net/asterisk15/Makefile
+++ b/net/asterisk15/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk
-PORTVERSION= 15.3.0
-PORTREVISION= 1
+PORTVERSION= 15.4.0
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
@@ -148,7 +147,7 @@ LDAP_CONFIGURE_WITH= ldap
LDAP_USE= OPENLDAP=yes
LUA_CONFIGURE_WITH= lua
-LUA_USES= lua:51
+LUA_USES= lua
LUA_CFLAGS= -I${LUA_INCDIR}
LUA_LDFLAGS= -L${LUA_LIBDIR}
diff --git a/net/asterisk15/distinfo b/net/asterisk15/distinfo
index b59c0dedfae5..6b621f9fd6df 100644
--- a/net/asterisk15/distinfo
+++ b/net/asterisk15/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1521144030
-SHA256 (asterisk-15.3.0.tar.gz) = f424f89f23b72f267ff9baab82d449bebbbf00c54e54fcd06b8fca13788b012c
-SIZE (asterisk-15.3.0.tar.gz) = 27584086
+TIMESTAMP = 1525249446
+SHA256 (asterisk-15.4.0.tar.gz) = 1b48d8b512305ed6f5909931c42afebce7003bf3a9d54f45e982500e15c571dd
+SIZE (asterisk-15.4.0.tar.gz) = 27609299
SHA256 (asterisk-core-sounds-en-g729-1.5.tar.gz) = 8b28a59cfa53b59c76e0a191704f0708e3d83acffab8c5e6f25dfc599f0123f9
SIZE (asterisk-core-sounds-en-g729-1.5.tar.gz) = 1551123
SHA256 (asterisk-moh-opsound-g729-2.03.tar.gz) = 0147ca9a97f0c550227aacb7793499057c4d2c64e021c95f93722f27d5549585
diff --git a/net/asterisk15/files/patch-configure b/net/asterisk15/files/patch-configure
index ea46b420720b..2974debdfacc 100644
--- a/net/asterisk15/files/patch-configure
+++ b/net/asterisk15/files/patch-configure
@@ -1,19 +1,7 @@
---- configure.orig 2017-12-20 20:39:39 UTC
+--- configure.orig 2018-04-19 18:45:51 UTC
+++ configure
-@@ -4818,9 +4818,9 @@ astheaderdir='${includedir}/asterisk'
- astlibdir='${libdir}'
- astmoddir='${libdir}/asterisk/modules'
- astmandir='${mandir}'
--astvarlibdir='${localstatedir}/lib/asterisk'
-+astvarlibdir='${prefix}/share/asterisk'
- astdatadir='${astvarlibdir}'
--astdbdir='${astvarlibdir}'
-+astdbdir='${localstatedir}/db/asterisk'
- astkeydir='${astvarlibdir}'
- astspooldir='${localstatedir}/spool/asterisk'
- astlogdir='${localstatedir}/log/asterisk'
-@@ -4843,8 +4843,6 @@ esac
- case "${host_os}" in
+@@ -4676,8 +4676,6 @@ case "${host_os}" in
+ ;;
freebsd*)
ac_default_prefix=/usr/local
- CPPFLAGS=-I/usr/local/include
@@ -21,7 +9,7 @@
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -20495,11 +20493,13 @@ $as_echo_n "checking for getifaddrs() support... " >&6
+@@ -20680,6 +20678,8 @@ $as_echo_n "checking for getifaddrs() support... " >&6
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -30,103 +18,61 @@
#include <ifaddrs.h>
int
main ()
- {
-- struct ifaddrs *p; getifaddrs(&p);
-+ Struct ifaddrs *p; getifaddrs(&p);
+@@ -29299,6 +29299,8 @@ fi
- ;
- return 0;
-@@ -30097,13 +30097,13 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
+ for ver in 5.3 5.2 5.1; do
++vernodot=`echo ${ver} | sed 's/\.//'`
++
+ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no"; then
+ pbxlibdir=""
+ # if --with-LUA=DIR has been specified, use it.
+@@ -29313,13 +29315,13 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
ast_ext_lib_check_save_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} "
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua5.2" >&5
--$as_echo_n "checking for luaL_newstate in -llua5.2... " >&6; }
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-5.2" >&5
-+$as_echo_n "checking for luaL_newstate in -llua-5.2... " >&6; }
- if ${ac_cv_lib_lua5_2_luaL_newstate+:} false; then :
+ as_ac_Lib=`$as_echo "ac_cv_lib_lua${ver}''_luaL_newstate" | $as_tr_sh`
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua${ver}" >&5
+-$as_echo_n "checking for luaL_newstate in -llua${ver}... " >&6; }
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-${ver}" >&5
++$as_echo_n "checking for luaL_newstate in -llua-${ver}... " >&6; }
+ if eval \${$as_ac_Lib+:} false; then :
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
--LIBS="-llua5.2 ${pbxlibdir} -lm $LIBS"
-+LIBS="-llua-5.2 ${pbxlibdir} -lm $LIBS"
+-LIBS="-llua${ver} ${pbxlibdir} -lm $LIBS"
++LIBS="-llua-${ver} ${pbxlibdir} -lm $LIBS"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -30144,7 +30144,7 @@ fi
+@@ -29361,7 +29363,7 @@ fi
# now check for the header.
if test "${AST_LUA_FOUND}" = "yes"; then
-- LUA_LIB="${pbxlibdir} -llua5.2 -lm"
-+ LUA_LIB="${pbxlibdir} -llua-5.2 -lm"
+- LUA_LIB="${pbxlibdir} -llua${ver} -lm"
++ LUA_LIB="${pbxlibdir} -llua-${ver} -lm"
# if --with-LUA=DIR has been specified, use it.
if test "x${LUA_DIR}" != "x"; then
LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -30154,7 +30154,7 @@ fi
+@@ -29371,8 +29373,8 @@ fi
# check for the header
ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
-- ac_fn_c_check_header_mongrel "$LINENO" "lua5.2/lua.h" "ac_cv_header_lua5_2_lua_h" "$ac_includes_default"
-+ ac_fn_c_check_header_mongrel "$LINENO" "lua52/lua.h" "ac_cv_header_lua5_2_lua_h" "$ac_includes_default"
- if test "x$ac_cv_header_lua5_2_lua_h" = xyes; then :
+- as_ac_Header=`$as_echo "ac_cv_header_lua${ver}/lua.h" | $as_tr_sh`
+-ac_fn_c_check_header_mongrel "$LINENO" "lua${ver}/lua.h" "$as_ac_Header" "$ac_includes_default"
++ as_ac_Header=`$as_echo "ac_cv_header_lua${vernodot}/lua.h" | $as_tr_sh`
++ac_fn_c_check_header_mongrel "$LINENO" "lua${vernodot}/lua.h" "$as_ac_Header" "$ac_includes_default"
+ if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
LUA_HEADER_FOUND=1
else
-@@ -30181,9 +30181,9 @@ fi
+@@ -29399,9 +29401,9 @@ fi
- if test "x${PBX_LUA}" = "x1" ; then
- if test x"${LUA_DIR}" = x; then
-- LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua5.2"
-+ LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua-5.2"
- else
-- LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua5.2"
-+ LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua-5.2"
+ if test "x${PBX_LUA}" = "x1" ; then
+ if test x"${LUA_DIR}" = x; then
+- LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua${ver}"
++ LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua${vernodot}"
+ else
+- LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua${ver}"
++ LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua${vernodot}"
+ fi
+ break;
fi
- fi
-
-@@ -30201,13 +30201,13 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
-
- ast_ext_lib_check_save_CFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} "
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua5.1" >&5
--$as_echo_n "checking for luaL_newstate in -llua5.1... " >&6; }
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-5.1" >&5
-+$as_echo_n "checking for luaL_newstate in -llua-5.1... " >&6; }
- if ${ac_cv_lib_lua5_1_luaL_newstate+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-llua5.1 ${pbxlibdir} -lm $LIBS"
-+LIBS="-llua-5.1 ${pbxlibdir} -lm $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-@@ -30248,7 +30248,7 @@ fi
-
- # now check for the header.
- if test "${AST_LUA_FOUND}" = "yes"; then
-- LUA_LIB="${pbxlibdir} -llua5.1 -lm"
-+ LUA_LIB="${pbxlibdir} -llua-5.1 -lm"
- # if --with-LUA=DIR has been specified, use it.
- if test "x${LUA_DIR}" != "x"; then
- LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -30258,7 +30258,7 @@ fi
- # check for the header
- ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
- CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
-- ac_fn_c_check_header_mongrel "$LINENO" "lua5.1/lua.h" "ac_cv_header_lua5_1_lua_h" "$ac_includes_default"
-+ ac_fn_c_check_header_mongrel "$LINENO" "lua51/lua.h" "ac_cv_header_lua5_1_lua_h" "$ac_includes_default"
- if test "x$ac_cv_header_lua5_1_lua_h" = xyes; then :
- LUA_HEADER_FOUND=1
- else
-@@ -30285,9 +30285,9 @@ fi
-
- if test "x${PBX_LUA}" = "x1" ; then
- if test x"${LUA_DIR}" = x; then
-- LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua5.1"
-+ LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua-5.1"
- else
-- LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua5.1"
-+ LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua-5.1"
- fi
- fi
-
diff --git a/net/asterisk15/files/patch-main_asterisk.c b/net/asterisk15/files/patch-main_asterisk.c
deleted file mode 100644
index 50382c6b909f..000000000000
--- a/net/asterisk15/files/patch-main_asterisk.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/asterisk.c.orig 2018-03-15 16:31:26 UTC
-+++ main/asterisk.c
-@@ -3991,7 +3991,7 @@ int main(int argc, char *argv[])
- *
- * \todo Document these options
- */
-- optind = 0;
-+ optind = 1;
- while ((c = getopt(argc, argv, getopt_settings)) != -1) {
- /*!\note Please keep the ordering here to alphabetical, capital letters
- * first. This will make it easier in the future to select unused
diff --git a/net/asterisk15/pkg-plist b/net/asterisk15/pkg-plist
index 0472f9cbf97a..1bdfc5da0548 100644
--- a/net/asterisk15/pkg-plist
+++ b/net/asterisk15/pkg-plist
@@ -168,6 +168,7 @@ include/asterisk/conversions.h
include/asterisk/core_local.h
include/asterisk/core_unreal.h
include/asterisk/crypto.h
+include/asterisk/data_buffer.h
include/asterisk/datastore.h
include/asterisk/devicestate.h
include/asterisk/dial.h