aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-10-10 05:02:00 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-10-10 05:13:11 +0000
commitc12b79b4af7c187d2550fcd8ea0f7201ccc98e81 (patch)
treefb324a097552479d0555ddf049bb10a485be8f65 /net
parent8d7d4f96b7410d4081e072884723c614d588a543 (diff)
downloadports-c12b79b4af7c187d2550fcd8ea0f7201ccc98e81.tar.gz
ports-c12b79b4af7c187d2550fcd8ea0f7201ccc98e81.zip
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pypacker/Makefile21
-rw-r--r--net/py-pypacker/distinfo3
-rw-r--r--net/py-pypacker/pkg-descr8
4 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 63c76d7064a5..e0943bdb7d77 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1076,6 +1076,7 @@
SUBDIR += py-pynamecheap
SUBDIR += py-pynmsg
SUBDIR += py-pynsq
+ SUBDIR += py-pypacker
SUBDIR += py-pypcap
SUBDIR += py-pyroute2
SUBDIR += py-pyroute2.core
diff --git a/net/py-pypacker/Makefile b/net/py-pypacker/Makefile
new file mode 100644
index 000000000000..30a327bd95d1
--- /dev/null
+++ b/net/py-pypacker/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= pypacker
+PORTVERSION= 5.0
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nobutaka@FreeBSD.org
+COMMENT= Packet manipulation library for Python
+
+LICENSE= BSD3CLAUSE GPLv2
+LICENSE_COMB= dual
+
+USES= python
+USE_GITLAB= yes
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+GL_ACCOUNT= mike01
+GL_COMMIT= 268e27c813545bf7995dd0a80abdb4da24d64722
+
+.include <bsd.port.mk>
diff --git a/net/py-pypacker/distinfo b/net/py-pypacker/distinfo
new file mode 100644
index 000000000000..8a6b1084840c
--- /dev/null
+++ b/net/py-pypacker/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633835778
+SHA256 (mike01-pypacker-268e27c813545bf7995dd0a80abdb4da24d64722_GL0.tar.gz) = c0e19b8fab13dcbf67105fb8564c50cdaf5eb35ff23801acef7f118e31b0da22
+SIZE (mike01-pypacker-268e27c813545bf7995dd0a80abdb4da24d64722_GL0.tar.gz) = 608601
diff --git a/net/py-pypacker/pkg-descr b/net/py-pypacker/pkg-descr
new file mode 100644
index 000000000000..aaf9d4680693
--- /dev/null
+++ b/net/py-pypacker/pkg-descr
@@ -0,0 +1,8 @@
+pypacker is a packet manipulation library for Python.
+
+Key features:
+- Creating custom Packets (via keywords) or from raw byte and change their data
+- Reading/writing packets from/to file (Support only for Wireshark/tcpdump pcap format)
+- Merging multiple pcap files to one file
+
+WWW: https://gitlab.com/mike01/pypacker