aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2000-04-15 15:02:51 +0000
committerRoger Hardiman <roger@FreeBSD.org>2000-04-15 15:02:51 +0000
commitc7859e2957e1a4aeb3b91315764d688028596f71 (patch)
treea4ff9dd29b923c52ccd5191a1e04d8e199b02081 /net
parent0ad4bec28a121f7dfe6f6cbe634d3b5a7ff3b1c7 (diff)
downloadports-c7859e2957e1a4aeb3b91315764d688028596f71.tar.gz
ports-c7859e2957e1a4aeb3b91315764d688028596f71.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/gatekeeper/Makefile32
-rw-r--r--net/gatekeeper/distinfo1
-rw-r--r--net/gatekeeper/pkg-comment1
-rw-r--r--net/gatekeeper/pkg-descr16
-rw-r--r--net/gatekeeper/pkg-plist1
5 files changed, 51 insertions, 0 deletions
diff --git a/net/gatekeeper/Makefile b/net/gatekeeper/Makefile
new file mode 100644
index 000000000000..910e73e7f061
--- /dev/null
+++ b/net/gatekeeper/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gatekeeper
+# Date created: Wed Apr 15 15:41:00 GMT 2000
+# Whom: Roger Hardiman <roger@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gatekeeper
+PORTVERSION= 0.12pre
+CATEGORIES= net
+MASTER_SITES= http://www.willamowius.de/download/
+DISTNAME= gk012pre
+
+MAINTAINER= roger@freebsd.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/net/openh323:build
+
+WRKSRC= ${WRKDIR}/gk
+
+NOCLEANDEPENDS= yes
+
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${PORTSDIR}/net/openh323/work/pwlib \
+ OPENH323DIR=${PORTSDIR}/net/openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/gk ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/gatekeeper/distinfo b/net/gatekeeper/distinfo
new file mode 100644
index 000000000000..2b5f33af81c9
--- /dev/null
+++ b/net/gatekeeper/distinfo
@@ -0,0 +1 @@
+MD5 (gk012pre.tar.gz) = aafb2606a42c2c024241ec1e0477800d
diff --git a/net/gatekeeper/pkg-comment b/net/gatekeeper/pkg-comment
new file mode 100644
index 000000000000..1034245e5514
--- /dev/null
+++ b/net/gatekeeper/pkg-comment
@@ -0,0 +1 @@
+GK is a H323 GateKeeper (GPLed) for OpenH323 OhPhone and NetMeeting
diff --git a/net/gatekeeper/pkg-descr b/net/gatekeeper/pkg-descr
new file mode 100644
index 000000000000..d216bad0e5bb
--- /dev/null
+++ b/net/gatekeeper/pkg-descr
@@ -0,0 +1,16 @@
+Gatekeeper (gk) is a H323 GateKeeper based on the OpenH323 project.
+It is released with the GPL (GNU Public Licence)
+
+A H323 Gatekeeper manages multiple H323 clients on a network
+and provides a nice user name to IP mapping.
+
+As it follows the H323 standard, it is compatible with H323
+client programs inclding voxilla, OhPhone, OpenPhone and MS NetMeeting.
+
+It makes use of PWLib and the OpenH323 stack from Equivalence Ltd Pty
+
+It's currently maintained by Jan Willamowius <jan@willamowius.de>
+http://www.willamowius.de/openh323gk.html
+
+Also see
+http://www.openh323.org
diff --git a/net/gatekeeper/pkg-plist b/net/gatekeeper/pkg-plist
new file mode 100644
index 000000000000..5aa86ed2295d
--- /dev/null
+++ b/net/gatekeeper/pkg-plist
@@ -0,0 +1 @@
+bin/gk