aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2012-04-06 14:47:50 +0000
committerSofian Brabez <sbz@FreeBSD.org>2012-04-06 14:47:50 +0000
commitcef7312f01fed908517621d878b1c1d4f974eb48 (patch)
tree53a8dcfed21101b91d3d7a86f6f070cc13730292 /net
parente2e280ca6f9e994b35296affecbc8a1c6123b3b9 (diff)
downloadports-cef7312f01fed908517621d878b1c1d4f974eb48.tar.gz
ports-cef7312f01fed908517621d878b1c1d4f974eb48.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/googlecl/Makefile13
-rw-r--r--net/googlecl/distinfo4
-rw-r--r--net/googlecl/files/patch-__init__.py40
-rw-r--r--net/googlecl/files/patch-base.py17
-rw-r--r--net/googlecl/files/patch-setup.py4
5 files changed, 10 insertions, 68 deletions
diff --git a/net/googlecl/Makefile b/net/googlecl/Makefile
index 66feab0a4b2c..3e79397ccb42 100644
--- a/net/googlecl/Makefile
+++ b/net/googlecl/Makefile
@@ -6,21 +6,20 @@
#
PORTNAME= googlecl
-PORTVERSION= 0.9.12
-PORTREVISION= 1
+PORTVERSION= 0.9.13
CATEGORIES= net www python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
-MAINTAINER= lwhsu@FreeBSD.org
+MAINTAINER= sbz@FreeBSD.org
COMMENT= Command line tools for the Google Data APIs
+LICENSE= AL2
+
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gdata/__init__.py:${PORTSDIR}/devel/py-gdata
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-LICENSE= AL2
-
.if !defined(NO_INSTALL_MANPAGES)
MAN1= google.1
.endif
@@ -29,10 +28,10 @@ PORTDOCS= *
post-install:
.if !defined(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKSRC}/man/google.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/${MAN1} ${MANPREFIX}/man/man1
.endif
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.* ${DOCSDIR}
.endif
diff --git a/net/googlecl/distinfo b/net/googlecl/distinfo
index 48937f40f62e..eb858f7e7c69 100644
--- a/net/googlecl/distinfo
+++ b/net/googlecl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (googlecl-0.9.12.tar.gz) = 1aac3069b7b8d51c2d0ac0f1c1c81c3bb2c4bef373bf7837b7ae13f537f844a6
-SIZE (googlecl-0.9.12.tar.gz) = 84266
+SHA256 (googlecl-0.9.13.tar.gz) = 14bf616b7a1a8671bab4a4000446198df6af06c8711c9ae7f3f616cfda1aa3bc
+SIZE (googlecl-0.9.13.tar.gz) = 85690
diff --git a/net/googlecl/files/patch-__init__.py b/net/googlecl/files/patch-__init__.py
deleted file mode 100644
index e377a15119e6..000000000000
--- a/net/googlecl/files/patch-__init__.py
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/googlecl/calendar/__init__.py.bak 2011-02-17 10:11:57.000000000 +0100
-+++ src/googlecl/calendar/__init__.py 2011-02-17 10:14:06.000000000 +0100
-@@ -235,12 +235,22 @@
-
-
- class CalendarEntryToStringWrapper(googlecl.base.BaseEntryToStringWrapper):
-+ def __init__(self, entry, config):
-+ """Initialize a CalendarEntry wrapper.
-+
-+ Args:
-+ entry: CalendarEntry to interpret to strings.
-+ config: Configuration parser. Needed for some values.
-+ """
-+ googlecl.base.BaseEntryToStringWrapper.__init__(self, entry)
-+ self.config_parser = config
-+
- @property
- def when(self):
- """When event takes place."""
- start_date, end_date, freq = get_datetimes(self.entry)
-- print_format = googlecl.CONFIG.lazy_get(SECTION_HEADER,
-- 'date_print_format')
-+ print_format = self.config_parser.lazy_get(SECTION_HEADER,
-+ 'date_print_format')
- start_text = time.strftime(print_format, start_date)
- end_text = time.strftime(print_format, end_date)
- value = start_text + ' - ' + end_text
-@@ -277,9 +287,9 @@
-
- for entry in single_events:
- print googlecl.base.compile_entry_string(
-- CalendarEntryToStringWrapper(entry),
-- options.fields.split(','),
-- delimiter=options.delimiter)
-+ CalendarEntryToStringWrapper(entry, client.config),
-+ options.fields.split(','),
-+ delimiter=options.delimiter)
-
-
- #===============================================================================
diff --git a/net/googlecl/files/patch-base.py b/net/googlecl/files/patch-base.py
deleted file mode 100644
index 233de1120da6..000000000000
--- a/net/googlecl/files/patch-base.py
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/googlecl/base.py.bak 2011-02-17 10:23:53.000000000 +0100
-+++ src/googlecl/base.py 2011-02-17 10:24:55.000000000 +0100
-@@ -671,12 +671,13 @@
- # with the missing field value.
- val = getattr(wrapped_entry, attr.replace('-','_')) or missing_field_value
- except ValueError, err:
-- LOG.debug(err.args[0] + ' (Did not add value for field ' + attr + ')')
-+ LOG.debug(err.args[0] + ' (value for field ' + attr + ')')
- except AttributeError, err:
- try:
- # Last ditch effort to blindly grab the attribute
- val = getattr(wrapped_entry.entry, attr).text or missing_field_value
- except AttributeError:
-+ LOG.debug(err.args[0] + ' (value for field ' + attr + ')')
- val = missing_field_value
- # Apparently, atom(?) doesn't always return a Unicode type when there are
- # non-latin characters, so force everything to Unicode.
diff --git a/net/googlecl/files/patch-setup.py b/net/googlecl/files/patch-setup.py
index 5b636ae9d080..e853bbed1aec 100644
--- a/net/googlecl/files/patch-setup.py
+++ b/net/googlecl/files/patch-setup.py
@@ -1,5 +1,5 @@
---- ./setup.py.orig 2010-12-11 00:04:45.000000000 +0100
-+++ ./setup.py 2010-12-11 00:04:57.000000000 +0100
+--- ./setup.py.orig 2012-04-06 17:49:48.000000000 +0200
++++ ./setup.py 2012-04-06 17:49:57.000000000 +0200
@@ -14,10 +14,7 @@
from __future__ import with_statement