aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-04-01 13:14:39 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-04-01 13:14:39 +0000
commite0e467783fd87f7df4c0b54097f1e3062f6c2d88 (patch)
treee3e471daf02c47ebd0e080d75cbb24ea015f20b0 /net
parent55120f7a730921ece1482c6da7ca77183f1fa566 (diff)
downloadports-e0e467783fd87f7df4c0b54097f1e3062f6c2d88.tar.gz
ports-e0e467783fd87f7df4c0b54097f1e3062f6c2d88.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile20
-rw-r--r--net/asterisk/distinfo4
-rw-r--r--net/asterisk/files/patch-configure24
-rw-r--r--net/asterisk/pkg-plist2
4 files changed, 31 insertions, 19 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 393ee6ea5e82..d06313c9f923 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.10.1
+PORTVERSION= 1.8.11.0
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -61,9 +61,12 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
CURL "Enable CURL support" on \
SPANDSP "Enable Spandsp faxing support" off \
EXCHANGE "Enable Exchange calendar support" off \
- NEWG711 "Enable new G711 Codec" off \
- SRTP "Enable SecureRTP support" off \
- LUA "Enable LUA extensions support" off
+ NEWG711 "Enable new G711 Codec" off \
+ SRTP "Enable SecureRTP support" off \
+ LUA "Enable LUA extensions support" off \
+ LDAP "Enable Ldap support" off
+
+PORTSCOUT= limit:^1\.8\.
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -269,6 +272,15 @@ CONFIGURE_ARGS+= --without-lua
PLIST_SUB+= WITH_LUA="@comment "
.endif
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-ldap
+USE_OPENLDAP= yes
+PLIST_SUB+= WITH_LDAP=""
+.else
+CONFIGURE_ARGS+= --without-ldap
+PLIST_SUB+= WITH_LDAP="@comment "
+.endif
+
post-extract:
${FIND} ${WRKSRC} -name '*.d' -delete
diff --git a/net/asterisk/distinfo b/net/asterisk/distinfo
index b2f57315bdb9..2e3cf422ba4d 100644
--- a/net/asterisk/distinfo
+++ b/net/asterisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.8.10.1.tar.gz) = dcf9b524c5e2d0b704e86729fbd55684121af190f7f8d1b9f23b20d92f58c974
-SIZE (asterisk-1.8.10.1.tar.gz) = 25202101
+SHA256 (asterisk-1.8.11.0.tar.gz) = 1ca2f1f4a298c28033f56cec335e2a771bed37a248cc912812554319276cdff8
+SIZE (asterisk-1.8.11.0.tar.gz) = 25250286
diff --git a/net/asterisk/files/patch-configure b/net/asterisk/files/patch-configure
index f86962825478..905236035d9e 100644
--- a/net/asterisk/files/patch-configure
+++ b/net/asterisk/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-01-14 17:40:17.000000000 +0100
-+++ configure 2012-03-05 21:58:31.150486278 +0100
-@@ -4693,9 +4693,9 @@
+--- ./configure.orig 2012-03-30 07:05:42.000000000 -0400
++++ ./configure 2012-03-30 07:09:16.000000000 -0400
+@@ -4424,9 +4424,9 @@
astheaderdir='${includedir}/asterisk'
astlibdir='${libdir}/asterisk'
astmandir='${mandir}'
@@ -12,7 +12,7 @@
astkeydir='${astvarlibdir}'
astspooldir='${localstatedir}/spool/asterisk'
astlogdir='${localstatedir}/log/asterisk'
-@@ -4718,8 +4718,6 @@
+@@ -4449,8 +4449,6 @@
case "${host_os}" in
freebsd*)
ac_default_prefix=/usr/local
@@ -21,16 +21,16 @@
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -18136,6 +18134,8 @@
-
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+@@ -29482,6 +29480,8 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
-+ #include <sys/types.h>
-+ #include <sys/socket.h>
- #include <ifaddrs.h>
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <ifaddrs.h>
int
main ()
-@@ -25814,7 +25814,7 @@
+@@ -47592,7 +47592,7 @@
fi
@@ -38,4 +38,4 @@
+ PLATFORM_OPENH323="h323_${OPENH323_SUFFIX}"
if test "${HAS_OPENH323:-unset}" != "unset"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking OpenH323 installation validity" >&5
+ { $as_echo "$as_me:$LINENO: checking OpenH323 installation validity" >&5
diff --git a/net/asterisk/pkg-plist b/net/asterisk/pkg-plist
index 963d485c244b..0b919179a7f7 100644
--- a/net/asterisk/pkg-plist
+++ b/net/asterisk/pkg-plist
@@ -465,7 +465,7 @@ lib/asterisk/modules/res_ael_share.so
lib/asterisk/modules/res_clialiases.so
%%WITH_CURL%%lib/asterisk/modules/res_curl.so
%%WITH_CURL%%lib/asterisk/modules/res_config_curl.so
-%%WITH_H323%%lib/asterisk/modules/res_config_ldap.so
+%%WITH_LDAP%%lib/asterisk/modules/res_config_ldap.so
%%WITH_SQLITE%%lib/asterisk/modules/res_config_sqlite.so
lib/asterisk/modules/res_limit.so
lib/asterisk/modules/res_phoneprov.so