aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-10-20 18:07:15 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-10-20 18:07:15 +0000
commite6dfd4bf9e9b02ca4fcdac9cf5fb22afa033a158 (patch)
tree18cfddf782d695d1006f5d97e8d2240cb7d242b1 /net
parentec2ff6fbc0b5ac1052c5be5e04b59d0f3e428513 (diff)
Enable stage
Notes
Notes: svn path=/head/; revision=331042
Diffstat (limited to 'net')
-rw-r--r--net/minisapserver/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/net/minisapserver/Makefile b/net/minisapserver/Makefile
index 5ecf8f4f1865..bc718f8c5c0f 100644
--- a/net/minisapserver/Makefile
+++ b/net/minisapserver/Makefile
@@ -11,28 +11,21 @@ COMMENT= SAP and SLP announcement for the VLC Media Player
LICENSE= GPLv2
-USE_XZ= yes
-USES= iconv
+USE_XZ= yes
+USES= iconv
GNU_CONFIGURE= yes
-MAN1= sapserver.1
-PLIST_FILES= bin/sapserver etc/sap.cfg-dist
+PLIST_FILES= bin/sapserver etc/sap.cfg-dist man/man1/sapserver.1.gz
USE_RC_SUBR= sapserver
SUB_FILES= pkg-message
+
OPTIONS_DEFINE= SLP
SLP_DESC= "Enable SLP support via openslp"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSLP}
-LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
-CONFIGURE_ARGS+=--enable-slp
-.else
-CONFIGURE_ARGS+=--disable-slp
-.endif
+SLP_LIB_DEPENDS= libslp.so:${PORTSDIR}/net/openslp
+SLP_CONFIGURE_ENABLE= slp
post-patch:
@${REINPLACE_CMD} -e 's|$$(prefix)/share/man|${MANPREFIX}/man|; \
@@ -46,7 +39,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|a6->sin_len|a6->sin6_len|g' ${WRKSRC}/broadcast.cpp
@${CP} -f ${WRKSRC}/sap.cfg ${WRKSRC}/sap.cfg-dist
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>