aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-04-07 02:14:04 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-04-07 02:14:04 +0000
commitf9f6f82671ff7ec69b5416c7f92abb4b9b44f7f7 (patch)
tree1669ff5750260d0ac6123a275bc3158688e5d10b /net
parent86df16ea066dfa6b3fa34665fe9c5d39043cf86b (diff)
downloadports-f9f6f82671ff7ec69b5416c7f92abb4b9b44f7f7.tar.gz
ports-f9f6f82671ff7ec69b5416c7f92abb4b9b44f7f7.zip
New port: net/astron: Server Technology for Realtime Object Networking
Astron is an open-source, distributed server suite particularly well-suited for powering MMO games. The design is inspired by a similar unrelated project developed at the Disney Interactive Media Group, and used in-house from 2001 until 2013. The suite consists of many components, which handle separate tasks in order to distribute the workload of managing a multi-sharded game/application environment with many objects and clients. WWW: https://astron.github.io/astron
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/astron/Makefile33
-rw-r--r--net/astron/distinfo3
-rw-r--r--net/astron/files/patch-CMakeLists.txt11
-rw-r--r--net/astron/pkg-descr10
5 files changed, 58 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index df4624a5bc91..65f8d2893813 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -37,6 +37,7 @@
SUBDIR += asterisk13
SUBDIR += asterisk16
SUBDIR += asterisk18
+ SUBDIR += astron
SUBDIR += avahi
SUBDIR += avahi-app
SUBDIR += avahi-autoipd
diff --git a/net/astron/Makefile b/net/astron/Makefile
new file mode 100644
index 000000000000..6a24fa6867cc
--- /dev/null
+++ b/net/astron/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= astron
+PORTVERSION= 0.0.20200521
+CATEGORIES= net
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Server Technology for Realtime Object Networking
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKDIR}/LICENSE.md
+
+LIB_DEPENDS= libuv.so:devel/libuv \
+ libyaml-cpp.so:devel/yaml-cpp
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= Astron
+GH_PROJECT= ${GH_ACCOUNT}
+GH_TAGNAME= c8ba982
+
+PLIST_FILES= bin/astrond
+
+OPTIONS_DEFINE= SOCI
+OPTIONS_DEFAULT= SOCI
+
+SOCI_DESC= Database support via Soci
+SOCI_LIB_DEPENDS= libsoci_core.so:databases/soci
+
+.if !empty(VARIABLE:MSOCI)
+CMAKE_ARGS+= -DSOCI_FOUND=NO
+.endif
+
+.include <bsd.port.mk>
+
diff --git a/net/astron/distinfo b/net/astron/distinfo
new file mode 100644
index 000000000000..120d5843c576
--- /dev/null
+++ b/net/astron/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617748994
+SHA256 (Astron-Astron-0.0.20200521-c8ba982_GH0.tar.gz) = 7764536e01c3b91769410f1758fcb3b4f3766cb148804e8b4760a785e01c9b96
+SIZE (Astron-Astron-0.0.20200521-c8ba982_GH0.tar.gz) = 333009
diff --git a/net/astron/files/patch-CMakeLists.txt b/net/astron/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..dc67f43c69fa
--- /dev/null
+++ b/net/astron/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2021-04-06 22:45:16 UTC
++++ CMakeLists.txt
+@@ -92,7 +92,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Windows") ### Windows
+ list(APPEND EXTRA_LIBS wsock32 ws2_32)
+ endif()
+
+-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux") ### Linux requires pthreads
++if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD") ### Linux requires pthreads
+ list(APPEND EXTRA_LIBS pthread rt)
+ endif()
+
diff --git a/net/astron/pkg-descr b/net/astron/pkg-descr
new file mode 100644
index 000000000000..0d9d3f9f3b36
--- /dev/null
+++ b/net/astron/pkg-descr
@@ -0,0 +1,10 @@
+Astron is an open-source, distributed server suite particularly well-suited
+for powering MMO games. The design is inspired by a similar unrelated project
+developed at the Disney Interactive Media Group, and used in-house from 2001
+until 2013.
+
+The suite consists of many components, which handle separate tasks in order
+to distribute the workload of managing a multi-sharded game/application
+environment with many objects and clients.
+
+WWW: https://astron.github.io/astron