aboutsummaryrefslogtreecommitdiff
path: root/news/cnews
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-10-09 22:12:13 +0000
committerMark Linimon <linimon@FreeBSD.org>2012-10-09 22:12:13 +0000
commita8693b8dee82d3226a0bc0b337d3eb2085add552 (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /news/cnews
parent39890db4500948ba8648094ec8b290262a74d880 (diff)
downloadports-a8693b8dee82d3226a0bc0b337d3eb2085add552.tar.gz
ports-a8693b8dee82d3226a0bc0b337d3eb2085add552.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Notes
Notes: svn path=/head/; revision=305610
Diffstat (limited to 'news/cnews')
-rw-r--r--news/cnews/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index b2783306fb16..ef46c8607657 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -40,6 +40,8 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
MAKE_JOBS_UNSAFE= yes
+USE_GCC= any
+
DIST_SUBDIR= ${DISTNAME}
NO_WRKSUBDIR= yes
MAKEFILE= makefile