aboutsummaryrefslogtreecommitdiff
path: root/news/cnews
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-08-03 14:54:20 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-08-03 14:54:20 +0000
commitb412193f24751a306dff5489cfd87567286ea454 (patch)
treed41d223947aa203539adf76dfbef735ca5547771 /news/cnews
parent3a0a4614ab5d9335a6d29a1685845d6d4717ebc7 (diff)
downloadports-b412193f24751a306dff5489cfd87567286ea454.tar.gz
ports-b412193f24751a306dff5489cfd87567286ea454.zip
- rename patch files
- rename MACROS
Notes
Notes: svn path=/head/; revision=363906
Diffstat (limited to 'news/cnews')
-rw-r--r--news/cnews/Makefile12
-rw-r--r--news/cnews/files/patch-config.make62
-rw-r--r--news/cnews/files/patch-inject-makefile (renamed from news/cnews/files/patch-sendmail)17
-rw-r--r--news/cnews/files/patch-makeinc7
-rw-r--r--news/cnews/files/patch-quiz.def (renamed from news/cnews/files/patch-quiz-substitutions)81
-rw-r--r--news/cnews/files/patch-report17
-rw-r--r--news/cnews/files/patch-substitutions12
7 files changed, 104 insertions, 104 deletions
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 84b26e43257e..0b4685895791 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -44,10 +44,10 @@ DIST_SUBDIR= ${DISTNAME}
NO_WRKSUBDIR= yes
MAKEFILE= makefile
SUB_FILES= pkg-message
-MAN1= checknews.1cn inews.1cn postnews.1cn readnews.1cn
-MAN5= controlperm.5 news.5 newsctl.5 newsdb.5 newsoverview.5 \
+LMAN1= checknews.1cn inews.1cn postnews.1cn readnews.1cn
+LMAN5= controlperm.5 news.5 newsctl.5 newsdb.5 newsoverview.5 \
newssys.5
-MAN8= cnewsdo.8cn expire.8cn explode.8cn mergeactive.8 \
+LMAN8= cnewsdo.8cn expire.8cn explode.8cn mergeactive.8 \
mkhistory.8cn newsaux.8cn newsbatch.8cn newsmail.8cn \
newsmaint.8cn newsoverview.8 relaynews.8cn report.8cn \
rnews.8cn
@@ -121,9 +121,9 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/conf/config ${STAGEDIR}${NEWSBIN}/
cd ${WRKSRC} && ${MAKE} ${MAKE_ARGS} ${MAKE_FLAGS} ${MAKEFILE} install
cd ${WRKSRC} && ${MAKE} ${MAKE_ARGS} ${MAKE_FLAGS} ${MAKEFILE} ui readpostcheck
- cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${STAGEDIR}${PREFIX}/man/man1/
- cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN5} ${STAGEDIR}${PREFIX}/man/man5/
- cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN8} ${STAGEDIR}${PREFIX}/man/man8/
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${LMAN1} ${STAGEDIR}${PREFIX}/man/man1/
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${LMAN5} ${STAGEDIR}${PREFIX}/man/man5/
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${LMAN8} ${STAGEDIR}${PREFIX}/man/man8/
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/newsctl
cd ${WRKSRC} && ${INSTALL_DATA} ${NO_EG_FILES:S,^,*/,} \
diff --git a/news/cnews/files/patch-config.make b/news/cnews/files/patch-config.make
new file mode 100644
index 000000000000..56bc50eab2f1
--- /dev/null
+++ b/news/cnews/files/patch-config.make
@@ -0,0 +1,62 @@
+diff -urN ../pre-conf/include/config.make include/config.make
+--- ../pre-conf/include/config.make Thu Jan 1 01:00:00 1970
++++ include/config.make Mon Aug 2 20:36:19 1999
+@@ -0,0 +1,58 @@
++# make header file
++# pathname variables
++# =()<NEWSARTS=@<NEWSARTS>@>()=
++NEWSARTS=/var/news
++# =()<NEWSOV=@<NEWSOV>@>()=
++NEWSOV=/var/news/over.view
++# =()<NEWSBIN=@<NEWSBIN>@>()=
++NEWSBIN=/usr/local/news/cnewsbin
++# =()<NEWSCTL=@<NEWSCTL>@>()=
++NEWSCTL=/usr/local/news/lib
++# =()<NEWSCONFIG=@<NEWSCONFIG>@>()=
++NEWSCONFIG=/usr/local/news/cnewsbin/config
++
++# workaround for System V make bug
++SHELL=/bin/sh
++
++# directories where things go
++UIBIN=/usr/local/bin
++RBIN=/usr/local/news/cnewsbin/input
++
++# compilation stuff
++# LIB is for makefile dependencies, LIBS for cc invocations
++LIB=../libcnews.a
++LIBS=../libcnews.a
++CFLAGS+=$(MORECFLAGS) -I../include
++LDFLAGS=$(CFLAGS)
++LINTFLAGS=$(MORELINTFLAGS) -I../include
++
++# directories etc.
++CONF=../conf
++MAKE=make
++TO=$(CONF)/cpto
++IN=$(CONF)/cmpto $(CMPOPT)
++CF=$(CONF)/checkfile $(CMPOPT)
++MKDIR=$(CONF)/mkdirs
++MX=chmod +x
++UPDATE=$(CONF)/update.ran ../libcnews.a
++LIBCMP=$(CONF)/libcmp ../libcnews.a
++
++# misc configuration bits
++SPACEFOR=statfs
++DOSPACEFOR=dospacefor
++QUEUELEN=tay
++UID=news
++GID=news
++SIZE=big
++DBZ=libdbz
++STDIO=sysstdio
++SERVER=
++REPORTTO=newsmaster
++URGENTTO=newscrisis
++
++# things for testing
++HERE=. ../conf/rsetup ;
++
++# fake files needed
++HFAKE= sys/timeb.h
++OFAKE= fgetline.o fsync.o
diff --git a/news/cnews/files/patch-sendmail b/news/cnews/files/patch-inject-makefile
index 4fac97680a8a..f48803358108 100644
--- a/news/cnews/files/patch-sendmail
+++ b/news/cnews/files/patch-inject-makefile
@@ -1,20 +1,3 @@
-*** util/report.old Thu Sep 15 13:24:57 1994
---- util/report Fri Sep 30 16:57:05 1994
-***************
-*** 65,70 ****
- else
- cat $r
- fi
-! ) | mail $args # some sites might want "/usr/lib/sendmail -t" instead
-
- # and the trap handles the exit status
---- 65,70 ----
- else
- cat $r
- fi
-! ) | /usr/sbin/sendmail -t $args # some sites might want "mail" instead
-
- # and the trap handles the exit status
*** inject/makefile.ORIG Thu Dec 29 00:30:01 1994
--- inject/makefile Thu Feb 23 11:21:46 1995
***************
diff --git a/news/cnews/files/patch-makeinc b/news/cnews/files/patch-makeinc
new file mode 100644
index 000000000000..722acecbb905
--- /dev/null
+++ b/news/cnews/files/patch-makeinc
@@ -0,0 +1,7 @@
+diff -urN ../pre-conf/conf/makeinc conf/makeinc
+--- ../pre-conf/conf/makeinc Thu Jan 1 01:00:00 1970
++++ conf/makeinc Mon Aug 2 20:32:23 1999
+@@ -0,0 +1,3 @@
++# makefile substitutions file
++# how to include ../include/config.make
++INCLUDE .include "../include/config.make"
diff --git a/news/cnews/files/patch-quiz-substitutions b/news/cnews/files/patch-quiz.def
index 00512597b351..74f9274aa3a0 100644
--- a/news/cnews/files/patch-quiz-substitutions
+++ b/news/cnews/files/patch-quiz.def
@@ -1,10 +1,3 @@
-diff -urN ../pre-conf/conf/makeinc conf/makeinc
---- ../pre-conf/conf/makeinc Thu Jan 1 01:00:00 1970
-+++ conf/makeinc Mon Aug 2 20:32:23 1999
-@@ -0,0 +1,3 @@
-+# makefile substitutions file
-+# how to include ../include/config.make
-+INCLUDE .include "../include/config.make"
diff -urN ../pre-conf/conf/quiz.def conf/quiz.def
--- ../pre-conf/conf/quiz.def Thu Jan 1 01:00:00 1970
+++ conf/quiz.def Mon Aug 2 20:36:19 1999
@@ -77,77 +70,3 @@ diff -urN ../pre-conf/conf/quiz.def conf/quiz.def
+faststrchr="no"
+# These answers are interdependent; do not edit this file!
+sftype="c"
-diff -urN ../pre-conf/conf/substitutions conf/substitutions
---- ../pre-conf/conf/substitutions Thu Jan 1 01:00:00 1970
-+++ conf/substitutions Mon Aug 2 20:36:19 1999
-@@ -0,0 +1,8 @@
-+# general substitutions file
-+NEWSBIN /usr/local/news/cnewsbin
-+NEWSCTL /usr/local/news/lib
-+NEWSARTS /var/news
-+NEWSOV /var/news/over.view
-+NEWSPATH /bin:/usr/bin:/usr/local/bin
-+NEWSUMASK 022
-+NEWSCONFIG /usr/local/news/cnewsbin/config
-diff -urN ../pre-conf/include/config.make include/config.make
---- ../pre-conf/include/config.make Thu Jan 1 01:00:00 1970
-+++ include/config.make Mon Aug 2 20:36:19 1999
-@@ -0,0 +1,58 @@
-+# make header file
-+# pathname variables
-+# =()<NEWSARTS=@<NEWSARTS>@>()=
-+NEWSARTS=/var/news
-+# =()<NEWSOV=@<NEWSOV>@>()=
-+NEWSOV=/var/news/over.view
-+# =()<NEWSBIN=@<NEWSBIN>@>()=
-+NEWSBIN=/usr/local/news/cnewsbin
-+# =()<NEWSCTL=@<NEWSCTL>@>()=
-+NEWSCTL=/usr/local/news/lib
-+# =()<NEWSCONFIG=@<NEWSCONFIG>@>()=
-+NEWSCONFIG=/usr/local/news/cnewsbin/config
-+
-+# workaround for System V make bug
-+SHELL=/bin/sh
-+
-+# directories where things go
-+UIBIN=/usr/local/bin
-+RBIN=/usr/local/news/cnewsbin/input
-+
-+# compilation stuff
-+# LIB is for makefile dependencies, LIBS for cc invocations
-+LIB=../libcnews.a
-+LIBS=../libcnews.a
-+CFLAGS+=$(MORECFLAGS) -I../include
-+LDFLAGS=$(CFLAGS)
-+LINTFLAGS=$(MORELINTFLAGS) -I../include
-+
-+# directories etc.
-+CONF=../conf
-+MAKE=make
-+TO=$(CONF)/cpto
-+IN=$(CONF)/cmpto $(CMPOPT)
-+CF=$(CONF)/checkfile $(CMPOPT)
-+MKDIR=$(CONF)/mkdirs
-+MX=chmod +x
-+UPDATE=$(CONF)/update.ran ../libcnews.a
-+LIBCMP=$(CONF)/libcmp ../libcnews.a
-+
-+# misc configuration bits
-+SPACEFOR=statfs
-+DOSPACEFOR=dospacefor
-+QUEUELEN=tay
-+UID=news
-+GID=news
-+SIZE=big
-+DBZ=libdbz
-+STDIO=sysstdio
-+SERVER=
-+REPORTTO=newsmaster
-+URGENTTO=newscrisis
-+
-+# things for testing
-+HERE=. ../conf/rsetup ;
-+
-+# fake files needed
-+HFAKE= sys/timeb.h
-+OFAKE= fgetline.o fsync.o
diff --git a/news/cnews/files/patch-report b/news/cnews/files/patch-report
new file mode 100644
index 000000000000..04f8984bba4f
--- /dev/null
+++ b/news/cnews/files/patch-report
@@ -0,0 +1,17 @@
+*** util/report.old Thu Sep 15 13:24:57 1994
+--- util/report Fri Sep 30 16:57:05 1994
+***************
+*** 65,70 ****
+ else
+ cat $r
+ fi
+! ) | mail $args # some sites might want "/usr/lib/sendmail -t" instead
+
+ # and the trap handles the exit status
+--- 65,70 ----
+ else
+ cat $r
+ fi
+! ) | /usr/sbin/sendmail -t $args # some sites might want "mail" instead
+
+ # and the trap handles the exit status
diff --git a/news/cnews/files/patch-substitutions b/news/cnews/files/patch-substitutions
new file mode 100644
index 000000000000..a22a60de1c4e
--- /dev/null
+++ b/news/cnews/files/patch-substitutions
@@ -0,0 +1,12 @@
+diff -urN ../pre-conf/conf/substitutions conf/substitutions
+--- ../pre-conf/conf/substitutions Thu Jan 1 01:00:00 1970
++++ conf/substitutions Mon Aug 2 20:36:19 1999
+@@ -0,0 +1,8 @@
++# general substitutions file
++NEWSBIN /usr/local/news/cnewsbin
++NEWSCTL /usr/local/news/lib
++NEWSARTS /var/news
++NEWSOV /var/news/over.view
++NEWSPATH /bin:/usr/bin:/usr/local/bin
++NEWSUMASK 022
++NEWSCONFIG /usr/local/news/cnewsbin/config