aboutsummaryrefslogtreecommitdiff
path: root/news/cnews
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2015-08-01 05:32:19 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2015-08-01 05:32:19 +0000
commitd8f99b235730ca5bb388dfec62bc1acc5401560e (patch)
tree6acdb3647c113ed0ae21a4a0328692f608e23e52 /news/cnews
parentbb9ec6ec733cd2c6d8a5962a51758514133ee27e (diff)
downloadports-d8f99b235730ca5bb388dfec62bc1acc5401560e.tar.gz
ports-d8f99b235730ca5bb388dfec62bc1acc5401560e.zip
- support disk with more than 4G blocks free
Notes
Notes: svn path=/head/; revision=393387
Diffstat (limited to 'news/cnews')
-rw-r--r--news/cnews/Makefile2
-rw-r--r--news/cnews/files/patch-dostatfs.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 930cb5ce0849..266d72c16835 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cnews
PORTVERSION= cr.g
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= news
MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/c-news/ \
ftp://ftp.funet.fi/pub/unix/news/cnews/ \
diff --git a/news/cnews/files/patch-dostatfs.c b/news/cnews/files/patch-dostatfs.c
new file mode 100644
index 000000000000..47ffd8f27c09
--- /dev/null
+++ b/news/cnews/files/patch-dostatfs.c
@@ -0,0 +1,11 @@
+--- util/dostatfs.c.orig 1995-04-28 02:51:39.000000000 +0200
++++ util/dostatfs.c 2015-06-10 06:28:42.000000000 +0200
+@@ -77,7 +77,7 @@
+ long bperi;
+ {
+ struct statfs info;
+- register long n;
++ register long long n;
+ # define LOTS 10000
+ register long iperfile = filesize/bperi + 1;
+