aboutsummaryrefslogtreecommitdiff
path: root/news/diablo
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-03-29 17:28:56 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-03-29 17:28:56 +0000
commit2a58169b19854c36ac6d019a7c3954879ded21d5 (patch)
tree1b1cbaaa8a1ad8875cf82eefa0bfb6687b917752 /news/diablo
parente08194692d8105d8bde7eed78560a26d65c7084b (diff)
downloadports-2a58169b19854c36ac6d019a7c3954879ded21d5.tar.gz
ports-2a58169b19854c36ac6d019a7c3954879ded21d5.zip
Add stage support to news, and improve correctness.
I am not touching the husky ports with a 10 foot pole. atp: stage, improve pkg-message crashmail: stage diablo: too wacky to stage, but convert WITH_* to OPTIONS, unmute commands that shouldn't be muted, use :MDOCS fidogate-ds: stage, OPTIONS, treat examples as EXAMPLES, not DOCS, handle /var/* in the plist properly golded+: stage, OPTIONS, protect examples behind %%PORTEXAMPLES%% nntpbtr: this was an unbelievably PITA stage, add missing prototypes, add missing return types, rename patch files to what they actually patch nntpcache: stage support, required lots of Makefile.in patching, call submakes correctly, handle config files properly nzbperl: stage, use OPTIONS, remove obsolete pkg-message papercut: stage, handle config file properly py-pynzb: stage, use OPTIONS helper to avoid bsd.port.options.mk inclusion s-news: stage slrnconf: stage slrnface: stage, install required files to datadir, not examplesdir, generate proper pkg-message sn: stage
Notes
Notes: svn path=/head/; revision=349572
Diffstat (limited to 'news/diablo')
-rw-r--r--news/diablo/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/news/diablo/Makefile b/news/diablo/Makefile
index 0439ba85a9f7..448e6217a99e 100644
--- a/news/diablo/Makefile
+++ b/news/diablo/Makefile
@@ -22,29 +22,33 @@ MAN8= dicmd.8 didump.8 dexpireover.8 dfeedinfo.8 dgrpctl.8 \
PORTDOCS= COPYRIGHT INSTALL README.READER README.SERVER RELEASE_NOTES
NO_STAGE= yes
+
+OPTIONS_DEFINE= DES DOCS
+DES_DESC= DES encryption support
+
+.include <bsd.port.options.mk>
+
post-patch:
- @${CP} ${SCRIPTDIR}/diablo.sh-sample ${WRKDIR}
- @${REINPLACE_CMD} -E 's|%%PREFIX%%|${PREFIX}|g ;\
+ ${CP} ${SCRIPTDIR}/diablo.sh-sample ${WRKDIR}
+ ${REINPLACE_CMD} -E 's|%%PREFIX%%|${PREFIX}|g ;\
s|-g -O.?|${CFLAGS}| ; s|g?cc|${CC}|' \
${WRKDIR}/diablo.sh-sample ${WRKSRC}/XMakefile.inc
# Fix for GCC 4.2
- @${REINPLACE_CMD} -e 's|VServerConfig\[\]|*VServerConfig|' \
+ ${REINPLACE_CMD} -e 's|VServerConfig\[\]|*VServerConfig|' \
${WRKSRC}/dreaderd/main.c
-.if !defined(WITH_DES)
- @${REINPLACE_CMD} -e 's| -ldes||g' ${WRKSRC}/XMakefile.inc
+.if empty(PORT_OPTIONS:MDES)
+ ${REINPLACE_CMD} -e 's| -ldes||g' ${WRKSRC}/XMakefile.inc
.endif
do-build:
- @cd ${WRKSRC} && xmake all
-
-pre-install:
- ${INSTALL} -d ${DOCDIR} ${PREFIX}/news ${PREFIX}/news/dbin
+ (cd ${WRKSRC} && xmake all)
do-install:
- @cd ${WRKSRC} && xmake install
+ ${MKDIR} ${PREFIX}/news/dbin
+ (cd ${WRKSRC} && xmake install)
${INSTALL_SCRIPT} ${WRKDIR}/diablo.sh-sample ${PREFIX}/etc/rc.d
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}